Results 1 to 3 of 3

Thread: Akonadi and booting stuff (mostly Akonadi)

  1. #1

    Default Akonadi and booting stuff (mostly Akonadi)

    I've recently switched back to OpenSUSE (from Neon) and am having a few problems which I think might be related to one another.

    First, when I boot Akonadi seems to break for a while. I don't get new emails for a long while (half an hour? a full hour?) after I boot. I should really try to time it, but it seems like Akonadi isn't working and then eventually restarts itself and I finally get my mail (a guess on my part). All accounts in Kmail are set to check at five minute intervals.

    Something sorta similar happens when I wake from suspend, except instead of restarting Kmail just sets all of my accounts to offline and I have to manually set them online again.

    Automatic checking for software updates is also not happening, I have to do that manually. I thought that perhaps this was related to the first thing, because my computer is slow to get online at boot - after I give Kwallet my password the wifi connects but the VPN complains that it's missing secrets and disconnects. Then the whole thing tries again (automatically) and this time both connect and everything's fine. This is weird, but it kinda seems like a timeout issue and maybe this is when update tries (and fails) to connect.

    Finally, Akonadi decided out of the blue that it needed to write and delete some files over and over and over again today, for hours. I made a gif:

    https://gfycat.com/ShadyYellowBangeltiger

    This is probably an Akonadi-specific bug, so maybe the KDE forum would be a better place to ask about it, but I never had this problem in Neon and Neon uses a more recent version of Akonadi (18.04.3 vs 17.12.3). So I added the "Updated KDE Applications Only" repo, thinking that I could get a newer version that way, but I'm only seeing 18.04.3 stuff for debugging and development. I'm not seeing anything that I can really use. Is there a good way to do that?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Akonadi and booting stuff (mostly Akonadi)

    If you did the OS switch via some upgrade method you probably have conflicting packages and configurations.Best to do a clean install when moving backward

  3. #3

    Default Re: Akonadi and booting stuff (mostly Akonadi)

    That's plausible. I did a clean install, but then I copied over my configuration files.

    Given that I don't want to get rid of those files and configure from scratch, is there some good way to upgrade to to the newer version of Akonadi? And maybe the software updater? I don't know what's up with that.

    I timed how long it took to get emails this morning: one hour and three minutes after booting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •