Results 1 to 5 of 5

Thread: Latest LTS Qt 5.9 and KDE 5.12

  1. #1

    Default Latest LTS Qt 5.9 and KDE 5.12

    Hi,


    My first question is: when is Leap 15 expected to get the latest LTS version of Qt 5.9 and KDE 5.12 ?

    The current version of KDE is 5.12.5 and there is the latest LTS version 5.12.6 which I could successfully test here from the additional repository.

    However, regarding Qt 5.9, the current version is 5.9.4 and there is the latest version 5.9.6. I'm getting unsolvable dependency issues when trying to install version 5.9.6 from the additional repository. Both stock KDE 5.12.5 and latest LTS KDE 5.12.6 are only accepting Qt 5.9.4 as required package version.

    My second question is: is there a way to test latest LTS Qt 5.9.6 on my Leap 15 (hopefully along with KDE 5.12.6)?


    Thanks in advance

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,983

    Default AW: Latest LTS Qt 5.9 and KDE 5.12


  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Latest LTS Qt 5.9 and KDE 5.12

    Quote Originally Posted by ghostharley View Post
    My first question is: when is Leap 15 expected to get the latest LTS version of Qt 5.9 and KDE 5.12 ?
    I may misunderstand your question, but the versions of the stable openSUSE releases (like Leap 15.0) will not get newer versions of packages during their lifetime (in the OSS repository). That is why they are called "stable". Newer packages may be included in the next version when they have passed satisfactory testing in that version before it is frozen.

    This is contrary to Tumbleweed where newer versions of packages will be in the next snapshot (also after testing of course).
    Henk van Velden

  4. #4

    Default Re: Latest LTS Qt 5.9 and KDE 5.12

    Quote Originally Posted by Sauerland View Post
    In fact, I was able to update KDE 5.12 from that one. I have tested KDE 5.12.6 successfully on my Leap 15.
    The issue is with installing Qt 5.9.6 and its dependency issues in relation to both KDE 5.12.5 (OSS repository) and KDE 5.12.6 (the repository you mentioned).


    Quote Originally Posted by hcvv View Post
    I may misunderstand your question, but the versions of the stable openSUSE releases (like Leap 15.0) will not get newer versions of packages during their lifetime (in the OSS repository). That is why they are called "stable". Newer packages may be included in the next version when they have passed satisfactory testing in that version before it is frozen.

    This is contrary to Tumbleweed where newer versions of packages will be in the next snapshot (also after testing of course).
    I see. Leap 15.1 then. Thank you



    Regarding the dependency issues in http://download.opensuse.org/reposit...USE_Leap_15.0/, I still would like to test latest LTS Qt 5.9 (currently 5.9.6) from that one.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,641
    Blog Entries
    3

    Default Re: Latest LTS Qt 5.9 and KDE 5.12

    Quote Originally Posted by ghostharley View Post
    I see. Leap 15.1 then. Thank you
    I just tested Leap 15.1 Alpha. Currently it is using KDE 5.12.5 and QT 5.9.4. However, this is very preliminary, and those versions are likely to change before it is released.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •