Results 1 to 4 of 4

Thread: Rygel (DLNA server) not showing all files

  1. #1
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Rygel (DLNA server) not showing all files

    Hello,

    I'm using Rygel 0.36.1 on my LEAP 15 based server to serve files over DLNA but not all files are showing up on my phone with BubbleUPNP. The cover images show up but not the movies themselves, is there a way to make them show up?
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  2. #2
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: Rygel (DLNA server) not showing all files

    I forgot to mention, this doens't hold true for all video files. Some show up and some don't I thought it might be a file extension thing but that doesn't seem to be the case as some .mkv's show up whilsts others don't. Could it come down to the codecs?
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  3. #3
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: Rygel (DLNA server) not showing all files

    Reading elsewhere on the internet "The problem with DLNA is that the client will only show you files it thinks it can handle, and the server will only show you files the client requests." I figured I'd install VLC and use its DLNA browsing option, a folder with 3 movies in it only shows 2 of them. Browsing the same folder, with the same VLC app but over SAMBA I can play the file fine so it can't be a client codec.

    How do I find the log of rygel? There's none in /var/log
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  4. #4
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: Rygel (DLNA server) not showing all files

    Figuring the client side codecs aren't at fault I tried my hand at installing serverside codecs so I installed the proprietary codecs for gstreamer and can now play the videos on the server but VLC on my phone is still not seeing some files. Some googling found me "101 secret rygel tips" which mentions that Rygel uses gst-discoverer to extract metadata from video files. Using gst-discoverer myself gst-discoverer-1.0 /path/to/video_file yields me this on a file that does show up fine:
    Code:
    Topology:
      container: Audio Video Interleave (AVI)
        audio: AC-3 (ATSC A/52)
        video: MPEG-4 Video (Advanced Simple Profile)
    
    Properties:
      Duration: 1:37:53.200666666
      Seekable: yes
      Tags: 
          video codec: MPEG-4
          container format: AVI
          audio codec: AC-3 audio
          bitrate: 384000
    and this on 2 files that don't show up:
    Code:
    Topology:                                                                                                                                                                               
      container: Quicktime
        audio: MPEG-4 AAC                                                 
        video: H.264 (High Profile)        
    
    Properties:                                                                    
      Duration: 1:40:02.203333333                                               
      Seekable: yes                                                                                                                                                                                                                                                                
      Tags:                                                                     
          video codec: H.264 / AVC                                               
          maximum bitrate: 7422200                                               
          bitrate: 948472                                                        
          datetime: 2017-04-20T18:24:26Z                                       
          container format: ISO MP4/M4A                                         
          audio codec: MPEG-4 AAC audio
    Code:
    Topology:
      container: Quicktime
        audio: MPEG-4 AAC
        video: H.264 (High Profile)
    
    Properties:
      Duration: 2:09:16.917000000
      Seekable: yes
      Tags: 
          video codec: H.264 / AVC
          bitrate: 2050105
          encoder: Lavf57.48.101
          container format: ISO MP4/M4A
          audio codec: MPEG-4 AAC audio
          maximum bitrate: 117117
    So I'm guessing that I'll somehow have to make Rygel serve up H.264 files, I don't know how to do this as the computer rygel is installed on has the codecs installed and can play H.264 files.
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •