Results 1 to 3 of 3

Thread: Trailing windows when dragging in KDE

  1. #1

    Default Trailing windows when dragging in KDE

    Whenever dragging windows around, there are very obvious trails that follow, which overall gives it a very non-smooth feeling. I have the relevant NVIDIA drivers installed from the repository:

    Code:
    nvidia-computeG04, nvidia-gfxG04-kmp-default, nvidia-glG04,x11-video-nvidiaG04
    as specified from the SDB. Not sure what could be the actual cause of this, though, as otherwise everything else graphically is fine.

  2. #2
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    326

    Default Re: Trailing windows when dragging in KDE

    I no longer have an nvidia laptop, but when I di, I seem to recall there was some grub switch I had to use to prevent tearing. Maybe "nvidia-drm.modeset=1" which you can add to kernel parameters line through YaST -> bootloader. If that's not exactly right, you might try googling "nvidia tearing modeset" - I seem to recall there's a way to do it via gru and another way via config file, but the syntax is a little different between them.

  3. #3

    Default Re: Trailing windows when dragging in KDE

    Yes, the modeset option looked promising but (maybe I didn't enable it correctly?) it didn't make any difference.

    I stumbled upon the compositor options for desktop effects, and fiddled with the settings there - for now it seems to be better, but I guess time will tell. Thanks for the suggestion!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •