Results 1 to 5 of 5

Thread: Completely disable akonadi

  1. #1

    Default Completely disable akonadi

    I'm using Plasma Desktop, but for my needs I prefer to use Evolution instead of Kontact as a PIM solution.

    I'm trying to find out how to completely prevent akonadi to start at boot; as far as I can understand, it is started by any application that rely on it, but I'm unable to exactly pinpoint by what application/service/widget/setting it is activated.

    Like I said, I switched from Kontact to Evolution, I'm not using the default digital clock widget ("Event Calendar" plasmoid in its place, that AFAIK connects directly to Google Calendar), and I have disable the Krunner extensions that seemed to use it as well.

    Do you have any other suggestion? Is there some log where I can possibly find out this kind of information (what has started akonadi)?

  2. #2
    Join Date
    Dec 2008
    Posts
    45

    Default Re: Completely disable akonadi

    I just discovered this: https://techbase.kde.org/KDE_PIM/Akonadi

    How do I completely disable Akonadi startup?

    Akonadi will be automatically started by any Akonadi-enabled application . If you don't want to start Akonadi at all, you can't use any of these applications (see the list of Akonadi-enabled applications). Also note, that some Plasma widgets, such as the "Digital Clock" applet uses Akonadi.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,048
    Blog Entries
    14

    Default Re: Completely disable akonadi

    -In ~/.config/akonadi/akonadiserverrc change StartServer=true to StartServer=false
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Completely disable akonadi

    Quote Originally Posted by Knurpht View Post
    -In ~/.config/akonadi/akonadiserverrc change StartServer=true to StartServer=false
    I was unaware of this setting, it was exactly what I needed.

    Danke schön!

  5. #5
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    326

    Default Re: Completely disable akonadi

    From Software Manager in YaST, remove akregator, kaddressmanager, kmaile, knotes, kontact, and korganizer; then return mark them taboo. In settings for your application menu, whichever one you use, make sure that "expand search to...emails" is not checked. The clock widget (configured by default in panel next to the tray) won't start akonadi unless you enable the holiday or astronomical events plugin. If you place a system monitor widget someplace handy, you'll see that you don't go over about 600MB with KDE alone, evidence that akonadi hasn't started. My system does not seem to have a "~/.config/akonadi/" folder. -GEF

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •