Results 1 to 4 of 4

Thread: DisplayLink and EVDI stopped working when I updated to LEAP 15

  1. #1
    Join Date
    Jul 2008
    Location
    Pittsburgh, PA
    Posts
    32

    Default DisplayLink and EVDI stopped working when I updated to LEAP 15

    I had originally gotten DisplayLink to run successfully on OpenSUSE 42.3 with a DisplayLink adapter and two external monitors, but after I upgraded to Leap 15.0 today, I can't seem to get it to find my other two monitors. I did see that there was a DisplayLink option in the build service, which I installed, but when I went to see if the service was running, it fails like this:
    Code:
    sudo service displaylink status
    ● displaylink.service - DisplayLink Manager Service
       Loaded: loaded (/usr/lib/systemd/system/displaylink.service; static; vendor preset: disabled)
       Active: activating (auto-restart) (Result: exit-code) since Mon 2018-07-23 17:22:16 EDT; 1s ago
      Process: 27855 ExecStartPre=/sbin/modprobe evdi (code=exited, status=1/FAILURE)
    
    Jul 23 17:22:16 Quicksilver systemd[1]: displaylink.service: Unit entered failed state.
    Jul 23 17:22:16 Quicksilver systemd[1]: displaylink.service: Failed with result 'exit-code'.
    I did try to find the EVDI software, which appears to be there but did not offer an option for Leap 15.0. I tried to get the original source for EVDI, but this reached the end of my limit of my knowledge as it doesn't appear to work for OpenSUSE 15.0. What should I be doing to get my extra monitors back?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,669
    Blog Entries
    15

    Default Re: DisplayLink and EVDI stopped working when I updated to LEAP 15

    Hi
    I've updated the evdi kernel module and built for Leap 15.0;
    https://build.opensuse.org/package/s...s:TESTING/evdi
    https://download.opensuse.org/reposi...p_15.0/x86_64/

    For the actual displaylink software, you need to download and run the installer... or just extract and manually run the driver to see if it starts working.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jul 2008
    Location
    Pittsburgh, PA
    Posts
    32

    Thumbs up Re: DisplayLink and EVDI stopped working when I updated to LEAP 15

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I've updated the evdi kernel module and built for Leap 15.0;
    https://build.opensuse.org/package/s...s:TESTING/evdi
    https://download.opensuse.org/reposi...p_15.0/x86_64/

    For the actual displaylink software, you need to download and run the installer... or just extract and manually run the driver to see if it starts working.
    Mister Malcom Lewis, sir, Thank you!!!

    I have all three of my desktops and am working wonderfully. I saw your name when working on this many times, thank you for answering my post and fixing my problem so quickly!

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,669
    Blog Entries
    15

    Default Re: DisplayLink and EVDI stopped working when I updated to LEAP 15

    Quote Originally Posted by LexPendragon View Post
    Mister Malcom Lewis, sir, Thank you!!!

    I have all three of my desktops and am working wonderfully. I saw your name when working on this many times, thank you for answering my post and fixing my problem so quickly!
    Hi
    Your welcome

    I see the kernel has updated, so grab this kmp and install;
    https://download.opensuse.org/reposi...Update/x86_64/
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •