Results 1 to 3 of 3

Thread: OBS+KIWI unresolvable

  1. #1

    Default OBS+KIWI unresolvable

    Hi all, I try to build custom image branched from openSUSE-Argon with kiwi in OBS, and have unresolvable error
    Code:
    python3-kiwi conflicts with systemd-mini, systemd-mini conflicts with python3-kiwi

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    24,954
    Blog Entries
    15

    Default Re: OBS+KIWI unresolvable

    Quote Originally Posted by GNorth View Post
    Hi all, I try to build custom image branched from openSUSE-Argon with kiwi in OBS, and have unresolvable error
    Code:
    python3-kiwi conflicts with systemd-mini, systemd-mini conflicts with python3-kiwi
    Hi
    You need to set a Prefer option in the project configuration, but easier to copy the source one over into your project;

    https://build.opensuse.org/project/prjconf/KDE:Medias
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: OBS+KIWI unresolvable

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You need to set a Prefer option in the project configuration, but easier to copy the source one over into your project;

    https://build.opensuse.org/project/prjconf/KDE:Medias
    Thx solved, but i have next problem with config.sh.
    Code:
    [  296s] [ DEBUG   ]: 15:01:00 | warning: failed to load external entity "/makezyppercmds.xsl"
    [  296s] [ DEBUG   ]: 15:01:00 | cannot parse /makezyppercmds.xsl
    [  296s] [ DEBUG   ]: 15:01:00 | + eval
    [  296s] [ DEBUG   ]: 15:01:00 | + xsltproc /changecontrolxml.xsl /etc/YaST2/control.xml
    [  296s] [ DEBUG   ]: 15:01:00 | warning: failed to load external entity "/changecontrolxml.xsl"
    [  296s] [ DEBUG   ]: 15:01:00 | cannot parse /changecontrolxml.xsl
    [  296s] [ DEBUG   ]: 15:01:00 | --------------out stop--------------
    [  296s] [ DEBUG   ]: 15:01:00 | --------------err start-------------
    [  296s] [ DEBUG   ]: 15:01:00 | + exec
    [  296s] + tee /var/log/config.log
    [  296s] + exec
    [  296s] 
    [  296s] [ DEBUG   ]: 15:01:00 | --------------err stop--------------
    [  296s] [ ERROR   ]: 15:01:00 | KiwiScriptFailed: config.sh failed: + exec
    [  296s] + tee /var/log/config.log
    [  296s] + exec
    but in Argon it works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •