Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: installed leap 15 and after that no menu option to boot windows 7

  1. #21
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,366
    Blog Entries
    3

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by tapassaini View Post
    The above partition #8 is the one I created for /boot/efi while installing opensuse leap 15
    Also I was mentioning about above partition #1 in my post #6
    It is weird (and that's why I asked).

    Your disk is using legacy MBR partitioning rather than GPT partitioning. This is unusual for a system that is booting with UEFI.

    In any case, here is how I would proceed.

    Step 1: Make sure that secure-boot is disabled in BIOS settings. You may have already checked this.

    Step 2: As root, edit the file "/etc/default/grub". Check to see if there is a line:
    Code:
    GRUB_USE_LINUXEFI="true"
    (or similar -- the quoting could be different). If there is such a line, then change that "true" to "false" and save the changed file.

    Step 3: Run Yast bootloader.
    There should be a box labeled "Boot loader" which says GRUB2 for EFI.
    Change that to "GRUB2".



    The remainder of the screen should then change. And, with those changes:
    Check the box: Boot from Master Boot Record.
    Uncheck all of the other checked boxes.

    Click OK.

    NOTE: If what you see on the screen does not match what I am describing, then click "Cancel" instead of OK, and abort Yast bootloader (and tell us what you see that is different).

    Then reboot. There should now be a Windows entry in the menu, but it probably doesn't work. That's because your system will probably still be using UEFI booting instead of legacy booting. You can check that by booting into openSUSE (which still should work) and running:
    efibootmgr -v

    I'll stop here for now until I get feedback on what is happening. You probably then have to delete the UEFI boot entry, so that it will revert to MBR booting. We can get to that step later.
    openSUSE Leap 15.1; KDE Plasma 5;

  2. #22
    Join Date
    Aug 2014
    Location
    India
    Posts
    29

    Unhappy Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by nrickert;2874834
    Step 1: Make sure that secure-boot is disabled in BIOS settings. You may have already checked this.

    Step 2: As root, edit the file "/etc/default/grub". Check to see if there is a line:
    [code
    GRUB_USE_LINUXEFI="true"[/code]
    (or similar -- the quoting could be different). If there is such a line, then change that "true" to "false" and save the changed file.

    Step 3: Run Yast bootloader.
    There should be a box labeled "Boot loader" which says GRUB2 for EFI.
    Change that to "GRUB2".



    The remainder of the screen should then change. And, with those changes:
    Check the box: Boot from Master Boot Record.
    Uncheck all of the other checked boxes.

    Click OK.

    NOTE: If what you see on the screen does not match what I am describing, then click "Cancel" instead of OK, and abort Yast bootloader (and tell us what you see that is different).
    I followed all step the way you told.....When I rebooted,the fancy colorful grub boot menu changed to BLACK & WHITE selection list. But windows is still not there in option

    Quote Originally Posted by nrickert View Post
    You can check that by booting into openSUSE (which still should work) and running:
    efibootmgr -v
    The results of efibootmgr after reboot
    Code:
    linux-1hcj:/home/ubiroute # efibootmgr -v
    BootCurrent: 0000
    Timeout: 0 seconds
    BootOrder: 0001,3000,2001,2002,2003
    Boot0000* EFI HDD Device        PciRoot(0x0)/Pci(0x1f,0x2)/EDD10(0x2a010400)/HD(3,MBR,0x46047eb5,0xc57a800,0x2ddd7800)/HD(4,MBR,0x0,0x12c94800,0xfa000)RC
    Boot0001* opensuse-secureboot   HD(3,MBR,0x46047eb5,0xc57a800,0x2ddd7800)/HD(4,MBR,0x0,0x12c94800,0xfa000)/File(\EFI\opensuse\shim.efi)
    Boot0002* Notebook Hard Drive   BBS(HD,▒�,0x0).......................................................................
    Boot2001* USB Drive (UEFI)      RC
    Boot3000* Internal Hard Disk or Solid State Disk        RC
    linux-1hcj:/home/ubiroute #
    Windows is still not there in boot option

  3. #23
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,366
    Blog Entries
    3

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by tapassaini View Post
    I followed all step the way you told.....When I rebooted,the fancy colorful grub boot menu changed to BLACK & WHITE selection list. But windows is still not there in option
    I didn't expect that Black&White menu. But that's not a serious issue. I did expect that you would still boot in UEFI mode, and that seems to be what has happened. Perhaps you have to boot to non-UEFI and then update the boot menu before Windows will show.

    This is where things get tricky. It looks as if we have to disable all UEFI booting options, in order to force a non-UEFI boot. And there is a risk that this might make your system unbootable. I'll get to that possibility shortly.

    As root:
    Code:
    cd /boot/efi/EFI
    ls
    The output of "ls" probably shows two directories. One of those will be "opensuse". The other will be either "Boot" or "boot" or "BOOT". I'll use "Boot" in what follows, but change that to the appropriate capitalization.

    The first step will be to rename that directory.

    Code:
    mv Boot oldBoot
    That just renames by putting "old" in front of the name.

    That should make UEFI boot options Boot0000 and Boot0002 fail.

    We also need to make Boot0001 fail. We can just delete that with the command
    Code:
    efibootmgr -b 2 -B
    That leaves your computer with no UEFI boot option, unless you plug in that install USB that you use. I hope that is still around, because you might need that to recover if something goes wrong.

    The next step is to try booting. And if it still boots, run "efibootmgr -v" again to see if it is still booting with UEFI.

    RECOVERY: What if it won't boot? That's a risk. And, worse still, if it doesn't boot then I don't know whether you still have a way of getting to the forum to report that. So here's the recovery procedure, just in case:

    Boot from the install media (which I think was a USB). There should be an option on the boot menu, to boot to the rescue system. Best to take that option.

    With the rescue system, you will get a command line login prompt. Login as root (no password needed).

    Mount the EFI partition
    Code:
    mount /dev/sda8 /mnt
    Then rename that directory back from "oldBoot" to "Boot"
    Code:
    cd /mnt/EFI
    mv oldBoot Boot
    And try to put the opensuse boot entry back:
    Code:
    efibootmgr -c -p 8 -L opensuse-secureboot -l '\EFI\opensuse\shim.efi'
    and then reboot
    Code:
    shutdown -r now
    Maybe print out this post or make notes, particularly if you won't have a way of accessing the forum in these circumstances.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #24
    Join Date
    Aug 2014
    Location
    India
    Posts
    29

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by nrickert View Post
    I didn't expect that Black&White menu. But that's not a serious issue. I did expect that you would still boot in UEFI mode, and that seems to be what has happened. Perhaps you have to boot to non-UEFI and then update the boot menu before Windows will show.

    This is where things get tricky. It looks as if we have to disable all UEFI booting options, in order to force a non-UEFI boot. And there is a risk that this might make your system unbootable. I'll get to that possibility shortly.


    The output of "ls" probably shows two directories. One of those will be "opensuse". The other will be either "Boot" or "boot" or "BOOT". I'll use "Boot" in what follows, but change that to the appropriate capitalization.

    The first step will be to rename that directory.
    That just renames by putting "old" in front of the name.

    That should make UEFI boot options Boot0000 and Boot0002 fail.

    We also need to make Boot0001 fail. We can just delete that with the command
    ......
    That leaves your computer with no UEFI boot option, unless you plug in that install USB that you use. I hope that is still around, because you might need that to recover if something goes wrong.

    The next step is to try booting. And if it still boots, run "efibootmgr -v" again to see if it is still booting with UEFI.
    As root, I did:
    Code:
    cd /boot/efi/EFI
    mv boot oldboot
    efibootmgr -b 2 -B
    After reboot, it still booting with same BLACK&WHITE prompt....and efibootmgr -v resilts...
    Code:
    linux-1hcj:/home/ubiroute # efibootmgr -v
    EFI variables are not supported on this system.
    linux-1hcj:/home/ubiroute #
    It looks EFI is gone...and it booting in legacy...

  5. #25
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,366
    Blog Entries
    3

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by tapassaini View Post
    As root, I did:
    It looks EFI is gone...and it booting in legacy...
    Okay. That was what I had hoped would happen.

    Now, as root:
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    And I am hoping that this will now give you a Windows entry in the boot menu.
    openSUSE Leap 15.1; KDE Plasma 5;

  6. #26
    Join Date
    Aug 2014
    Location
    India
    Posts
    29

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    BINGO....
    As root I did...
    Code:
    linux-1hcj:/home/ubiroute # grub2-mkconfig -o /boot/grub2/grub.cfg 
    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-4.12.14-lp150.12.4-default
    Found initrd image: /boot/initrd-4.12.14-lp150.12.4-default
    Found linux image: /boot/vmlinuz-4.12.14-lp150.11-default
    Found initrd image: /boot/initrd-4.12.14-lp150.11-default
    Found Windows 7 on /dev/sda1
    Found Windows 7 on /dev/sda2
    done
    linux-1hcj:/home/ubiroute #
    And now its dual booting both Windows 7 And Leap 15

    Many Many Thanks for your guidance and time for the troubleshooting......

    One last query: Any suggestion for thet redundant partition: /dev/sda8 in post #19(which I created for EFI during installation)... I mean shall I just delete or It can be merged with root(/) partition

    Thanks Again for your guidance and Time...

  7. #27
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,366
    Blog Entries
    3

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by tapassaini View Post
    And now its dual booting both Windows 7 And Leap 15
    I'm glad to hear that.

    Do you still have a black and white boot menu, or did that fix by itself?

    One last query: Any suggestion for thet redundant partition: /dev/sda8 in post #19(which I created for EFI during installation)... I mean shall I just delete or It can be merged with root(/) partition
    It is probably still being mounted at "/boot/efi". So you should remove the line in "/etc/fstab" that mounts it. And once you see that it is no longer being automatically mounted, you can delete it -- or just let it sit there unused.
    openSUSE Leap 15.1; KDE Plasma 5;

  8. #28
    Join Date
    Aug 2014
    Location
    India
    Posts
    29

    Smile Re: installed leap 15 and after that no menu option to boot windows 7

    Do you still have a black and white boot menu, or did that fix by itself?
    No it is still there, Is there any possibility of changing to colored one ? Else I can still live with that
    So you should remove the line in "/etc/fstab" that mounts it. And once you see that it is no longer being automatically mounted, you can delete it -- or just let it sit there unused.
    I will let it unused and merge during installation of next big release of opensuse

    Thanks Again

  9. #29
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,366
    Blog Entries
    3

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by tapassaini View Post
    No it is still there, Is there any possibility of changing to colored one ? Else I can still live with that
    I'm not sure why it went off. So I'm guessing.

    Start Yast bootloader
    Click on the "Kernel Parameters" tab.
    Make sure that the box for "Use graphical console" is checked. Click OK.

    If that box was already checked, then try:

    Yast --> Software Manager

    Search for "grub2". Find the line with "grub2-branding-openSUSE". Right click and select "update unconditionally". But I'm puzzled as to why this should be needed.
    openSUSE Leap 15.1; KDE Plasma 5;

  10. #30
    Join Date
    Aug 2014
    Location
    India
    Posts
    29

    Default Re: installed leap 15 and after that no menu option to boot windows 7

    Quote Originally Posted by nrickert View Post
    I'm not sure why it went off. So I'm guessing.

    Start Yast bootloader
    Click on the "Kernel Parameters" tab.
    Make sure that the box for "Use graphical console" is checked. Click OK.

    If that box was already checked
    THIS WORKED....Though "use graphical console" was already checked...but the text box for console theme was empty.
    I did browse...and selected file: 'boot/grub2/themes/openSUSE/theme.txt'
    Now my grub menu is also colored with openSUSE

    Many Thanks Again for your time and effort, people like you keep up momentum of openSUSE

    Tapas

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •