Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: How to disable menu in titlebar

  1. #11
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: How to disable menu in titlebar

    Hi eng-int!

    Quote Originally Posted by eng-int View Post
    This is my understanding. Hopefully if I am wrong someone will correct me.
    You are conflating two unrelated (except by the name “Menu”) matters. You should not expect one to affect the other.
    Unfortunately you are completely missing the point.
    After seeing your screenshots, I now understand why you weren't understanding my problem.
    Please, take a look at the forum thread I wrote about earlier (here it is) so that you can understand what my problem is and what I'm talking about.

    Thank you BTW for trying to help.
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #12
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: How to disable menu in titlebar

    Hi Miguel!

    Quote Originally Posted by miguel_mirandag1975 View Post
    Hi Cris, as nricket suggested the best bet is to restore defaults, check everything works and then delete the buttoms you dont want, i have disconfigured these things many times trying to understand what every settings of the miriad plasma has now do and restoring defaults always get me out of trouble. i personally dont like the menu buttom that eng-int shows i always delete it, but you should see it when restore to defaults, if not you have touched or installed something else may be a library or plasmoid, addons from kde store etc. do a check list what you have done before you noticed the problem, may be trying to configure a not working global menu technical preview addon?
    Thank you Miguel! I'll try again tomorrow, as the problem is on the laptop I use at work.

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  3. #13
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: How to disable menu in titlebar

    Replying to myself, so that others can find the solution if they have the same problem.

    So: KDE does NOT restore the menubar of the application if you remove the title-bar button (this is different from how it was previously, when the setting was in Application Style -> Widget Style -> Fine Tuning, see here). This is IMHO a bug and I am thinking about reporting it upstream.
    OTOH, it probably happens only to those who - like me - enabled the feature when it was available in Application Style -> Widget Style -> Fine Tuning, which probably means very few users.

    The solution is to remove the button from the titlebar by going to Application Style -> Windows Decorations -> Buttons and dragging the button from the titlebar to the center of the window.
    Then close and restart every KDE application that had a standard menu bar (e.g. Kate) and try to re-enable the menu using the CTRL-M keyboard shortcut.

    This may work differently in each application, e.g.: with Kate I had to enter CTRL-M twice because the first time Kate told me it hid the menubar (which BTW was already hidden) and the second time it showed the menubar. Notepadqq instead showed the menubar at the first CTRL-M.

    It may be (I don't know because I did not try) that if you completely restart your session (or reboot) KDE will restore all the menubars.

    Hope this helps.
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •