Results 1 to 5 of 5

Thread: Brother printer HL-2240 not working

  1. #1

    Default Brother printer HL-2240 not working

    Dear All,

    I've recently updated my father's laptop to LEAP 15 having a real smooth installation experience. No major problems popping up so far, the only annoying thing is the printer: Brother HL-2240.

    As I did in previous installations


    • Downloaded the latest driver from the Brother website
    • Installed the driver like the description said, some problems appearing there:


    Code:
     # bash linux-brprinter-installer-2.2.0-1 Input model name ->HL-2240
    
    You are going to install following packages.
       hl2240lpr-2.1.0-1.i386.rpm
       cupswrapperHL2240-2.0.4-2.i386.rpm
    OK? [y/N] ->y
    
    rpm -ihv --nodeps --replacefiles --replacepkgs hl2240lpr-2.1.0-1.i386.rpm
    Preparing...                          ################################# [100%]
    Updating / installing...
       1:hl2240lpr-2.1.0-1                ################################# [100%]
    /var/tmp/rpm-tmp.eCfQY6: Zeile 2: /usr/local/Brother/Printer/HL2240/inf/braddprinter: Datei oder Verzeichnis nicht gefunden
    rpm -ihv --nodeps --replacefiles --replacepkgs cupswrapperHL2240-2.0.4-2.i386.rpm
    Preparing...                          ########################################
    Updating / installing...
    cupswrapperHL2240-2.0.4-2             ########################################
    #
    The security level of AppArmor has been lowered. (aa-complain cups)
    aa-complain cupsd
    Profil für /usr/sbin/cupsd nicht gefunden, wird übersprungen
    Will you specify the Device URI? [Y/n] ->n
    
    Test Print? [y/N] ->y
    
    wait 5s.
    lpr -P HL2240 /usr/share/cups/data/testprint
    apt-get install libusb-0.1-4
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    'libusb-0.1-4' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
    Keine Anbieter von 'libusb-0.1-4' gefunden.
    Paketabhängigkeiten werden aufgelöst...
    
    Keine auszuführenden Aktionen.
    Hit Enter/Return key.
    I deinstalled the driver, installed libusb-0.1-4 via YAST, re-installed the driver but same message.

    Basically in YAST the printer looks fine after the driver installation, it just won't work. When trying to print the test page from YAST nothing happens.

    /var/log/cups/error_log contains the following:

    Code:
    W [16/Jul/2018:11:13:33 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [16/Jul/2018:11:13:33 +0200] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [16/Jul/2018:11:13:38 +0200] [CGI] cups-brf must be called as root
    E [16/Jul/2018:11:13:38 +0200] [cups-deviced] PID 1469 (cups-brf) stopped with status 1!
    E [16/Jul/2018:11:13:38 +0200] [cups-deviced] PID 1473 (gutenprint52+usb) stopped with status 1!
    W [16/Jul/2018:15:05:43 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [16/Jul/2018:15:05:43 +0200] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [16/Jul/2018:15:05:48 +0200] [CGI] cups-brf must be called as root
    E [16/Jul/2018:15:05:48 +0200] [cups-deviced] PID 1416 (cups-brf) stopped with status 1!
    E [16/Jul/2018:15:05:48 +0200] [cups-deviced] PID 1422 (gutenprint52+usb) stopped with status 1!
    W [16/Jul/2018:21:00:52 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [16/Jul/2018:21:00:52 +0200] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [16/Jul/2018:21:00:57 +0200] [CGI] cups-brf must be called as root
    E [16/Jul/2018:21:00:57 +0200] [cups-deviced] PID 1454 (cups-brf) stopped with status 1!
    E [16/Jul/2018:21:00:57 +0200] [cups-deviced] PID 1465 (gutenprint52+usb) stopped with status 1!
    W [16/Jul/2018:21:08:35 +0200] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    W [16/Jul/2018:21:08:35 +0200] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
    E [16/Jul/2018:21:08:39 +0200] [CGI] cups-brf must be called as root
    E [16/Jul/2018:21:08:39 +0200] [cups-deviced] PID 1394 (cups-brf) stopped with status 1!
    E [16/Jul/2018:21:08:39 +0200] [cups-deviced] PID 1398 (gutenprint52+usb) stopped with status 1!

    I also tried to stop/restart the printer queue which appears as IDLE, but no success.

    Does anyone have a hint? I was a bit suspicious about the i386 rpms in the installation, but the printer worked flawlessly in LEAP 42.1 which was a 64bit installation too.

    Regards

    tuxEvangelist

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: Brother printer HL-2240 not working

    There was a recent thread concerning Brother printer drivers....
    https://forums.opensuse.org/showthre...ut-can-t-print
    In particular post #21 (re missing glibc-32bit) and post #30 (re missing libusb-0_1-4 libusb-0_1-4-32bit)

    See if that helps.
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3

    Default Re: Brother printer HL-2240 not working

    Ah, I missed out on this one, looks like my search string was too narrow :-|

    I'll check it out ASAP and will be back. Thank you very much for pointing me there!!!

    Regards

    tuxEvangelist

  4. #4

    Default Re: Brother printer HL-2240 not working

    YES! That was the solution, glibc-32bit was missing. As soon as I installed that, the printer worked instantly :-)))

    Looks like there was nothing 32bit installed, because half-a-dozen other 32bit libs were also installed. But that's no issue, the root partition has lots of space left.

    Thanx again a ton, please mark the thread as solved.

    Regards

    tuxEvangelist

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: Brother printer HL-2240 not working

    Quote Originally Posted by tuxEvangelist View Post
    YES! That was the solution, glibc-32bit was missing. As soon as I installed that, the printer worked instantly :-)))

    Looks like there was nothing 32bit installed, because half-a-dozen other 32bit libs were also installed. But that's no issue, the root partition has lots of space left.

    Thanx again a ton, please mark the thread as solved.

    Regards

    tuxEvangelist
    Happy to have been of guidance. We don't tend to mark a thread as solved, but you can reply and change the title to reflect if you desire .
    openSUSE Leap 15.0; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •