Results 1 to 6 of 6

Thread: okular doesn't open files

  1. #1

    Default okular doesn't open files

    on my
    Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz: DE=plasma 5.13.2, KDE frameworks 5.47.0, KDE applications 18.4.2, Kernel 4.4.138-59-default, nvidia drivers, when I click on a pdf file nothing happen, okular is the default application to open pdf, if I rightclick and choose another application it works fine, opening okular by commandline in konsole it works, opening a pdf file by commandline in konsole gives me this error:
    Code:
     okular azz.pdf
    okular: symbol lookup error: /usr/lib64/qt5/plugins/okular/generators/okularGenerator_poppler.so: undefined symbol: _ZNK7Poppler4Page13renderToImageEddiiiiNS0_8RotationEPFvRK6QImageRK8QVariantEPFbS7_ESB_S7_


    How can I have okular working?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: okular doesn't open files

    Since those KDE version numbers don't appear to be consistent with those used as default in Leap 42.3, I assume that you have subscribed to additional repos. As such, please show us
    Code:
    zypper lr -d
    I suspect the error message you report is only the 'tip of the iceberg' here.
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3

    Default Re: okular doesn't open files

    Quote Originally Posted by deano_ferrari View Post
    Since those KDE version numbers don't appear to be consistent with those used as default in Leap 42.3, I assume that you have subscribed to additional repos. As such, please show us
    Code:
    zypper lr -d
    I suspect the error message you report is only the 'tip of the iceberg' here.
    ...maaaanythanks, you rised me to the solution :-) I uninstalled okular and installed okular5 and now it works!!!

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,157

    Default Re: okular doesn't open files

    Quote Originally Posted by pier_andreit View Post
    ...maaaanythanks, you rised me to the solution :-) I uninstalled okular and installed okular5 and now it works!!!
    But did you understand the warning about "the tip of the iceberg"?
    Henk van Velden

  5. #5

    Default Re: okular doesn't open files

    Quote Originally Posted by hcvv View Post
    But did you understand the warning about "the tip of the iceberg"?
    ...not so deeply as I should , ...but in a few weeks I would upgrade to leap 15 and I think many of this problem with app/app5 I suppose will disappear :-)

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,854
    Blog Entries
    14

    Default Re: okular doesn't open files

    Sorry to say so, but this is YaPaMP ( Yet another Post about Mixed Packages ). This means that you not only mix packages from different origins, but also that you don't adjust your update routines. Are you aware that almost all your posts here are about issues that are the result of that?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •