Results 1 to 9 of 9

Thread: System ignored login

  1. #1

    Default System ignored login

    I built a new GeckoLinux Cinnamon Leap system last night. This morning, I started the system. It seemed to take a little longer than usual and then displayed the desktop -- only I never logged in. I've never seen that with any Linux distribution. What do I look for via journalctl to research the problem? I looked through the log, but did not see anything obviously relevant.

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,432

    Default Re: System ignored login

    Automatic login was offered as an installation option on this screen:
    https://doc.opensuse.org/documentati...user_osuse.png
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  3. #3

    Default Re: System ignored login

    Thanks for the reply. I never would have selected that intentionally. I looked at User And Group Management and "autologin" was checked. Then I looked at Users And Groups and saw that the user had admin privilege, something I didn't want. I must have selected the wrong box, that's a first. I won't make that mistake again.

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,127

    Default Re: System ignored login

    And you can edit:
    /etc/sysconfig/displaymanagerISPLAYMANAGER_AUTOLOGIN=""
    to remove autologin. You can either use YaST or a text editor.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  5. #5

    Default Re: System ignored login

    Thanks for the reply. It was more interesting than you know. The app I mentioned in my other reply was of no value, because I confused autologin group with autologin.

    Good thing I remember how to use VI. I first commented-out the line DISPLAY_AUTOLOGIN="me" but that had no affect. Then I tried DISPLAY_AUTOLOGIN="" but that also had no affect. Then I tried DISPLAY_AUTOLOGIN=0 and that worked, so there's a difference between an empty string and a boolean.

  6. #6
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,127

    Default Re: System ignored login

    Quote Originally Posted by anymouse View Post
    I first commented-out the line DISPLAY_AUTOLOGIN="me" but that had no affect. Then I tried DISPLAY_AUTOLOGIN="" but that also had no affect. Then I tried DISPLAY_AUTOLOGIN=0 and that worked, so there's a difference between an empty string and a boolean.
    That is interesting because I pasted in the output of:
    Code:
    rayh@y3:~> sudo grep -ir autolog /etc/sysconfig
    /etc/sysconfig/displaymanager:DISPLAYMANAGER_AUTOLOGIN=""
    /etc/sysconfig/displaymanager:# DISPLAYMANAGER_AUTOLOGIN is empty.
    I have enabled and disabled autolgin on a remote machine to assist with an upgrade to Leap-15.0, but used YaST (ncurses) on that occasion.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,432

    Default Re: System ignored login

    It's fairly typical that changes in /etc/sysconfig/ do not take effect without a reboot. Could that explain the difference you experienced between ="" and =0?
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,547

    Default Re: System ignored login

    Note also default is to have the first user have the same password as root. This does NOT make them admin just the same password.

  9. #9

    Default Re: System ignored login

    @mrmazda Yes, I was rebooting in between each change.

    @gogalthorp Yes, sometimes I forget that.

    Something @eng-int wrote made me curious. It looked like his example had a string with one blank, but my example used an empty string. So I went back and tried a string with one blank: DISPLAYMANAGER_AUTOLOGIN=" "

    And this worked the same as DISPLAYMANAGER_AUTOLOGIN=0, giving me the login screen. Something tells me that using a string with one blank is closer to the developer's original intent.

    If I have some spare time, I'll build a new system on a spare drive and note that line in /etc/sysconfig/displaymanager.

    Thanks to everyone for their help. This was my first venture into openSUSE, having previously spent my time mainly with Fedora, Linux Mint, and Lubuntu, and the forum is very helpful.

    One last question: how do I mark the thread as answered? I don't see a way to do that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •