Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Plasma only starts as root

  1. #1

    Default Plasma only starts as root

    Hi all,

    I am still struggling with my Plasma installation (I posted here one month ago: Black screen - mouse only). I invested several hours in resolving conflicts in Yast, and I uninstalled everything X11/KDE/Plasma related I could find. After that I installed the patterns-kde-kde.

    But: When I start a KDE Plasma session, the screen stays black, only showing a mouse cursor.

    However, when I startx from a root session, I get a KDE desktop. I crashes every few seconds - i.e., taskbar + desktop icons freeze, disappear, then reappear - but I managed to start a Firefox and it continued running although the plasmashell (?) crashed.

    Trying to do the same as my normal user => black screen + mouse.

    I also created a new user (adduser), logged in on console, did startx => black screen + mouse.

    Any ideas what I could try?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,268
    Blog Entries
    2

    Default Re: Plasma only starts as root

    1. Are you running KDE with Xorg X server or Wayland?
    If you don't know, you can disable autologin, then when you reboot and arrive at the screen where you enter your Username/Password, there will be a dropdown somewhere (exact location depends on your Display Manager) that allows you to choose (try both).

    2.Is your KDE/Plasma from the default OSS, or do you also have special KDE repos installed?
    If you don't know, post the results of the following command
    Code:
    sudo zypper lr -d
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Plasma only starts as root

    Startx is pretty much deprecated.
    What happens if you try to login to another graphical desktop, e.g. IceWM or Openbox?

    You have the Nvidia proprietary repository enabled. The only non-openSUSE signed repository that I know of that consistently keeps pace with Tumbleweed is Packman. Consider using Nouveau (but first read up on its current status with your graphics card), or Leap-15.0 if alien repositories are a must.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  4. #4

    Default Re: Plasma only starts as root

    Thanks for your hints!

    I am using DisplayManager xdm because sddm sends me directly into black screen + mouse. /etc/sddm.conf.d/autologin.conf does not exist, so autologin should be disabled, right? (actually, the whole /etc/sddm.conf.d is empty.)

    As far as I can tell, xdm does not show me an option to select an Xserver or WM. Any hints on that?

    I am using IceWM while writing this post. So IceWM seems to work fine.

    As proposed, I disabled the nvidia repository (after uninstalling everything that looked like nvidia-drivers.) After reboot, my screen resolution is now terribly low. But apart from that IceWM is still working and sddm/KDE still is not. I think the nvidia drivers were ok because the screen showed at least something (the mouse cursor).

    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    --+--------------+--------------+---------+-----------+---------+----------+--------+------------------------------------------------------+--------
    1 | NVIDIA | NVIDIA | Yes | (r ) Yes | Yes | 99 | rpm-md | https://download.nvidia.com/opensuse/tumbleweed |
    2 | repo-debug | repo-debug | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/debug |
    3 | repo-non-oss | repo-non-oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss |
    4 | repo-oss | repo-oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss |
    5 | repo-update | repo-update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |

    Any more ideas?

  5. #5

    Default Re: Plasma only starts as root

    Ah, sorry, my above posting of the zypper output was outdated. Here with nvidia disabled.

    Code:
    # | Alias        | Name         | Enabled | GPG Check | Refresh
    --+--------------+--------------+---------+-----------+--------
    1 | NVIDIA       | NVIDIA       | No      | ----      | ----   
    2 | repo-debug   | repo-debug   | Yes     | (r ) Yes  | Yes    
    3 | repo-non-oss | repo-non-oss | Yes     | (r ) Yes  | Yes    
    4 | repo-oss     | repo-oss     | Yes     | (r ) Yes  | Yes    
    5 | repo-update  | repo-update  | Yes     | (r ) Yes  | Yes

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,975

    Default AW: Plasma only starts as root

    Post:
    Code:
    cat /var/log/Xorg.0.log
    This as a attached textfile.

    Also:
    Code:
    grep -i 'blacklist nouveau' /etc/modprobe.d/*
    This in Code-Tags

    PS:
    startx does only works as root.
    Last edited by Sauerland; 14-Jul-2018 at 23:07.

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,686

    Default Re: Plasma only starts as root

    Replacing sddm with lightdm seems to be a common solution to black screens. None of my TW or Leap installations include sddm. You may need to use yast2 alternatives to make the DM change after doing the (optional sddm) package removal and (necessary lightdm) installation.

    What is the output of the following in IceWM running a (root) Xterm
    Code:
    zypper in inxi; inxi -G -c0; lspci -nnk | grep -A3 VGA; grep onnect /var/log/Xorg.0.log
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8

    Default Re: AW: Plasma only starts as root

    Hi again,

    Quote Originally Posted by Sauerland View Post

    Code:
    cat /var/log/Xorg.0.log
    This as a attached textfile.

    Also:
    Code:
    grep -i 'blacklist nouveau' /etc/modprobe.d/*
    This in Code-Tags
    The Xorg.0.log seems to contain only log information of the current run; which is IceWM because I need Firefox. Should I still send this file? Or a different one like Xorg.1.log or Xorg.0.log.old?

    grep -i 'blacklist nouveau' /etc/modprobe.d/*
    =>
    Code:
    /etc/modprobe.d/nvidia-desktop.conf:blacklist nouveau
    Should I comment out this line?

    @mrmazda:
    I installed lightdm and did a
    Code:
    update-alternatives --config displaymanager
    to select it. Worked.
    Tried to log in to KDE: black screen + mouse. crtl+alt+backspace, and then tried KDE (wayland): black, no mouse. ctrl+alt+bs, switch to console, etc. did not work. Pushing the power button let my notebook shutdown.

    Here is the output of inxi, lspci:

    Code:
     zypper in inxi; inxi -G -c0; lspci -nnk | grep -A3 VGA; grep onnect /var/log/Xorg.0.log
    Loading repository data...
    Reading installed packages...
    'inxi' is already installed.
    No update candidate for 'inxi-3.0.10-1.1.noarch'. The highest available version is already installed.
    Resolving package dependencies...
    
    Nothing to do.
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = (unset),
            LC_ALL = (unset),
            LC_CTYPE = "de_DE.UTF-8,LANG=en_US.UTF-8",
            LANG = "de_DE.utf8"
        are supported and installed on your system.
    perl: warning: Falling back to a fallback locale ("de_DE.utf8").
    Graphics:
      Card-1: NVIDIA GF106M [GeForce GTX 460M] driver: nvidia v: 390.67 
      Display: x11 server: X.Org 1.19.6 driver: fbdev,modesetting,nouveau,vesa 
      unloaded: nv,nvidia resolution: 640x480~73Hz 
      OpenGL: renderer: N/A v: N/A 
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF106M [GeForce GTX 460M] [10de:0dd1] (rev a1)
            Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:1083]
            Kernel driver in use: nvidia
            Kernel modules: nouveau, nvidia_drm, nvidia
    Hm, still nvidia...? Confused; thought I had removed it...

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,975

    Default AW: Plasma only starts as root

    You have to remove the Nvidia Packages, not only to disable the Repo........
    Last edited by Sauerland; 15-Jul-2018 at 02:29.

  10. #10

    Default Re: AW: Plasma only starts as root

    Quote Originally Posted by Sauerland View Post
    You have to remove the Nvidia Packages, not only to disable the Repo........
    Sorry, probably stupid question, but what name could that remaining nvidia package have?

    Code:
     rpm -qa --last |grep nv
    plasma-nm5-openvpn-5.13.2-1.1.x86_64          Tue Jul  3 21:16:26 2018
    konversation-lang-1.7.5-1.1.noarch            Tue Jul  3 21:16:00 2018
    konversation-1.7.5-1.1.x86_64                 Tue Jul  3 21:15:46 2018
    libKF5UnitConversion5-lang-5.47.0-1.1.noarch  Tue Jul  3 21:14:54 2018
    libKF5UnitConversion5-5.47.0-1.1.x86_64       Tue Jul  3 21:14:46 2018
    libdolphinvcs5-18.04.2-1.1.x86_64             Tue Jul  3 21:13:16 2018
    libdouble-conversion1-32bit-2.0.1-6.2.x86_64  Fri Jun  1 19:53:45 2018
    NetworkManager-openvpn-lang-1.8.4-1.1.noarch  Fri Jun  1 18:18:50 2018
    NetworkManager-openvpn-1.8.4-1.1.x86_64       Fri Jun  1 18:18:28 2018
    texlive-environ-2018.151.0.0.3svn33821-37.2.noarch Fri Jun  1 16:44:41 2018
    openvpn-2.4.6-1.1.x86_64                      Fri Jun  1 16:35:24 2018
    libv4lconvert0-1.14.1-1.1.x86_64              Fri Jun  1 16:29:38 2018
    libmpeg2convert0-0.5.1-2.1.x86_64             Fri Jun  1 16:24:26 2018
    libdouble-conversion1-2.0.1-6.2.x86_64        Fri Jun  1 16:17:50 2018
    texlive-environ-doc-2018.151.0.0.3svn33821-37.2.noarch Fri Jun  1 16:12:15 2018

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •