Results 1 to 5 of 5

Thread: Latest FWupdate version (11) issue with SuSE (SLEDSP3)

  1. #1

    Default Latest FWupdate version (11) issue with SuSE (SLEDSP3)

    Since Suse OS does not have fwupdate or fwup packages on their, i am currently using packages released for OpenSuse which is why i created a post here [i apologize if it is not OK]
    I am mostly doing manual update using fwupdate because SLED SP3 sversion is not supporting LVFS yet (AFAIK)
    I could update firmware on the older versions but after updating to Version 11 (still Opensuse tumbleweed version) error message is returned when i use fwupdate -a :
    Code:
    
    
    Could not set up firmware update: no such file or directory 
    error trace: libfwup.c:1061 get_paths(): could not find fwup on ESP: no such file or directory
     libfwup.c:1119 set_up_boot_next(): could not find paths for shim and fwup: no such file or directory


    I did not encounter any error on other linux OS (ubuntu, RHEL7 and debian)that i have, but I realize version 11 isn't available yet for these OS

    Operating system and version: SuSE Linux Enterprise Desktop SP3
    Shim? : latest 14-3.1
    How did you install fwupdate: via terminal (zypper install fwupdate) and also via YaST2
    Have you tried rebooting? Yes
    Are you using an NVMe disk? no
    Is secure boot enabled (only for the UEFI plugin)? no

    Any guidance to resolve issue is greatly appreciated

    Thank you very much!

  2. #2

    Default Re: Latest FWupdate version (11) issue with SuSE (SLEDSP3)

    I believe it may have something to do with a specific package that is not in its correct place

    Any help for this issue is greatly appreciated

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Latest FWupdate version (11) issue with SuSE (SLEDSP3)

    Quote Originally Posted by lollipop2185 View Post
    I believe it may have something to do with a specific package that is not in its correct place

    Any help for this issue is greatly appreciated
    Hi
    So did you rebuild fwupdate version 11 locally on your SLED 12 SP3 system, or just install the tumbleweed version (this won't work), you need to build against your system...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Latest FWupdate version (11) issue with SuSE (SLEDSP3)

    Hi Malcolm,

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So did you rebuild fwupdate version 11 locally on your SLED 12 SP3 system, or just install the tumbleweed version (this won't work), you need to build against your system...
    does this also apply to other fwupdate dependencies too? e.g. fwupdate-efi , Libefivar1 , libfwup1?

    I just selected the install option on OpenSuse site and accepted vendor change to opensuse before and it worked. Was there an update for version 11 that restricted fwupdate deployment to suse?

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,670
    Blog Entries
    15

    Default Re: Latest FWupdate version (11) issue with SuSE (SLEDSP3)

    On Fri 13 Jul 2018 04:26:02 AM CDT, lollipop2185 wrote:

    Hi Malcolm,

    malcolmlewis;2873388 Wrote:
    > Hi
    > So did you rebuild fwupdate version 11 locally on your SLED 12 SP3
    > system, or just install the tumbleweed version (this won't work), you
    > need to build against your system...


    does this also apply to other fwupdate dependencies too? e.g.
    fwupdate-efi , Libefivar1 , libfwup1?

    I just selected the install option on OpenSuse site and accepted vendor
    change to opensuse before and it worked. Was there an update for version
    11 that restricted fwupdate deployment to suse?


    Hi
    Correct, you will wind up having different versions of supporting
    libs (eg efivar-devel)...then you can run into issues if a core item
    changes that most of SLE is build on...

    SLE 15 (and Leap 15.0) is on;
    Code:
    Information for package fwupdate:
    ---------------------------------
    Repository     : SLE-Module-Basesystem15-Pool
    Name           : fwupdate
    Version        : 9+git21.gcd8f7d7-4.17
    Remember Tumbleweed is rolling so updates over the SLE lifetime will
    move this goal post potentially many times...

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-23-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •