Results 1 to 5 of 5

Thread: Grub 2 doesn't see opensuse after Win10 update

  1. #1

    Default Grub 2 doesn't see opensuse after Win10 update

    Hi Guys,

    After having updated Win10 i can't find opensuse on the grub 2.

    I've try this:

    bcdedit /set {bootmgr} path \EFI\ubu.tu\grubx64.efi

    but only kubuntu appear.

    Thanks in advance to all of you.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,585
    Blog Entries
    14

    Default Re: Grub 2 doesn't see opensuse after Win10 update

    Boot from a live or install medium. Replace sdX# by the /dev/ entry your openSUSE is on.
    Do:
    Code:
    mount /dev/sdX# /mnt
    mount --bind /dev /mnt/dev
    mount --bind /proc /mnt/proc
    mount --bind /sys /mnt/sys
    chroot /mnt
    yast
    Next enter the bootloader module in YaST, make sure os-prober is checked, OK, reboot.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,177
    Blog Entries
    3

    Default Re: Grub 2 doesn't see opensuse after Win10 update

    Quote Originally Posted by Kubayashi View Post
    bcdedit /set {bootmgr} path \EFI\ubu.tu\grubx64.efi

    but only kubuntu appear.
    What happens if you try:
    Code:
    bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4

    Default Re: Grub 2 doesn't see opensuse after Win10 update

    Quote Originally Posted by nrickert View Post
    What happens if you try:
    Code:
    bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi

    Thanks a lot! This solution works and now i have the same previous grub. Can you explane me where is my fault?

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,585
    Blog Entries
    14

    Default Re: Grub 2 doesn't see opensuse after Win10 update

    Quote Originally Posted by Kubayashi View Post
    Thanks a lot! This solution works and now i have the same previous grub. Can you explane me where is my fault?
    You were editting Kubuntu's EFI, which apparently is not aware of openSUSE. To me this looks like openSUSE was installed last, and has the control over GRUB
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •