Results 1 to 5 of 5

Thread: zypper dup wants to downgrade VLC packages from videolan

  1. #1
    Join Date
    Jan 2018
    Location
    Annandale, VA
    Posts
    195

    Default zypper dup wants to downgrade VLC packages from videolan

    I want the ability to play out of region DVDs on my Tumbleweed system, so I configured the videolan repository and installed VLC. As I understand it the version on packman doesn't have the requisite codec support. For some time now zypper has been giving me messages asking to downgrade VLC from videolan to packman, e.g.,

    9 Problems:
    Problem: problem with installed package libavutil55-3.4.2-11.3.i586
    Problem: problem with installed package libavfilter6-3.4.2-11.3.i586
    Problem: problem with installed package libavformat57-3.4.2-11.3.i586
    Problem: problem with installed package libpostproc54-3.4.2-11.3.i586
    Problem: problem with installed package libswscale4-3.4.2-11.3.i586
    Problem: problem with installed package libswresample2-3.4.2-11.3.i586
    Problem: problem with installed package libavresample3-3.4.2-11.3.i586
    Problem: problem with installed package libavdevice57-3.4.2-11.3.i586
    Problem: problem with installed package libavcodec57-3.4.2-11.3.i586

    Problem: problem with installed package libavutil55-3.4.2-11.3.i586
    Solution 1: install libavutil55-3.4.2-3.1.i586 (with vendor change)
    VideoLAN Project (http://www.videolan.org) --> http://packman.links2linux.de
    Solution 2: keep obsolete libavutil55-3.4.2-11.3.i586
    I've been responding 2 to all of those messages. Is videolan just slow to catch up with changes elsewhere, or is there a problem that I need to worry about? Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,431
    Blog Entries
    14

    Default Re: zypper dup wants to downgrade VLC packages from videolan

    A couple of things:
    - Do not use both the videolan and Packman repo at the same time, disable the videolan one.
    - After doing so, run a 'zypper dup --from #' where # is the number representing the Packman repo ( found through 'zypper lr' ).
    - I've seen some issue too, so it might be better to wait until tomorrow and check again.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jan 2018
    Location
    Annandale, VA
    Posts
    195

    Default Re: zypper dup wants to downgrade VLC packages from videolan

    Quote Originally Posted by Knurpht View Post
    A couple of things:
    - Do not use both the videolan and Packman repo at the same time, disable the videolan one.
    - After doing so, run a 'zypper dup --from #' where # is the number representing the Packman repo ( found through 'zypper lr' ).
    - I've seen some issue too, so it might be better to wait until tomorrow and check again.
    Won't zipper still try to replace packages that I installed from videolan with newer packages from packman? Won't I eventually need upgrades from videolan?

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,212

    Default AW: zypper dup wants to downgrade VLC packages from videolan

    Its the same Source package:
    Problem: problem with installed package libavutil55-3.4.2-11.3.i586
    Solution 1: install libavutil55-3.4.2-3.1.i586 (with vendor change)
    But as mentinoed, it is not good, to enable Packman- and Videolan-Repo together.

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: zypper dup wants to downgrade VLC packages from videolan

    Quote Originally Posted by shmuelmetz View Post
    Won't zipper still try to replace packages that I installed from videolan with newer packages from packman? Won't I eventually need upgrades from videolan?
    nope zypper on TW now uses vendor stickiness and running zypper dup will not download packages from a different vendor
    you should tell us your repo list
    Code:
    zypper lr -d
    playing DVD's on Linux is region independent as libdvcss does not use region coding but you do need libdvdcss2 installed both vlc and opensuse-guide.org house the libdvdcss2 package
    Code:
    zypper ar -f http://opensuse-guide.org/repo/openSUSE_Tumbleweed/ libdvdcss
    zypper in libdvdcss2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •