Results 1 to 6 of 6

Thread: Problem first boot

  1. #1

    Default Problem first boot

    Hi all. I've installed many times OpenSuse Tumbleweed on a laptop, both UEFI and not, but i still have the same problem at first boot. The system is loading but it doesn't boot, it stop on "A start job is running for" with three differents sentences:
    - Update cron periods from /etc/sysconfig/btrfsmaintence
    - Wait for chrony to synchronize system clock
    - Hold until boot process finishes up

    and it goes this way for several minutes. What can i do?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,858
    Blog Entries
    14

    Default Re: Problem first boot

    Make sure you DO NOT activate the ntp service during install. I've seen others reporting issues caused by both ntpd and chrony running.

    If the install does complete the boot sequence in the end ( people have reported ~10 minutes ) you can do that from the installed system as well using YaST's service manager.
    Last edited by Knurpht; 16-Sep-2019 at 03:43.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Problem first boot

    I've installed OpenSuse Leap and seems there's no problems with it... i guess i will change to Tumbleweed switching the repositories and with "zypper dup"... Can be the right thing?

  4. #4
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: Problem first boot

    Quote Originally Posted by Knurpht View Post
    Make sure you DO NOT activate the ntp service during install. I've seen others reporting issues caused by both ntpd and chrony running. [CITATION NEEDED]
    The problem is chrony-wait.service

    https://bugzilla.opensuse.org/show_bug.cgi?id=1145193

    The quickest workaround is:

    Code:
    systemctl disable chrony-wait.service
    You can also edit the service to reduce the wait time, as indicated in the bugreport.

    I've edited the service to use "makestep" instead of "waitsync"; although, I'm still waiting for feedback about that on the bugreport. I've had no apparent problems so far.
    Tumbleweed, Xfce, Firefox, uBlock Origin

  5. #5

    Default Re: Problem first boot

    Thank you all for the replies! I've solved the problem with the solution i wrote before: i installed OpenSuse Leap, then i changed the repositories and i shifted to Tumbleweed with zypper dup. Now the system it's ok, maybe just a little slow to boot but i think that's for other reasons, i don't know. Anyway, when i will have to reinstall Tumbleweed i will follow your advices

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Problem first boot

    systemd-analyze blame will show what is taking extra time

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •