Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Leap 15 = Black Screen after boot

Hybrid View

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Leap 15 = Black Screen after boot

    I just installed Leap 15 and KDE
    After login a black screen appears
    What can I do to get in?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,580

    Default Re: Leap 15 = Black Screen after boot

    What graphics card??

    try nomodeset

    At boot press e find line starting linux or linuxefi go to end of the line (it wraps) add space and nomodeset press F10 to continue boot

  3. #3
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Leap 15 = Black Screen after boot

    Thanks for the answer.
    When I press the key between Ctrl and Alt the screen returns to normal
    With this information maybe there is another way to solve this problem

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,583
    Blog Entries
    14

    Default Re: Leap 15 = Black Screen after boot

    Quote Originally Posted by sergelli View Post
    Thanks for the answer.
    When I press the key between Ctrl and Alt the screen returns to normal
    With this information maybe there is another way to solve this problem
    Please check whether this issue is the same for a newly created user.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Leap 15 = Black Screen after boot

    I rebooted the machine and now the screen remains black even if I press the key I mentioned earlier.
    I tried to use the nomodeset but there is no line that you mentioned. I do not think the words "starting linux or linuxefi"
    Please....What else should I do?

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,583
    Blog Entries
    14

    Default Re: Leap 15 = Black Screen after boot

    Quote Originally Posted by sergelli View Post
    I rebooted the machine and now the screen remains black even if I press the key I mentioned earlier.
    I tried to use the nomodeset but there is no line that you mentioned. I do not think the words "starting linux or linuxefi"
    Please....What else should I do?
    In the bootloader menu, hit 'e', then look for "showopts", add a space behind it and 'nomodeset'. If that works out OK, make it persistent by YaST - System - Bootloader - Kernelparameters, where you'll see the same 'showopts' option, add it there, and reboot
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,008
    Blog Entries
    1

    Default Re: Leap 15 = Black Screen after boot

    Quote Originally Posted by sergelli View Post
    I rebooted the machine and now the screen remains black even if I press the key I mentioned earlier.
    I tried to use the nomodeset but there is no line that you mentioned. I do not think the words "starting linux or linuxefi"
    Please....What else should I do?
    Yes there is, but you'll need to use the down arrow key to find it. Read the following if it's still not clear to you...

    https://doc.opensuse.org/documentati...b2.menu_change
    openSUSE Leap 15.0; KDE Plasma 5

  8. #8
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Leap 15 = Black Screen after boot

    OK thank you. Using "nomodeset" the desktop has returned.
    But how do I get saved at boot?

  9. #9
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    398

    Default Re: Leap 15 = Black Screen after boot

    Quote Originally Posted by sergelli View Post
    OK thank you. Using "nomodeset" the desktop has returned.
    But how do I get saved at boot?
    Code:
    su -
    nano /etc/default/grub
    Here add nomodeset
    grub2-mkconfig -o /boot/grub2/grub.cfg

  10. #10
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Leap 15 = Black Screen after boot

    Quote Originally Posted by another_roadrunner View Post
    Code:
    su -
    nano /etc/default/grub
    Here add nomodeset
    grub2-mkconfig -o /boot/grub2/grub.cfg
    I made the indicated change and restart OpenSUSE and this time worked well.
    I would like to know what caused this installation to fail.
    So, I can avoid this problem in the future.
    So? How did this happen?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •