Results 1 to 4 of 4

Thread: Okular crash

  1. #1

    Default Okular crash

    Today's update of Leap 15.0 makes okular to crash regularly on clicking any pdf file. In fact, nothing happens at all.
    When running okular in terminal, the following error message appears:

    okular: symbol lookup error: /usr/lib64/qt5/plugins/okular/generators/okularGenerator_poppler.so: undefined symbol: _ZNK7Poppler4Page13renderToImageEddiiiiNS0_8RotationEPFvRK6QImageRK8QVariantEPFbS7_ESB_S7_

    Using Leap 15.0, plasma 5.13.3, Frameworks 5.47.0, Qt 5.11.1, kernel 4.12.14, OS 64-bit.

  2. #2

    Default Re: Okular crash

    Do you have additional repositories?
    Code:
    zypper ls -d
    It also searches for and deletes Okular configuration files between hidden files
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  3. #3

    Default Re: Okular crash

    Code:
    zypper ls -d
    #  | Alias                               | Name                                                      | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                            
    ---+-------------------------------------+-----------------------------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------------------
    1  | Fonts                               | Fonts                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                      
    2  | Frameworks5_1                       | Frameworks5                                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                 
    3  | KDE_Applications                    | KDE Applications                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/
    4  | KDE_Extra                           | KDE Extra                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                       
    5  | Mozilla                             | Mozilla                                                   | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                          
    6  | Qt_5                                | Qt 5                                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                         
    7  | Science                             | Science                                                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                          
    8  | download.nvidia.com-leap            | nVidia Graphics Drivers                                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/15.0                                                  
    9  | download.opensuse.org-non-oss       | Main Repository (NON-OSS)                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distrib.../repo/non-oss/                              
    10 | download.opensuse.org-non-oss_1     | Update Repository (Non-Oss)                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                                         
    11 | download.opensuse.org-oss           | Main Repository (OSS)                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distrib...15.0/repo/oss/                                  
    12 | download.opensuse.org-oss_1         | Main Update Repository                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss                                              
    13 | http-download.opensuse.org-946e51e6 | openSUSE:Leap:15.0:Update                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                                             
    14 | http-download.opensuse.org-a905d3e3 | graphics                                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                         
    15 | http-opensuse-guide.org-06febf05    | libdvdcss repository                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/                                             
    16 | openSUSE-15.0-0                     | openSUSE-15.0-0                                           | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-_Patriot_Memory_07A71501AE6B283E-0:0-part2                   
    17 | openSUSE_Leap_15.0                  | LibreOffice                                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.0/                 
    18 | packman.inode.at-suse               | Packman_Repository                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.0/                                               
    19 | proxsign                            | SETCCE proXSign® Component Suite for (openSUSE_Leap_15.0) | No      | ----      | ----    |   99     | rpm-md | http://public.setcce.si/proxsign/rep...USE_Leap_15.0/                                      
    20 | repo-debug                          | openSUSE-Leap-15.0-Debug                                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/d...15.0/repo/oss/                            
    21 | repo-debug-non-oss                  | openSUSE-Leap-15.0-Debug-Non-Oss                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/d.../repo/non-oss/                        
    22 | repo-debug-update                   | openSUSE-Leap-15.0-Update-Debug                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/u...leap/15.0/oss/                                       
    23 | repo-debug-update-non-oss           | openSUSE-Leap-15.0-Update-Debug-Non-Oss                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/u.../15.0/non-oss/                                   
    24 | repo-source                         | openSUSE-Leap-15.0-Source                                 | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/...15.0/repo/oss/                           
    25 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss                         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/.../repo/non-oss/
    But I managed to solve the problem by updating/upgrading poppler. The "zypper up" or "zypper dup" command did not produce any result. I had to do "zypper install libpoppler ..." in order to get poppler updated. Now, okular is back to work.
    Last edited by Fraser_Bell; 12-Jul-2018 at 14:25. Reason: Add Code Tags: OP, when pasting code, please use the Code tags so it is properly formatted and readable. Do that by clicking the "#" icon above the message window, then pasting in between t

  4. #4

    Default Re: Okular crash

    I do not use Plasma and sincerely I think a lot of the repositories, then all with the same priority.
    But it may be that I'm wrong
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •