Hello,

Just wanted to share my experience with openSUSE Linux on a Mini PC with Intel Atom z8350 2GB RAM 32 GB SSD WiFi Gb LAN HDMI (e.g. X5 Z8350 mini PC on AliExpress)

- Installation of openSUSE Leap 15 from a USB with Network ISO went without a hitch
- I've removed all preinstalled partitions with Android and Windows, formatted the whole drive, but the Android droid still appears on start-up and then goes to Grub - can't get rid of it
- First, I had boot problems which I fixed (see https://forums.opensuse.org/showthre...endless-errors)
- The whole system runs well, slight lag in opening applications - well, considering the brains, it's ok, opens everything, plays videos and Youtube, although Firefox lags with Youtube the most, everything else is fine
- WiFi works out of the box
- It turned out there is either no Bluetooth inside (the Chinese vendors lie) or it's completely unrecognized by Linux, no matter what I tried - all in vain, but I had an Asus USB BT400 adaptor - works out of the box fine
- Wireless keyboard and mouse work out of the box
- It also turned out there is no sound card, it's also completely unrecognized by Linux, no matter what I tried - all in vain, can't get sound through the headphones, however wireless headphones work fine through the Asus BT (took me 6 hours to make it work: install pulse and alsa, add a dummy alsa sound card in Yast, turn on Bluetooth and headphones, change KDE Multimedia sound settings for the wireless headphones - only then sound works)

Well, apart from a few hiccups, it looks and works just fine. I bought a big monitor with wireless keyboard and mouse and gave this system to my wife instead of a windows laptop - she just can't get enough of it! ))) So excited and releived after stupid windows.