Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: The problem with Gnome on openSUSE

  1. #1

    Default The problem with Gnome on openSUSE

    The problem is that some applications do not respond to a mouse click.In Cheese, I can not select a click by any effect. In Gnome Maps, I grab the map with the mouse, but I can not drag it. The totem video player does not respond to a click on the playback icon, and if you double-click that window it just turns on the whole screen. Can you please if anyone knows what the reason is. Thank you.
    For verification, I downloaded it on my computer to live Fedora mode and everything is working in it. I think the problem is somehow petty but I can not figure it out.

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: The problem with Gnome on openSUSE

    Hi and welcome to the openSUSE Forums!
    Gnome defaults to a Wayland session now and that might have problems with some HW.
    You may try to login to "Gnome on X session" to check if that is your case: at the login screen, enter password but click (or otherwise select) the little gear wheel and check "Gnome on X" before actually logging in.
    I cannot reproduce what you see, so it might be related to your HW or configuration.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3

    Default Re: The problem with Gnome on openSUSE

    Quote Originally Posted by OrsoBruno View Post
    Hi and welcome to the openSUSE Forums!
    Gnome defaults to a Wayland session now and that might have problems with some HW.
    You may try to login to "Gnome on X session" to check if that is your case: at the login screen, enter password but click (or otherwise select) the little gear wheel and check "Gnome on X" before actually logging in.
    I cannot reproduce what you see, so it might be related to your HW or configuration.
    I tested in session X using the password when I logged on. Just recently I recompiled from the sources and installed the Cheese and it did not solve the problem.
    I start the Cheese, I want to select the effect for the camera, I click, and nothing happens, the effects do not respond to a click.
    Totem video player is playing with such a defect in the form and the button at the bottom left does not react to the click of the left mouse .. if you double-click that window it simply unfolds. As if the objects inside the window do not respond to the click.I think the mistakes of these applications are related to each other

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: The problem with Gnome on openSUSE

    Sorry, cannot confirm: everything normal here both in installed Leap 15 and with last Tumbleweed 20180709 Live DVD.
    Describing your HW and showing the result of the following command issued in a terminal emulator might help in understanding your problem:
    Code:
    zypper lr -d
    Please insert the result between CODE tags (click the # button if you are using the web interface).
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5

    Default Re: The problem with Gnome on openSUSE

    Quote Originally Posted by OrsoBruno View Post
    Sorry, cannot confirm: everything normal here both in installed Leap 15 and with last Tumbleweed 20180709 Live DVD.
    Describing your HW and showing the result of the following command issued in a terminal emulator might help in understanding your problem:
    Code:
    zypper lr -d
    Please insert the result between CODE tags (click the # button if you are using the web interface).

    Приоритеты репозиториев не используются, у всех включенных репозиториев одинаковый приоритет.
    (The repository priorities are not used, all the repositories included have the same priority.)

    # | Псевдоним | Имя (Name) | Включен (Enable) | Проверка GPG | Обновление(Update) | Приоритет(Priority) | Тип(Type) | URI | Сервис(Service)
    ---+----------------------------------------+-----------------------------+---------+--------------+------------+-----------+--------+---------------------------------------------------------------------------------------+-------
    1 | download.nvidia.com-tumbleweed | nVidia Graphics Drivers | Да (Yes) | (r ) Да | Да | 99 | rpm-md | https://download.nvidia.com/opensuse/tumbleweed |
    2 | http-download.opensuse.org-185abb80 | Education | Да | (r ) Да | Да | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    3 | http-download.opensuse.org-8100b75e | home:Simmphonie:mono | Да | (r ) Да | Да | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    4 | http-download.opensuse.org-f0c1b963 | openSUSE:Factory | Да | (r ) Да | Да | 99 | rpm-md | http://download.opensuse.org/reposit...tory/snapshot/ |
    5 | openSUSE-20180707-0 | openSUSE-20180707-0 | Нет(NO) | ---- | ---- | 99 | rpm-md | hd:///?device=/dev/disk/by-id/usb-TDKMedia_Trans-It_Drive_070326DE971F0199-0:0-part2 |
    6 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository | Да | (r ) Да | Да | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/ |
    7 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository | Да | (r ) Да | Да | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/ |
    8 | repo-debug | openSUSE-Tumbleweed-Debug | Нет | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
    9 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Да | (r ) Да | Да | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
    10 | repo-oss | openSUSE-Tumbleweed-Oss | Да | (r ) Да | Да | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
    11 | repo-source | openSUSE-Tumbleweed-Source | Нет | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/...weed/repo/oss/ |
    12 | repo-update | openSUSE-Tumbleweed-Update | Да | (r ) Да | Да | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |

    Да ( YES) Нет (NO)

  6. #6

    Default Re: The problem with Gnome on openSUSE

    I used a clean installation like Leap and Thumbleweed
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] [1002:6840]
    Subsystem: Toshiba America Info Systems Radeon HD 7670M [1179:fb31]
    Kernel driver in use: radeon
    Toshiba Satellite C850-D3K
    glxinfo | grep -i opengl
    OpenGL vendor string: X.Org
    OpenGL renderer string: AMD TURKS (DRM 2.50.0 / 4.17.4-1-default, LLVM 6.0.0)
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.1.3
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.1 Mesa 18.1.3
    OpenGL shading language version string: 1.40
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.3
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
    OpenGL ES profile extensions:

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,897
    Blog Entries
    3

    Default Re: The problem with Gnome on openSUSE

    Quote Originally Posted by vitaliklinuxsuseuser View Post
    Приоритеты репозиториев не используются, у всех включенных репозиториев одинаковый приоритет.
    Code:
    (The repository priorities are not used, all the repositories included have the same priority.)  
    
    #  | Псевдоним                              | Имя (Name)                         | Включен (Enable) | Проверка GPG | Обновление(Update) | Приоритет(Priority) | Тип(Type)    | URI                                                                                   | Сервис(Service)
    ---+----------------------------------------+-----------------------------+---------+--------------+------------+-----------+--------+---------------------------------------------------------------------------------------+-------
     1 | download.nvidia.com-tumbleweed         | nVidia Graphics Drivers     | Да (Yes)      | (r ) Да      | Да         |   99      | rpm-md | https://download.nvidia.com/opensuse/tumbleweed                                       |       
     2 | http-download.opensuse.org-185abb80    | Education                   | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/              |       
     3 | http-download.opensuse.org-8100b75e    | home:Simmphonie:mono        | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |       
     4 | http-download.opensuse.org-f0c1b963    | openSUSE:Factory            | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/reposit...tory/snapshot/                 |       
     5 | openSUSE-20180707-0                    | openSUSE-20180707-0         | Нет(NO)     | ----         | ----       |   99      | rpm-md | hd:///?device=/dev/disk/by-id/usb-TDKMedia_Trans-It_Drive_070326DE971F0199-0:0-part2  |       
     6 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository        | Да      | (r ) Да      | Да         |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                   |       
     7 | packman.inode.at-openSUSE_Tumbleweed   | Packman Repository          | Да      | (r ) Да      | Да         |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                     |       
     8 | repo-debug                             | openSUSE-Tumbleweed-Debug   | Нет     | ----         | ----       |   99      | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                               |       
     9 | repo-non-oss                           | openSUSE-Tumbleweed-Non-Oss | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                                 |       
    10 | repo-oss                               | openSUSE-Tumbleweed-Oss     | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                     |       
    11 | repo-source                            | openSUSE-Tumbleweed-Source  | Нет     | ----         | ----       |   99      | NONE   | http://download.opensuse.org/source/...weed/repo/oss/                              |       
    12 | repo-update                            | openSUSE-Tumbleweed-Update  | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/                                       |
    Да ( YES) Нет (NO)
    Inserting code tags to quoted copy, to improve readability.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: The problem with Gnome on openSUSE

    Thank you so much for the help, I just found what was the problem. I was wondering what could interfere with the program's work and why such display. I checked Mesa, DRI and decided to install the driconf. In the driconf, I turned off the function "Allow exposure of visuals and fbconfigs with rgb10a2 formats" - Miscellaneous.This parameter is set by default, I did not apply it.And now the effects are selected in the Cheese. In the GNOME Maps I can move the map, and the Totem responds to the click of the mouse.
    It is possible to close a subject. Many thanks that responded to my problem

  9. #9
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: The problem with Gnome on openSUSE

    Quote Originally Posted by vitaliklinuxsuseuser View Post
    Thank you so much for the help, I just found what was the problem.
    Nice to see you are up and running again!
    I was wondering what could interfere with the program's work and why such display. I checked Mesa, DRI and decided to install the driconf. In the driconf, I turned off the function "Allow exposure of visuals and fbconfigs with rgb10a2 formats" - Miscellaneous.This parameter is set by default, I did not apply it.
    Checked in Leap 15 and it is NOT set by default. Cannot comment on Tumbleweed at the moment.
    It is possible to close a subject. Many thanks that responded to my problem
    We don't usually close threads here, writing that the problem is solved is enough.
    By the way, it seems that your repositories #4 and #10 are duplicate, pointing to the same place even if the addresses seem to be different. Consider deleting one (#4 perhaps?)
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  10. #10

    Default Re: The problem with Gnome on openSUSE

    Quote Originally Posted by OrsoBruno View Post
    Nice to see you are up and running again!

    Checked in Leap 15 and it is NOT set by default. Cannot comment on Tumbleweed at the moment.


    We don't usually close threads here, writing that the problem is solved is enough.
    By the way, it seems that your repositories #4 and #10 are duplicate, pointing to the same place even if the addresses seem to be different. Consider deleting one (#4 perhaps?)


    With all due respect .. I yesterday reinstalled the system (openSUSE leap 15 install) by formatting all the partitions, and after installation I found that the errors are present, and in the driconf was that miserable function is included.I do not know for sure, but maybe the driconf has a configurator and configures my radeon 7600 at startup.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •