Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: how use MetaTrader 5 on OpenSUSE

  1. #1

    Default how use MetaTrader 5 on OpenSUSE

    I have been installing MetaTrader for a long time, but no success
    https://www.metatrader5.com/pt/download
    Before, until last year, the installation flowed normally.

    Now when I try to install a window appears asking to configuring such a "proxy server"
    I do not have this server and I do not even know what that is.

    I have seen many issues about how to install Metatrader
    But nothing I do solves the problem.
    Now even install the new LEAP 15 but MetaTRader also did not work
    I searched for solution on the site winehq and they say that with Distribution UBUNTO MetaTrader Works
    I do not want to use another distribution
    But seeing that MetaTrader works with Linux Ubuntu, I do not understand why it does not work with OpenSUSE
    Please, can not you solve this problem?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,144
    Blog Entries
    2

    Default Re: how use MetaTrader 5 on OpenSUSE

    The Metatrader install on Linux document indicates that Metatrader is a Windows app, so you have to install Wine
    https://www.metatrader5.com/en/termi.../install_linux

    So,
    Pls post the guide you're using to install Wine and then Metatrader,
    And if you run into problems, post the error however you can.
    If the problem is captured in a log, you can post the log.
    If an error is displayed in a window, do a screenshot.
    if the error is displayed in a text console (window), then most times you can do a copy and paste.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: how use MetaTrader 5 on OpenSUSE

    Sorry, but the problem is too simple to describe.
    I downloaded setup.exe from the address I provided

    https://www.metatrader5.com/pt/download

    When I run it appears a screen asking for information about a "proxy server" that does not exist.
    After that, the installation program closes ....
    In previous versions of OpenSUSE this did not happen and MetaTrader installed without problems

    There is no more information to pass you through;
    If I send images from my screen or texts that appear on my screen, you will see that there is nothing beyond what I am already describing here

    To see the problem you must try to install MetaTrader ... Someone could try this installation and see the problem ...

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,704

    Default Re: how use MetaTrader 5 on OpenSUSE

    Did you try to start form the command line that normally gives more info of problems. Also since this is a Windows program you must have a compatible version of Wine.

  5. #5

    Default Re: how use MetaTrader 5 on OpenSUSE

    If I start from the command line, it will occur that the installation program runs normally, as I described earlier.
    But, does not install the MetaTrader.
    When the operation ends the command prompt appears with no messages.
    This is like an execution that found no errors.

    In my lay way of seeing, it seems that the following sequence is performed:
    1-The installation code "setup.exe" searches the internet for an address to download the updated application
    2-Can not find address and try another path
    3-The other path is requested in a window asking for the address of a "proxi" that I do not have and I do not even know how to do a "proxi"
    4-As "setup.exe" does not find how to download the application, it simply ends the attempt with a message saying that it was not possible to install.

    The logical conclusion is that "setup.exe" is faulty, however on Windous machines it works perfectly.
    So, I'm looking for a solution on how to make "MetaTrader" work again with Linux Wine. Well, before, it worked ....
    Please, to help me try doing this installation yourself

  6. #6

    Default Re: how use MetaTrader 5 on OpenSUSE

    That's the output from command line:
    Code:
    sergio@linux-n7o7:~/.wine/drive_c/metaTrader/oficial> wine mt5setup.exe
    000b:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    000f:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    0012:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    000d:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    001d:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    0022:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    0029:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    0009:fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for -03, bias 180, std (d/m/y): 18/02/2018, dlt (d/m/y): 4/11/2018
    0009:fixme:thread:SetThreadStackGuarantee (0x33f978): stub
    0017:fixme:mountmgr:harddisk_ioctl returning zero-filled buffer for IOCTL_VOLUME_GET_VOLUME_DISK_EXTENTS
    0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
    0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
    0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d0c10 (device=2d access=0 func=304 method=0)
    0017:fixme:mountmgr:harddisk_ioctl returning zero-filled buffer for IOCTL_VOLUME_GET_VOLUME_DISK_EXTENTS
    0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
    0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
    0017:fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d0c10 (device=2d access=0 func=304 method=0)
    0030:fixme:ver:GetCurrentPackageId (0xb3fe9c (nil)): stub
    0035:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0038:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0031:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003f:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0032:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0034:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0041:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003b:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003a:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0039:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0040:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003d:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003c:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0043:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0033:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0037:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0042:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0031:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0038:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003c:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003f:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0037:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0041:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003a:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003d:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0040:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0042:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0039:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0043:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0032:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003c:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003b:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0038:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003f:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0037:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003a:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0041:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003d:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0042:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0043:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0039:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0040:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0032:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    003b:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0044:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    0044:fixme:secur32:schan_QueryContextAttributesW Unhandled attribute 0x64
    sergio@linux-n7o7:~/.wine/drive_c/metaTrader/oficial>

  7. #7

    Default Re: how use MetaTrader 5 on OpenSUSE

    I'm sad.
    Is not there anyone who knows how to solve my problem?

    I talked at the Winehq Forum, there they said that the MetaTrader program runs standard with openSUSE
    One of them told me that using Leap 42.2
    I have a friend here in Brazil who has 4 machines, and has already tested on all using OpenSUSE 13.2, Leap 42.1 the Leap 42.2 and also the Leap 15
    But it was not successful either.
    Please, what should I do?

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: how use MetaTrader 5 on OpenSUSE

    I'm guessing that firewalld is blocking wine from accessing the internet
    I haven't tested internet access under wine so I can't really give you an advice how to fix this but you could temporally turn off firewalld and see if there is a wine option in Firewall config center in Yast

  9. #9

    Default Re: how use MetaTrader 5 on OpenSUSE

    It looks like there are similar problems on newer Ubuntu versions: https://www.mql5.com/en/forum/60949/page2


    All things mentioned on that forum should be available in openSUSE. winetricks, wine-mono, wine-gecko and 32bit version of gnutls. Beware of you will maybe need a 32bit wine version.

  10. #10

    Default Re: how use MetaTrader 5 on OpenSUSE

    Hello guys,

    I just wanted to say, that to run mt5 on openSuse Leap 15.0 is possible, but not as easy. I had switched from Leap 15.0 to ubuntu a week ago, due to other problems, and still can't find the right way to install mt5 on ubuntu. Cause errors are slightly different.

    I just wanted to share direct way how did I installed mt5 on my Leap 15.0.

    First of all, you have to understand that setup you download from vendor is 64bit. And there is some bugs i think between windows and linux archs, so you have to install this setup in 32bit manner. But I think you've already maneged to find this out.

    So, first off all you have to prepare wine for 32 bit installing. I have done this in following lines:

    Code:
    WINEARCH=win32 WINEPREFIX=/home/user/. wine32 winecfg
    That line should invoke wine conf window, and you should select, if not selected yet, os version at least windows 7.

    Then launch setup in the same way, otherwise, i think wine will stay to 64bit mode:

    Code:
    WINEARCH=win32 WINEPREFIX=/home/user/. wine32 wine /destination to your setup/mt5setup.exe
    Than you should invoke setup and get those bunch of error lines, but this time you will see setup that will be in 32bit version. Though, you have to carefully read those error lines. When I installed on Leap 15.0 it asked for some audio packages. I think pulseaudio or something, and if not it often tells you in whick package requaired packages are included. So after installing right package and running the last line again, it started to run without any proxy errors. Install went smoothly and successfully. Those proxy errors you get installing in wrong way, I think, is nothing related to proxy - so no digging arround your wirewalls, it's just a timewaster. I believe Its just not an elegant way program tries to solve error exceptions, that's it. The default respondance.

    In my ubuntu linux, mt5 asked for winbind package, after installing it, this requairement disapeared, but still left those errors with "stub" word in the end left. And I cannot manage to find the problem. If someone knows the way how to install it on ubuntu bionic beaver, please, let me know...

    P. S. Sorry for my english, and mistakes. It's hard to type with homer simpson fingers om those little tiny todays smartphones...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •