Results 1 to 3 of 3

Thread: Dolphin SMB Zugriff auf QNAP NAS - diverse Fehlfunktionen

  1. #1
    Join Date
    Jun 2008
    Location
    Bonn, Germany
    Posts
    63

    Default Dolphin SMB Zugriff auf QNAP NAS - diverse Fehlfunktionen

    Ich habe ein QNAP TS-228A NAS mit aktueller Software QTS 4.3.4.0597 mit mehreren per SMB und NFS erreichbaren Freigaben im LAN.
    Auf dem NAS sind neben dem Admin-Benutzer individuelle Benutzer für die einzelnen Familienmitglieder eingerichtet, mich eingeschlossen.
    Der Admin-Benutzer wird nur für administrative Tätigkeiten benutzt.
    Die Optionen "Advanced Folder Permissions" und "Windows ACL Support" sind aktiv.
    Ein "Portal Folder" ist nicht eingerichtet.
    (Alle Angaben beziehen sich auf die englische Oberfläche, weil die deutsche Übersetzung so grottig ist.)

    Der Zugriff per SMB von Windows-Clients und der Zugriff per NFS Mount per /etc/fstab von meiner Opensuse Leap 42.3 Workstation funktionieren einwandfrei.
    Wenn meine Frau von ihrem Notebook (ebenfalls Opensuse Leap 42.3, aktueller Updatestand) aus mit Dolphin auf die Freigaben zugreifen will, gibt's diverse Probleme.

    1. Wenn sie in Dolphin auf "Netzwerk" und dann auf "Samba-Freigaben" klickt, erscheint nach einiger Wartezeit am oberen Rand des Hauptfensters ein roter Balken mit dem Text:
    Es ist keine Arbeitsgruppe im lokalen Netzwerk auffindbar. Dies könnte durch eine aktivierte Firewall verursacht werden.
    In YaST - Firewall ist das einzige Netzwerkinterface (br0) als "intern" eingestellt, was laut Erläuterungstext alles erlauben soll und folgerichtig auch keine weiteren expliziten Freigaben erlaubt.

    2. Wenn sie die Freigaben in Dolphin - Netzwerk durch Klick auf "Add Network Folder" (ja, das steht auf englisch da, obwohl alles andere deutsch ist) von Hand verbindet und ihre NAS-Anmeldedaten eingibt, wird der Inhalt nicht vollständig angezeigt. Wir haben z.B. eine Freigabe "Multimedia" mit einem Ordner "Pictures" und mehreren Unterordnern, deren Namen teils mit einer Jahreszahl, teils mit einem Wort beginnen. Die mit einem Wort beginnenden werden angezeigt, die mit einer Jahreszahl beginnenden nicht. In der Web-Oberfläche des NAS sind keine Unterschiede in den Zugriffsrechten zwischen den beiden Ordnergruppen zu erkennen.

    3. Auf dem obengenannten Ordner "Pictures" hat sie Schreibzugriff und konnte auch in Dolphin erfolgreich einen Unterordner "2018-04-Schottland" anlegen. Wenn sie dort allerdings nun per Copy/Paste Dateien hineinkopieren will, ist die Option "Einfügen" in Dolphin ausgegraut, als ob der Ordner schreibgeschützt wäre. Wieder zeigt die Web-Oberfläche des NAS keine Unterschiede in den Zugriffsrechten zum übergeordneten Ordner "Pictures" oder den anderen, bereits vorhandenen Unterordnern an. Über die Upload-Funktion in der Web-Oberfläche konnte sie dieselben Dateien problemlos in den Ordner kopieren.

    Ich habe versucht die Probleme von der Kommandozeile aus zu untersuchen. Dort sind allerdings die SMB-Mounts von Dolphin gar nicht zu sehen.

    Was macht Dolphin da und welche Möglichkeit habe ich, die Problemursache(n) einzugrenzen?
    Gibt es eine laiengeeignete Alternative für den NAS-Zugriff?

  2. #2
    Join Date
    Jun 2008
    Location
    Bonn, Germany
    Posts
    63

    Default Re: Dolphin SMB Zugriff auf QNAP NAS - diverse Fehlfunktionen

    Im QNAP-Forum, wo ich die Frage parallel auch gestellt hatte, bekam ich die Antwort:
    Da es bei Deinem PC ja funktioniert kann es eigentlich nicht an der QNAP liegen.
    Dem habe ich wenig entgegenzusetzen.
    Also ist es wohl ein Bug in der speziellen Art und Weise, wie Dolphin seine SMB-Zugriffe am Kernel vorbei macht.
    Gibt es darüber irgendwo nähere Informationen?
    Welche SMB-Version verwendet Dolphin?
    Unterstützt er irgendwelches Logging oder Debugging Output?

  3. #3
    Join Date
    Jun 2008
    Location
    Bonn, Germany
    Posts
    63

    Lightbulb Re: Dolphin SMB Zugriff auf QNAP NAS - diverse Fehlfunktionen

    Da offenbar niemand etwas darüber weiß, was Dolphin da treibt, und ich keine Lust hatte selber in den Quellcode zu tauchen, habe ich den Ansatz jetzt aufgegeben und den NAS-Zugriff meiner Frau auf die im openSUSE Reference Manual beschriebene Methode via Automounter umgestellt. Das war viel einfacher als befürchtet:

    1. In der Datei /etc/auto.master folgende Zeile einfügen (wo, ist egal):
      Code:
      /smb /auto.smb
    2. Das Verzeichnis /etc/creds und darin eine Datei /etc/creds/{Name des NAS} mit folgendem Inhalt anlegen:
      Code:
      username={Benutzername meiner Frau auf dem NAS}
      password={Passwort meiner Frau auf dem NAS}
      domain={SMB-Arbeitsgruppe des NAS}
      (Wegen des Klartextpassworts empfiehlt es sich den Zugriff auf diese Datei auf root zu beschränken.)
    3. Den autofs-Dienst aktivieren und starten:
      Code:
      sudo systemctl enable autofs 
      sudo systemctl start autofs
    4. Einen Symlink von ihrem Home-Verzeichnis auf /smb/{Name des NAS} legen, den sie in Dolphin anklicken kann, um den Automount zu triggern.

    Das funktioniert einwandfrei. Die Probleme bzw. Merkwürdigkeiten waren also ausschließlich von Dolphin's eigenwilligem SMB-Zugriffsverfahren verursacht. Einziger Wermutstropfen bei der Lösung ist das Klartextpasswort in der Credentials-Datei.

    Vielleicht hilft's ja jemandem.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •