Results 1 to 4 of 4

Thread: Skanlite doesn't see HP multi-function printers

  1. #1
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    287

    Default Skanlite doesn't see HP multi-function printers

    So I just had to re-install Tumbleweed, with the 7/3 version.

    On the previous install, after I installed my wifi-based HP 8700 using hp-toolbox (a very nice utility), I then opened skanlight and it found the scanner on that device automagically. Now skanlite says, "Sorry. No devices found." From the HP Toolbox, I can click the link for the printer's webpage and use that to scan into the browser, then save a PDF, so I'm not dead in the water, but I actually favor skanlite when it works.

    I also have an HP Envy 4510 to which the paragraph above applies equally. Any idea either what's causing this behavior or what config files to change manually?

    Thanks,

    GEF

    PS: I had Leap 15 installed for a day, with the same problem.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,009
    Blog Entries
    1

    Default Re: Skanlite doesn't see HP multi-function printers

    Hi gfagan. For the HPLIP (hpaio) scanner backend to work, the CUPS backend must also be correctly configured for the HP printers. That's explained here
    https://developers.hp.com/hp-linux-i...roubleshooting

    BTW, that can be checked using
    Code:
    hp-check -t
    Code:
    lpstat -t
    Assuming that checks out ok, also make sure that 'hpaio' is present and uncommented in /etc/sane.d/dll.conf, and the scanner should hen be detected okay by whatever scanning application you're using.
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    287

    Default Re: Skanlite doesn't see HP multi-function printers

    Thanks, Deano - hpaio in dll.conf was commented out. -GEF

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,009
    Blog Entries
    1

    Default Re: Skanlite doesn't see HP multi-function printers

    Quote Originally Posted by gfagan View Post
    Thanks, Deano - hpaio in dll.conf was commented out. -GEF
    Glad to have been of assistance.
    openSUSE Leap 15.0; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •