Results 1 to 6 of 6

Thread: Printing in Okular

  1. #1

    Default Printing in Okular

    When I try printing in okular it gives me always Duplex=None as default, although in cups KDE printer settings etc. "long edge" is given. How can I change the default in okular?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,372
    Blog Entries
    1

    Default Re: Printing in Okular

    Quote Originally Posted by klausmoenig View Post
    When I try printing in okular it gives me always Duplex=None as default, although in cups KDE printer settings etc. "long edge" is given. How can I change the default in okular?
    The KDE 'Print' > 'Options>>' dialogue does show 'Duplex Printing' defaulted to 'None', but if you examine 'Properties' > 'Advanced', you'll see the currently configured printer options which will match those set via the printer settings utility, (and these options are set in the printer PPD file located in the /etc/cups/ppd/ directory).
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3
    Join Date
    Jul 2017
    Location
    Melbourne, Australia
    Posts
    51

    Default Re: Printing in Okular

    Quote Originally Posted by deano_ferrari View Post
    The KDE 'Print' > 'Options>>' dialogue does show 'Duplex Printing' defaulted to 'None', but if you examine 'Properties' > 'Advanced', you'll see the currently configured printer options which will match those set via the printer settings utility, (and these options are set in the printer PPD file located in the /etc/cups/ppd/ directory).
    However, Okular still defaults to Duplex Printing - None, and consequently prints single sided. This has happened to me only recently, since upgrading from 42.3. Qpdfview holds the duplex setting from document to document, while Okular loses it.

    There are a couple of Ubuntu bugs that look like this, but none in KDE's bug tracker. This has happened in other distros in the past, and got fixed sooner or later. It's just a nuisance, as I almost always print duplex.

  4. #4

    Default Re: Printing in Okular

    **Bump**

    I have had the same thin g with Okular ever since I upgraded to Leap 15.

    Yes, the Properties -> Advanced page does recognise what has been specified by CUPS but, as others have noted, Okular overrides this. It doesn't seem to be happening with any other application so the problem seems to lie with Okular (and specifically the version distributed with Leap 15, since it worked fine before).

    Is there somewhere this can be brought to the attention of the Okular maintainers?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,372
    Blog Entries
    1

    Default Re: Printing in Okular

    Quote Originally Posted by johngwalker View Post
    Is there somewhere this can be brought to the attention of the Okular maintainers?
    The existing Ubuntu bug reports (that you referred to earlier) seem to suggest a problem with libQt5PrintSupport5...
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1777615
    https://bugs.launchpad.net/ubuntu/+s...c/+bug/1776173
    ...and a patch is mentioned, although there may be other apparent printing option issues as well.

    You could file a bug report with openSUSE bugzilla....
    https://en.opensuse.org/openSUSE:Submitting_bug_reports

    or upstream at
    https://bugs.kde.org/
    openSUSE Leap 15.0; KDE Plasma 5

  6. #6

    Default Re: Printing in Okular

    Thanks, Delano. I hadn’t realised that Okular was part of the KDE family. I’ll report the problem. But there do seem to be a lot of bugs already outstanding for the application.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •