Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

  1. #1
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    I installed a Leap 15 on an Intel Atom Z8350 mini computer, installation went well, but during boot it hangs with endless errors ''power supply fuel gauge driver failed" (see picture https://cloud.mail.ru/public/3r4d/XE2kgbXeH). It actually boots to KDE Plasma, but after a few seconds hangs. Switching to another console (Ctrl-Alt-F1) shows those errors non-stop until something overflows and the computer reboots.

    I use EXT4 FS. Tried btrFS and XFS - same errors happen. Tried 'acpi=off' - doesn't help. Sorry I can't make any logs because it hangs just after a few seconds.

    What can be the problem?

    Thank you.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,259
    Blog Entries
    1

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    The 'axp288_fuel_gauge' kernel module is a battery monitoring for AXP288 power management hardware (PMIC device). It's unlikely to be the cause of KDE crashing IMO, but maybe it wouldn't hurt to blacklist it for now if it's not working. You could also try starting IceWM session at the login screen perhaps?
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    Quote Originally Posted by linuxoidoz View Post
    I installed a Leap 15 on an Intel Atom Z8350 mini computer, installation went well, but during boot it hangs with endless errors ''power supply fuel gauge driver failed" (see picture https://cloud.mail.ru/public/3r4d/XE2kgbXeH). It actually boots to KDE Plasma, but after a few seconds hangs. Switching to another console (Ctrl-Alt-F1) shows those errors non-stop until something overflows and the computer reboots.

    I use EXT4 FS. Tried btrFS and XFS - same errors happen. Tried 'acpi=off' - doesn't help. Sorry I can't make any logs because it hangs just after a few seconds.

    What can be the problem?

    Thank you.
    Of topic: I'd be curious what brand and model the mini computer is if you don't mind telling me Small form factors just always peak my interest.
    I don’t have anything to hide, but I don’t have anything I want to show you either.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,259
    Blog Entries
    1

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    It might be possible that disabling desktop effects helps. You could try removing or renaming kwinrc...
    Code:
    mv ~/.config/kwinrc ~/.config/kwinrc-old
    ...from outside the KDE session eg via a console at init 3. Then see if the Plasma 5 session is more stable again.
    openSUSE Leap 15.0; KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    Quote Originally Posted by deano_ferrari View Post
    The 'axp288_fuel_gauge' kernel module is a battery monitoring for AXP288 power management hardware (PMIC device). It's unlikely to be the cause of KDE crashing IMO, but maybe it wouldn't hurt to blacklist it for now if it's not working. You could also try starting IceWM session at the login screen perhaps?
    BTW it's a mini PC, not a laptop, it doesn't have a battery.

    KDE is not crashing at the start, the fuel gauge errors start as soon as it starts booting, long in advance of KDE.

    Would you mind telling me how I can blacklist that? And how to start IceWM?

    BTW, the mini PC is X5. That's all there is on it.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  6. #6
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    Quote Originally Posted by deano_ferrari View Post
    It might be possible that disabling desktop effects helps. You could try removing or renaming kwinrc...
    Code:
    mv ~/.config/kwinrc ~/.config/kwinrc-old
    ...from outside the KDE session eg via a console at init 3. Then see if the Plasma 5 session is more stable again.
    I can't do anything in any console because the errors are just running like mad and all consoles just hang
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,259
    Blog Entries
    1

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    KDE is not crashing at the start, the fuel gauge errors start as soon as it starts booting, long in advance of KDE.
    Yes, got that already. However, it's not clear to me that the module errors have anything to do with your KDE issue.

    Would you mind telling me how I can blacklist that?
    Try blacklisting via a custom file in /etc/modprobe.d/ directory eg blacklist-axp288.conf with the following entry
    Code:
    blacklist axp288_fuel_gauge
    And how to start IceWM?
    At the login screen you should be able to choose your preferred desktop session. Logging out of the KDE session will get you there, or press and hold CTRL+ALT+Backspace.

    You could also configure it with update-alternatives...
    Code:
    sudo update-alternatives --config default-xsession.desktop
    and it will take effect the next time the X-server is (re)started.
    openSUSE Leap 15.0; KDE Plasma 5

  8. #8
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    I'm telling you I can't do anything neither in KDE, nor in any console, nor anywhere because the PC simply hangs. There is just nothing I can go and change anything, it's unresponsive. The only place I can do anything is the boot menu before it boots. That's it. After I press the boot button, it spits out thousand of those errors until it restarts. All I've got is that black screen with thousands of errors going by.

    If I press Ctrl-Alt-F1 - I've got the running errors. If I press Ctrl-Alt-F5 - I've got the running errors. If I press Ctrl-Alt-Backspace(x2) - I've got the running errors.

    Can I disable the module at boot time?
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  9. #9
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    399

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    Just FYI: I did a network install form a USB. If that matters in any way...
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,259
    Blog Entries
    1

    Default Re: Leap 15 on Intel Atom 'power supply fuel gauge driver failed' endless errors

    If you're comfortable working at runlevel 3, you can boot to it with an "on the fly" edit of the grub2 boot entry. Hit 'e' as soon as you have the grub boot screen, and scroll down with arrow keys unitl you get to the linux entry. Press the 'end' key to get to the end of the line and add a space then a '3', then press F10 to boot.

    Here's a graphical guide if it's still not clear...
    https://www.if-not-true-then-false.c...evel-on-grub2/

    You'll need to fire up a CLI editor (eg nano or pico) to make the required changes. Once you're done, reboot so that the blacklist takes effect. See how that goes.
    Last edited by deano_ferrari; 01-Jul-2018 at 02:18.
    openSUSE Leap 15.0; KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •