Results 1 to 7 of 7

Thread: Shutter on Leap15

  1. #1
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default Shutter on Leap15

    Trying to install Shutter (0.94-lp150.74.1) from the standard repos on Leap15 x64.
    Install and runs OK, but when PrtScrn is pressed, the program crashes (trying to run 2x copies)
    Have also tried installng the experimental package from https://software.opensuse.org/ - same result.
    Anybody had similar or got any answers?
    Have reported a bug at https://bugs.launchpad.net/shutter/+bug/1779516
    Thanks.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  2. #2

    Default Re: Shutter on Leap15

    Looks like you got a response to your bug report pointing to this thread: https://bugs.launchpad.net/shutter/+bug/731874

    Perhaps filing a bug report at https://bugzilla.opensuse.org/index.cgi will put it on the radar.
    I don’t have anything to hide, but I don’t have anything I want to show you either.

  3. #3
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default Re: Shutter on Leap15

    Submitted this bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1099774 on 1/7/18, and a fix was submitted on 2/7/18, but as of now (10/9/18), I still have the issue on Leap15 (fully updated...)
    Anyone know how I can get this fixed? Would really appreciate it, as I use (or would like to!) it fairly often.
    Does a cache need cleaning/config deleted to get it to work??

    Thanks.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  4. #4
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default Re: Shutter on Leap15

    Seriously, does Bugzilla work??
    This is ridiculous!!
    Submitted this bug MONTHS ago, apparently fixed days after submitted, and should have been updated in the repos shortly thereafter, APPARENTLY...
    But still not working on a fully updated system, have made several enquiries both here and on bugzilla, with no response, or information on how to actually get it to install.
    If the issue is elsewhere (upstream or whatever..) fair enough, but would really be good if someone could comment as such.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: Shutter on Leap15

    software.opensuse.org/search is down for maintenance as I'm writing this,

    But,
    Based on the bugzilla URL above,

    There was a long delay between the bug was reported and a fix accepted by QA, as far as I can tell the bug passed all tests and should have been in the Update repo in July according to the following
    https://build.opensuse.org/package/b....2.3.1.src.rpm

    So,
    Assuming you've run a "zypper update" on LEAP 15, you should have gotten the patched version.
    If the problem still exists, then either the patch didn't work or it's a different issue and you may need to either re-open or submit a new bug.

    From the Shutter project website...
    Bug fix announcement (Sept 10 2018) so there may be something new
    http://shutter-project.org/2018/09/n...elease-0-94-1/

    Until fixed,
    It's possible to download source from the following page and build yourself
    http://shutter-project.org/wp-conten...releases/tars/
    or
    https://code.launchpad.net/shutter
    https://launchpad.net/shutter/+download

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6
    Join Date
    Jun 2008
    Location
    Elliott Heads, Qld, Aus
    Posts
    201

    Default Re: Shutter on Leap15

    Quote Originally Posted by tsu2 View Post
    software.opensuse.org/search is down for maintenance as I'm writing this,

    So,
    Assuming you've run a "zypper update" on LEAP 15, you should have gotten the patched version.
    If the problem still exists, then either the patch didn't work or it's a different issue and you may need to either re-open or submit a new bug.
    Yep, have definitely updated regularly, and removed previous configs etc 'just in case'...

    Quote Originally Posted by tsu2 View Post
    From the Shutter project website...
    Bug fix announcement (Sept 10 2018) so there may be something new
    http://shutter-project.org/2018/09/n...elease-0-94-1/

    Until fixed,
    It's possible to download source from the following page and build yourself
    http://shutter-project.org/wp-conten...releases/tars/
    or
    https://code.launchpad.net/shutter
    https://launchpad.net/shutter/+download

    TSU
    Can't find any 'recent' src files - found a couple of binaries, but no change...
    Have submitted another bug. Thanks.
    i5/8GB
    openSuse Leap15.1
    KDE Plasma 5.12.8 (and Gnome - In training!)
    Linux Counter 130995

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,977

    Default AW: Shutter on Leap15

    I have disabled the shortcut for screenshots in systemsettings5, made a personal shortcut for screenshot and if shutter is running, I have to press 2 time the shortcut, if shutter is not running only 1 time.
    Last edited by Sauerland; 27-Sep-2018 at 16:55.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •