Results 1 to 8 of 8

Thread: nvidia driver install with black screen, kde

  1. #1

    Default nvidia driver install with black screen, kde

    I reinstalled opensuse 42.3, using the whole hard drive.

    I used the yast method to install nvidia driver.
    SDB:NVIDIA drivers - openSUSE

    When the boot finished, I saw a black screen with working mouse cursor.

    I used the opensuse dvd upgrade install and removed the nvidia repo. I rebooted to working system.

    I used this page for one-click install of nvidia drivers.
    openSUSE-Community.Org - Multimedia Codecs including MP3, DVD, DivX, MP4, x265, x264, WMV, WMA, MOV and more for openSUSE via one click

    Same result. Black screen with working cursor. Again, I completed a dvd upgrade install. System working, but in 640x480 screen resolution. (Same as above upgrade install.)

    For security reasons, I'm not posting my system info. I can private mail that info.

    Need help.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: nvidia driver install with black screen, kde

    If you did an "upgrade" remove and reinstall NVIDIA driver. The upgrade may have replaced the NVIDIA special mesa files.

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,979

    Default AW: nvidia driver install with black screen, kde

    Did you update your System before you install the Nvidia driver?

    And if you install the Nvidia driver the hard way, do you deinstall the driver from Repo?

    Is it only a Nvidia card or hybrid:
    Code:
    /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'

  4. #4

    Default Re: AW: nvidia driver install with black screen, kde

    Quote Originally Posted by Sauerland View Post
    Did you update your System before you install the Nvidia driver?

    And if you install the Nvidia driver the hard way, do you deinstall the driver from Repo?

    Is it only a Nvidia card or hybrid:
    Code:
    /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    Yes, I always use update software on bootup.

    Standard nvidia 3rd party card, '400 series or later'. With Yast install of nvidia drivers, I clicked on the correct driver

    Didn't do 'the hard way', manual terminal. I will try that next.

    Upgrade installs on previous versions of opensuse usually gets me 1024x768. This the upgrade install gives me 640x480.


    Steps:

    #1: boot opensuse 42.3
    #2: click on upgrade install and wait
    #3: on repo list don't click on anything. Then click next, repeating.
    #4: let upgrade run
    #5: processing - removes all nvidia drivers and installs standard drivers.
    #6: reboot to 640x480 resolution

    I'v used this many times over with no problems, to uninstall nvidia drivers and multi-media community apps. Usually on multi-media codecs when they cause system problems.

  5. #5

    Default Re: nvidia driver install with black screen, kde

    Quote Originally Posted by gogalthorp View Post
    If you did an "upgrade" remove and reinstall NVIDIA driver. The upgrade may have replaced the NVIDIA special mesa files.
    Yast->software management -> search mesa --> install mesa drivers

    Right?


    So, the opensuse dvd has an upgrade install bug?

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: nvidia driver install with black screen, kde

    No just remove then install NVIDA driver. NVIDIA has it own mesa programs and will not work with the stock drivers. you must use the NVIDIA ones with NVIDIA

  7. #7

    Default Re: nvidia driver install with black screen, kde

    Quote Originally Posted by gogalthorp View Post
    No just remove then install NVIDA driver. NVIDIA has it own mesa programs and will not work with the stock drivers. you must use the NVIDIA ones with NVIDIA
    When I did the 'upgrade install' to uninstall the nvidia drivers, the mesa (non-nvidia) installed, 640x480.


    I installed the nvidia drivers manually. This is the relevant output. I have the whole command output in a text file.

    zypper inr -r NVIDIA

    The following 4 NEW packages are going to be installed:
    nvidia-computeG04 nvidia-gfxG04-kmp-default
    nvidia-glG04 x11-video-nvidiaG04

    4 new packages to install.
    Overall download size: 78.0 MiB. Already cached: 0 B.
    After the operation, additional 365.0 MiB will be used.
    Continue? [y/n/...? shows all options] (y): y
    Retrieving package nvidia-gfxG04-kmp-default-390.67_k4.4
    (1/4), 8.2 MiB ( 45.6 MiB unpacked)
    Retrieving: nvidia-gfxG04-kmp-default-[done (3.9 MiB/s)]
    Retrieving package nvidia-glG04-390.67-8.1.x86_64
    (2/4), 27.7 MiB (137.3 MiB unpacked)
    Retrieving: nvidia-glG04-390.67-8.1.x8[done (3.9 MiB/s)]
    Retrieving package nvidia-computeG04-390.67-8.1.x86_64
    (3/4), 14.6 MiB ( 70.7 MiB unpacked)
    Retrieving: nvidia-computeG04-390.67-8[done (3.6 MiB/s)]
    Retrieving package x11-video-nvidiaG04-390.67-8.1.x86_64
    (4/4), 27.5 MiB (111.4 MiB unpacked)
    Retrieving: x11-video-nvidiaG04-390.67[done (3.9 MiB/s)]
    Checking for file conflicts: .....................[done]
    (1/4) Installing: nvidia-gfxG04-kmp-default-390.67[done]
    Additional rpm output:
    make: Entering directory '/usr/src/linux-4.4.138-59-obj/x86_64/default'
    Building modules, stage 2.
    MODPOST 0 modules
    make: Leaving directory '/usr/src/linux-4.4.138-59-obj/x86_64/default'
    /usr/src/kernel-modules/nvidia-390.67-default /
    make[1]: Entering directory '/usr/src/linux-4.4.138-59'
    make[2]: Entering directory '/usr/src/linux-4.4.138-59-obj/x86_64/default'
    CONFTEST: INIT_WORK
    CONFTEST: remap_pfn_range
    CONFTEST: hash__remap_4k_pfn
    CONFTEST: follow_pfn
    CONFTEST: vmap
    CONFTEST: set_pages_uc
    CONFTEST: set_memory_uc
    ...
    Modprobe blacklist files have been created at /etc/modprobe.d to prevent Nouveau from loading. This can be reverted by deleting /etc/modprobe.d/nvidia-*.conf.

    *** Reboot your computer and verify that the NVIDIA graphics driver can be loaded. ***

    grep: /etc/sysconfig/kernel: No such file or directory
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknown symbol __x86_indirect_thunk_rbp
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknown symbol __x86_indirect_thunk_rdx
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-drm.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-drm.ko needs unknown symbol __x86_indirect_thunk_r8
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rbp
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r15
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r11
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rdx
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r14
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rbx
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r13
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r10
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rcx
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r9
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r12
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r8
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia.ko needs unknown symbol __x86_indirect_thunk_rdx
    depmod: WARNING: //lib/modules/4.4.76-1-default/updates/nvidia.ko needs unknown symbol __x86_indirect_thunk_r8
    Warning: /lib/modules/4.4.76-1-default is inconsistent
    Warning: weak-updates symlinks might not be created
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknown symbol __x86_indirect_thunk_rbp
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknown symbol __x86_indirect_thunk_rdx
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-drm.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-drm.ko needs unknown symbol __x86_indirect_thunk_r8
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rbp
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r15
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r11
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rdx
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r14
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rbx
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r13
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r10
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_rcx
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r9
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r12
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-uvm.ko needs unknown symbol __x86_indirect_thunk_r8
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia.ko needs unknown symbol __x86_indirect_thunk_rax
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia.ko needs unknown symbol __x86_indirect_thunk_rdx
    depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia.ko needs unknown symbol __x86_indirect_thunk_r8


    (2/4) Installing: nvidia-glG04-390.67-8.1.x86_64 .[done]
    Additional rpm output:
    update-alternatives: using /usr/lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so to provide /usr/lib64/xorg/modules/extensions/libglx.so (libglx.so) in auto mode
    /var/tmp/rpm-tmp.fRaUCV: line 12: 9195 Bus error (core dumped) /sbin/ldconfig
    warning: %post(nvidia-glG04-390.67-8.1.x86_64) scriptlet failed, exit status 135


    (3/4) Installing: nvidia-computeG04-390.67-8.1.x86[done]
    Additional rpm output:
    warning: %post(nvidia-computeG04-390.67-8.1.x86_64) scriptlet failed, signal 7
    ...
    (4/4) Installing: x11-video-nvidiaG04-390.67-8.1.x[done]
    Additional rpm output:
    /var/tmp/rpm-tmp.XELOmT: line 1: 9204 Bus error (core dumped) /sbin/ldconfig
    grep: etc/X11/xorg.conf: No such file or directory
    Using MD5DIR="/var/adm/SuSEconfig/md5"...
    No changes for /etc/X11/xdm/Xservers
    No changes for /etc/X11/xdm/xdm-config
    ...
    Output of nvidia-gfxG04-kmp-default-390.67_k4.4.76_1-8.1.x86_64.rpm %posttrans script:
    Creating initrd: /boot/initrd-4.4.138-59-default
    dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.4.138-59-default 4.4.138-59-default
    dracut: *** Including module: bash ***
    dracut: *** Including module: systemd ***
    dracut: *** Including module: warpclock ***
    dracut: *** Including module: systemd-initrd ***
    dracut: *** Including module: i18n ***
    dracut: Could not find FONT_MAP none!
    dracut: *** Including module: drm ***
    dracut: *** Including module: plymouth ***
    dracut: *** Including module: btrfs ***
    dracut: *** Including module: kernel-modules ***
    ...
    dracut: *** Creating image file '/boot/initrd-4.4.138-59-default' ***
    dracut: *** Creating initramfs image file '/boot/initrd-4.4.138-59-default' done ***
    Creating initrd: /boot/initrd-4.4.76-1-default
    dracut: Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.4.76-1-default 4.4.76-1-default
    dracut: *** Including module: bash ***
    dracut: *** Including module: systemd ***
    dracut: *** Including module: warpclock ***
    dracut: *** Including module: systemd-initrd ***
    dracut: *** Including module: i18n ***
    dracut: Could not find FONT_MAP none!
    dracut: *** Including module: drm ***
    dracut: *** Including module: plymouth ***
    dracut: *** Including module: btrfs ***
    ...
    dracut: root=UUID=280099b6-ac49-4975-8ab1-fe6b7bc265b9 rootfstype=btrfs rootflags=rw,relatime,space_cache,subvolid=259,subvol=/@/.snapshots/1/snapshot,subvol=@/.snapshots/1/snapshot
    dracut: *** Creating image file '/boot/initrd-4.4.76-1-default' ***
    dracut: *** Creating initramfs image file '/boot/initrd-4.4.76-1-default' done ***

  8. #8

    Default Re: nvidia driver install with black screen, kde

    I reinstalled the nvidia driver today. It worked this time.

    Apparently, the driver was fixed. I have the full resolution available to try the full retail LInux port of a retail game.

    Thanks to those to fixed it...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •