Results 1 to 3 of 3

Thread: GTK font rendering problem

  1. #1

    Question GTK font rendering problem

    Hi,

    I installed both KDE and GNOME on leap 15, but I am unable to get "Roboto Medium" font to be rendered as medium. In the attached screenshot, even though I have Medium weight (tested with Black as well) selected, gnome always renders Normal variant. However, all Qt applications are respecting my Roboto Medium settings (configured via KDE settings).

    Please help me fix the font rendering issue. My GTK3 config in
    Code:
    ~/.config/gtk-3.0/settings.ini
    :

    Code:
    gtk-application-prefer-dark-theme=false
    gtk-button-images=1
    gtk-cursor-theme-name=DMZ-Black
    gtk-fallback-icon-theme=breeze-dark
    gtk-font-name=Roboto Medium 12
    gtk-icon-theme-name=breeze
    gtk-menu-images=1
    gtk-primary-button-warps-slider=0
    gtk-theme-name=Breeze
    gtk-toolbar-style=GTK_TOOLBAR_ICONS

    As you can see in the attached screenshot, in the left I have a Qt application (Dolphin) and to the right is Gnome-Tweaks running under Gnome desktop.
    GTK applications even in KDE are not respecting my font settings.

    I see no difference in the font rendering in GTK even when I select Roboto Black. Please help me find the root cause and fix it.

  2. #2

    Default Re: GTK font rendering problem

    On the KDE end look at:

    Menu->Settings->Configure Desktop
    Click Application Style
    Third selection down in the left column is GNOME Application Style (GTK)

    My export|grep gtk also points at a ~/.gtkrc-2.0. (Yeah, I know GTK+2, but worth making sure the font in there matches the one in your INI.)

    If that doesn't help, it is as far as my Google foo got me, but you peaked my curiosity about fonts.

    Anyway, I got the first part from the link below, which states:

    If running KDE Plasma, install kde-gtk-config and either run it from the command line, or go to System Settings > Application Style > GNOME Application Style (GTK). Fonts, icon themes, cursors, and widget styles set in System Settings outside of the GTK configuration module will affect Qt only; GTK settings should be set manually using the previously mentioned module.

    That is really badly worded. so I had to do some interpretation, and it maybe wrong.

    Original link: https://wiki.archlinux.org/index.php...K_applications

    Good luck.
    I don’t have anything to hide, but I don’t have anything I want to show you either.

  3. #3

    Default Re: GTK font rendering problem

    Sorry for the late response, I wasnt notified of replies.

    Quote Originally Posted by d3vnull View Post

    My issue is not just with GTK apps in KDE, but a more fundamental GTK apps in Gnome. They just cant render font style at all. Only default style is being rendered everytime. This is definitely a bug. Should I report it to gnome or opensuse ? See more screenshots in gnome env

    You can compare the four images with two styles each of ubuntu and roboto here: https://postimg.cc/gallery/oiuzjw0o/a70fcef2/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •