Results 1 to 10 of 10

Thread: Services do not restart at boot

  1. #1

    Default Services do not restart at boot

    I go into Yast2 Services managed and enable and start smb. nmb, firewalld. But every time I restart, they are not automatically started. Even worse, the firewalld app does not remember my added ports.
    How do I get my daemons to start on boot, and how do I get the firewall to remember its ports?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,367

    Default Re: Services do not restart at boot

    The YaST > System > Service Manager entries do not only have a checkbox for Start, but also for Enable. Use that to enable the service to be started at boot.
    Henk van Velden

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,869
    Blog Entries
    3

    Default Re: Services do not restart at boot

    Quote Originally Posted by jarome View Post
    ..., and how do I get the firewall to remember its ports?
    When making settings, be sure to toggle firewall-config to "Permanent" instead of "Runtime". Otherwise you only make temporary changes.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,367

    Default Re: Services do not restart at boot

    Quote Originally Posted by nrickert View Post
    When making settings, be sure to toggle firewall-config to "Permanent" instead of "Runtime". Otherwise you only make temporary changes.
    I am not sure this is a separate question about the firewall. The OP does not say he changed something to the firewall configuration .

    I assume that YaST > System > Services Manager will not only start/stop a service, but also open/close posts (that is why we have a good system managers tool, to help you to do those things you might not have thought of).
    Then I assume that on enabling the service, YaST will also make the opened port(s) permanent. Or am I wrong here (I am a bit guessing here, because I have the firewall off).
    Henk van Velden

  5. #5

    Default Re: Services do not restart at boot

    Quote Originally Posted by hcvv View Post
    The YaST > System > Service Manager entries do not only have a checkbox for Start, but also for Enable. Use that to enable the service to be started at boot.
    Both are checked!

  6. #6

    Default Re: Services do not restart at boot

    Quote Originally Posted by nrickert View Post
    When making settings, be sure to toggle firewall-config to "Permanent" instead of "Runtime". Otherwise you only make temporary changes.
    Thanks on that. The new interface is not very intuitive. There is a menu item "change runtime to permanent"
    Who would think to look?

  7. #7

    Default Re: Services do not restart at boot

    Quote Originally Posted by hcvv View Post
    I am not sure this is a separate question about the firewall. The OP does not say he changed something to the firewall configuration .

    I assume that YaST > System > Services Manager will not only start/stop a service, but also open/close posts (that is why we have a good system managers tool, to help you to do those things you might not have thought of).
    Then I assume that on enabling the service, YaST will also make the opened port(s) permanent. Or am I wrong here (I am a bit guessing here, because I have the firewall off).
    I do not think that Services Manager knows the ports of "strange" services like ejabberd, subsonic, openfire,...
    But I still must restart everything at boot, even though both enable and start are checked in systemd. It comes up as enabled, but not started,

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,367

    Default Re: Services do not restart at boot

    Quote Originally Posted by jarome View Post
    I do not think that Services Manager knows the ports of "strange" services like ejabberd, subsonic, openfire,...
    But I still must restart everything at boot, even though both enable and start are checked in systemd. It comes up as enabled, but not started,
    I think your thinking is correct . YaST would not know which ports belong to which service it has never hear off, but is for which there is only a systemd unit.

    To the OP.

    You better provide people here with more information like listings of the systemd units or whatever you think others could use to get a good discussion going on what might be wrong.

    Also the name of those services you kept secret for us might trigger people into saying: Oh, I had that also, but i solved it ....

    More info, more chance that somebody jumps the wagon.
    Henk van Velden

  9. #9

    Default Re: Services do not restart at boot

    What more information do you want?

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,367

    Default Re: Services do not restart at boot

    What about
    Code:
    systemctl status firewalld
    Maybe also forthe others.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •