Results 1 to 6 of 6

Thread: firewalld config timeout when not using YaST

  1. #1

    Default firewalld config timeout when not using YaST

    Anyone else experience this:

    If I run firewalld from YaST I can configure for quite a while without having to re-enter the root credentials.

    If I run firewalld from the KDE menu eventually firewalld will prompt me twice for the root password.

    It is not a big deal. Just wondering if anyone else has observed this behavior.
    I don’t have anything to hide, but I don’t have anything I want to show you either.

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: firewalld config timeout when not using YaST

    Quote Originally Posted by d3vnull View Post
    If I run firewalld from YaST
    If I run firewalld from the KDE menu
    Could you please explain?
    I can start-stop, enable-disable the firewalld daemon from YaST Service Manager, but cannot configure the firewall from YaST.
    From a KDE application launcher I can start firewall-config (via kdesu), but cannot run firewalld.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,381
    Blog Entries
    1

    Default Re: firewalld config timeout when not using YaST

    Quote Originally Posted by eng-int View Post
    I can start-stop, enable-disable the firewalld daemon from YaST Service Manager, but cannot configure the firewall from YaST.
    YaST > Security and Users > Firewall should launch the graphical firewall-config utility (if firewalld is already active).
    openSUSE Leap 15.0; KDE Plasma 5

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: firewalld config timeout when not using YaST

    Quote Originally Posted by deano_ferrari View Post
    YaST > Security and Users > Firewall should launch the graphical firewall-config utility (if firewalld is already active).
    So it does, but only with graphical YaST. I normally use the ncurses version, which displays:
    Code:
    Error
    YaST currently does not have a module for configuring firewall. Please, 
    either use "firewall-config" to configure your firewall via a user interface
    or "firewall-cmd" for the command line.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,381
    Blog Entries
    1

    Default Re: firewalld config timeout when not using YaST

    Quote Originally Posted by eng-int View Post
    So it does, but only with graphical YaST. I normally use the ncurses version, which displays:
    Code:
    Error
    YaST currently does not have a module for configuring firewall. Please, 
    either use "firewall-config" to configure your firewall via a user interface
    or "firewall-cmd" for the command line.
    Right ,there is no ncurses utility at this time, and even the graphical utility is not a YaST module. It's a firewalld utility called by YaST. However, Red Hat/Fedora have system-config-firewall-tui (ncurses utility for firewalld), which might be a good option for openSUSE IMHO...


    https://www.techrepublic.com/article...-ncurses-tool/
    openSUSE Leap 15.0; KDE Plasma 5

  6. #6
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: firewalld config timeout when not using YaST

    Quote Originally Posted by deano_ferrari View Post
    ... However, Red Hat/Fedora have system-config-firewall-tui (ncurses utility for firewalld), which might be a good option for openSUSE IMHO...
    Thanks, I had a quick look at system-config-firewall-tui (which I had been unaware of).
    It seemed less onerous than reading the firewall-cmd man page, but I think that editing “/etc/firewalld/zones/public.xml” with vim (or whatever editor is preferred) is much simpler; that (plus scp) is how I converted our servers from SuSEfirewall2 to firewalld.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •