Results 1 to 4 of 4

Thread: mouse doesn't work properly in KDE unless I log in as root

  1. #1

    Default mouse doesn't work properly in KDE unless I log in as root

    My mouse can't access the KDE menu and it behaves in an intermittent fashion. If I login as root it behaves properly. What's wrong

  2. #2

    Default Re: mouse doesn't work properly in KDE unless I log in as root

    I made myself a member of the input group and I'm no longer having mouse problems. I didn't realize it was necessary.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,261

    Default Re: mouse doesn't work properly in KDE unless I log in as root

    Several thoughts here.

    Do you really mean that you can use the mouse everywhere on the screen (KDE desktop), but that it (the arrow) refuses to go into the KDE main menu item (normally left on the panel), or that you can open the main menu, but that your mouse then does not go into the menu? It sounds strange. Please we can not look over your shoulder, thus a precise description is needed for others to understand what you see.

    It is strongly discouraged to log in into the GUI as root. Whenever you want to check if a desktop problem is bound to a specific user, use another user (not root), that you can specially create for the test to be sure it is all "fresh".

    There should be no need to make a user member of the input group. At least I dot have any user as member of the group input and my KDE works as intended.

    So I am afraid that notwithstanding the fact that you might be satisfied with the result, I think you still have a problem somewhere, that you did not cure, but probably made worse.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,553
    Blog Entries
    1

    Default Re: mouse doesn't work properly in KDE unless I log in as root

    Quote Originally Posted by johnschwartzman View Post
    I made myself a member of the input group and I'm no longer having mouse problems. I didn't realize it was necessary.
    It isn't necessary and doesn't make sense at all.
    openSUSE Leap 15.1; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •