Hello to all guys,

after updating my openSuSE Tumbleweed with zypper dup command Virtualbox does’t work anymore, clicking the icon does not start the program.

I tried removing and reinstalling VirtualBox and extra packages with this proocedure:
1) I reinstalled virtualbox from yast
2) After I reinstalled the extra packages whit:
# zypper in gcc make kernel-devel
3) Finally when I try to upgrading the kernel running:
# /etc/init.d/vboxdrv setup
but I get the following error:
bash: /etc/init.d/vboxdrv: No such file or directory

Anyone have some suggestions?

This is my configuration whit installed packages:

# zypper se -si vbox virtualbox
Loading repository data...
Reading installed packages...
S | Name | Type | Version | Arch | Repository
---+-----------------------------+---------+-----------------------+--------+------------------------
i+ | virtualbox | package | 5.2.12-3.3 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | virtualbox-host-kmp-default | package | 5.2.12_k4.16.12_2-3.3 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | virtualbox-qt | package | 5.2.12-3.3 | x86_64 | openSUSE-Tumbleweed-Oss

# zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.
# | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
--+-------------------------------------+-----------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------+--------
1 | http-download.opensuse.org-04dc211c | science | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
2 | http-ftp.uni-erlangen.de-f181d6a1 | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.uni-erlangen.de/…/packm…/...USE_Tumbleweed |
3 | openSUSE-20180209-0 | openSUSE-20180209-0 | No | ---- | ---- | 99 | yast2 | hd:///?device=/dev/disk/by-id/usb-Lexar_USB_Flash_Drive_AAIMQ0FJ924K93V5-0:0-part2 |
4 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
5 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
6 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
7 | repo-source | openSUSE-Tumbleweed-Source | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/...weed/repo/oss/ |
8 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |
9 | skype-stable | skype (stable) | Yes | (r ) Yes | Yes | 99 | rpm-md | https://repo.skype.com/rpm/stable/

# uname -a
Linux wmtpc01-linux.WMT 4.16.12-2-default #1 SMP PREEMPT Fri May 25 18:40:19 UTC 2018 (39c7522) x86_64 x86_64 x86_64 GNU/Linux

Thanks in advance for any help!
Eno