Results 1 to 6 of 6

Thread: ffmpeg - autocodec error

  1. #1
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default ffmpeg - autocodec error

    Hi.
    I have upgraded my system to Leap 15.

    When I run a command:
    Code:
    ffmpeg -i input.flv otuput.mp4
    I get this error:
    Automatic encoder selection failed for output stream #0:0. Default encoder for format mp4 (codec mpeg4) is probably disabled or this build of ffmpeg does not include that codec. Please choose an encoder manually.
    Error selecting an encoder for stream 0:0
    On my previous system it worked flawlessly.

    My ffmpeg version is 4.0
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: ffmpeg - autocodec error

    Did you subscribe to the packman repo yet? (Some codecs and package switching needed)

    http://www.opensuse-guide.org/codecs.php
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: ffmpeg - autocodec error

    Switching system packages to packman helped, but it downgraded ffmpeg from 4.0 to 3.4.2.

    So it seems that something is broken in new release.
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: ffmpeg - autocodec error

    Quote Originally Posted by GazetaCypr View Post
    Switching system packages to packman helped, but it downgraded ffmpeg from 4.0 to 3.4.2.

    So it seems that something is broken in new release.
    No, that's consistent with the current version in packman....
    Code:
    # zypper se -si ffmpeg
    Loading repository data...
    Reading installed packages...
    
    S  | Name         | Type    | Version           | Arch   | Repository            
    ---+--------------+---------+-------------------+--------+-----------------------
    i+ | ffmpeg       | package | 3.4.2-lp150.3.1   | x86_64 | packman               
    i+ | ffmpegthumbs | package | 17.12.3-lp150.1.1 | x86_64 | openSUSE-Leap-15.0-oss
    openSUSE Leap 15.0; KDE Plasma 5

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,629
    Blog Entries
    3

    Default Re: ffmpeg - autocodec error

    Quote Originally Posted by GazetaCypr View Post
    Switching system packages to packman helped, but it downgraded ffmpeg from 4.0 to 3.4.2.
    I am not seeing 4.0 anywhere. I only see 3.4.2 in either openSUSE repos or packman repo. Maybe you misread something.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: ffmpeg - autocodec error

    ffmpeg 4.0 isn't even out for TW (yet) and I doubt it ever will be officially (by packman) for LEAP 15
    there are a few user builds of 4.0 and a build in the multimedia:libs repo but no patented code can be allowed on OBS so all the builds from
    https://software.opensuse.org/package/ffmpeg
    lack the restricted formats
    the only fully functional version of ffmpeg for LEAP 15.0 is 3.4.2 from packman
    http://packman.links2linux.org/package/ffmpeg/854669
    if you want a fully functional 4.x you'll have to build it your self and seeing how ffmpeg depends on a ton of other packages that's not an easy to do
    you could use packman's 3.4.2 build or upgrade to TW and wait a few days for 4.0 to enter in the packman TW builds or try and build it yourself

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •