Results 1 to 5 of 5

Thread: qjackctl crashes

  1. #1
    Join Date
    May 2009
    Location
    Australia
    Posts
    332

    Default qjackctl crashes

    Hi,
    For unknown reason qjackctl (frontend for jack audio system) started crashing. I started it in the konsole, msg was core dump (Iwonder where).
    I tried to start it under root , the msg was

    QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
    Segmentation fault (core dumped)

    There seams to be something wrong with the ownership (of what ?) ....

    Does anybody have an idea ? .... That would be much appreciated since I would need qjackctl to test a soundcard connection.

    Thanks for your help
    Desktop: CPU: AMD Ryzan 4 core, RAM: 32 GB, SSD 120 GB OS, SSD 480 GB Raid, HD 500 GB , OS: 15.1
    Laptop: Toshiba, AMD 4 core, 8 GB RAM, SSD 500 GB, OS 15.1
    Printer: Brother Color laser , Scanner Epson V370. Main application: Ardour, Jack

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,371

    Default Re: qjackctl crashes

    Quote Originally Posted by otto_oz View Post
    I tried to start it under root , the msg was

    QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
    Segmentation fault (core dumped)

    There seams to be something wrong with the ownership (of what ?) ....
    Only about this part.

    I doubt you should run such an end-user application as root (remember: never run something as root when not really needed). And it seems that the application thinks likewise. The end-user has UID 1000 and root has of course UID 0. Thus better forget about this side path and concentrate on your real problem.
    Henk van Velden

  3. #3
    Join Date
    May 2009
    Location
    Australia
    Posts
    332

    Default Re: qjackctl crashes

    .... sure wrong path but why does an application all of a sudden does not work ?


    and where would I find the core dump.? I cant see what triggered it

    Thanks for your help
    Desktop: CPU: AMD Ryzan 4 core, RAM: 32 GB, SSD 120 GB OS, SSD 480 GB Raid, HD 500 GB , OS: 15.1
    Laptop: Toshiba, AMD 4 core, 8 GB RAM, SSD 500 GB, OS 15.1
    Printer: Brother Color laser , Scanner Epson V370. Main application: Ardour, Jack

  4. #4
    Join Date
    May 2009
    Location
    Australia
    Posts
    332

    Default Re: qjackctl crashes

    Solved ....
    There is in the hidden files of a user ....../.config/mcbc.org/ the file QjackCtl.conf. So I saved/renamed that file as old.conf.

    No hoping when starting qjackctl a new config file will be created with qjackctl working .... and it worked. !!!!!

    So there must be an entry in the conf file which let qjackctl crash.

    anyway it works now
    Desktop: CPU: AMD Ryzan 4 core, RAM: 32 GB, SSD 120 GB OS, SSD 480 GB Raid, HD 500 GB , OS: 15.1
    Laptop: Toshiba, AMD 4 core, 8 GB RAM, SSD 500 GB, OS 15.1
    Printer: Brother Color laser , Scanner Epson V370. Main application: Ardour, Jack

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,371

    Default Re: qjackctl crashes

    Congratulations!

    You could of course compare both files and see if it tells you something. But maybe it never happens again.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •