Results 1 to 3 of 3

Thread: Tumbleweed update question: zypper dup reinstalling deleted packages??

  1. #1

    Default Tumbleweed update question: zypper dup reinstalling deleted packages??

    I am trying to update Tumbleweed using zypper dup --no-allow vendor-change. I have uninstalled some unwanted packages from KDE (gimp, etc.) but zypper dup --no-allow vendor-change wants to reinstall all those packages I have uninstalled.

    How can I update Tumbleweed w/o zypper reinstalling uninstalled packages?

    Thx.
    CGC

  2. #2

    Default Re: Tumbleweed update question: zypper dup reinstalling deleted packages??

    Quote Originally Posted by cgc13b View Post
    I am trying to update Tumbleweed using zypper dup --no-allow vendor-change. I have uninstalled some unwanted packages from KDE (gimp, etc.) but zypper dup --no-allow vendor-change wants to reinstall all those packages I have uninstalled.

    How can I update Tumbleweed w/o zypper reinstalling uninstalled packages?

    Thx.
    CGC
    If you do not want to reinstall them, block them with yast> click on the package> tabu
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Tumbleweed update question: zypper dup reinstalling deleted packages??

    I do believe those are part of an installed pattern and doing a clean dup installs all packages part of that pattern
    that's why I unchecked all installed patterns in yast (it didn't uninstall any packages) I also disable recommended applications in yast software management -> options

    edit
    you could also do what enziosavio suggested and taboo them in yast or lock them in zypper
    Code:
    zypper al <packages_to_lock>
    ps.
    Quote Originally Posted by cgc13b View Post
    I am trying to update Tumbleweed using zypper dup --no-allow vendor-change. I have uninstalled some unwanted packages from KDE (gimp, etc.) but zypper dup --no-allow vendor-change wants to reinstall all those packages I have uninstalled.

    How can I update Tumbleweed w/o zypper reinstalling uninstalled packages?

    Thx.
    CGC
    unless you are using a very old TW snapshot 6+ months you don't need to use --no-allow vendor-change as by default both TW and LEAP 15 use vendor stickiness and will not do a vendor change when calling zypper dup so to upgrade you just need to do
    Code:
    zypper dup
    Last edited by I_A; 16-Jun-2018 at 11:52.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •