Results 1 to 9 of 9

Thread: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

  1. #1

    Default nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    Did a zypper dup earlier, and now after login, for a few seconds I see my network icon on my panel, and I can click on it, and eg turn wifi on or off, or turn netowking on on off

    And then the icon just disappears without trace.

    So, if my wifi was off, then I would not be able to turn it back on, can't turn my network off efgif I want to set a temporary static IP address on my laptop

    I can get it back by running nm-applet in a terminal and then backgrounding it

    But not sure why it disappears in the first place, other than something broke it in the recent update.

    So
    a) you can get round it, as described above

    b) something in the last zypper dup broke it


    I note while I've been typing this, it's disappeared again, So it only shows up in my panel for a few seconds


    And if I don't background it it stays there - aha, until I click on it, whence it disappears again

    Code:
    user@computer:~> nm-applet 
    [1]+  Segmentation fault      (core dumped) nm-applet
    Segmentation fault (core dumped)
    and dmesg tells me

    Code:
    [ 6034.493751] traps: nm-applet[4410] general protection ip:7f025a16b25a sp:7ffe6d46bed0 error:0 in libglib-2.0.so.0.5600.1[7f025a0ff000+116000]

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,264
    Blog Entries
    1

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    Did you reboot since those updates were applied? (I'm not a TW user, but I understand it was a substantial upgrade today.)
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,767
    Blog Entries
    14

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    First please answer Deano's question, then ( I'm no Xfce user, but Tw - KDE and GNOME )

    - Any error messages on the zypper dup?
    - Any repos apart from the stock Tw repos involved?
    Code:
    zypper lr -d
    - Does the issue exist for a newly created user in the same desktop environment?
    - Have you tried to reset the networking?
    Code:
    sudo netconfig update -f && cat /etc/resolv.conf
    Please post the output between CODE tags.
    Last edited by Fraser_Bell; 15-Jun-2018 at 22:45. Reason: Fix Code Tags
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    Firstly, yes, I did reboot, I usually do after a zypper dup, and I also tend to shut my laptop down rather than just suspend it. So it's had several reboots since finishing the update yesterday evening.

    I have tried with a new user, and the new user also gets the seg fault - and of course cannot use nm-applet for long enough to be able to connect to a wifi AP


    There was an issue with netconfig update -f in that the update yesterday seems to have hard-coded my works static search into
    Code:
     /etc/sysconfig/network/config
    
    NETCONFIG_DNS_STATIC_SEARCHLIST="dns-01.wibble.net"
    which I've (redacted above) and manually removed, and re-run

    Code:
    sudo netconfig update -f
    /etc/resolv.conf looks now as I'd expect, with just the two nameserver entries that are provided by my wifi AP



    zypper repos:

    Code:
    sudo zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias               | Name                                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                      | Service
    ---+---------------------+--------------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------------+--------
     1 | Wine                | Wine                                       | No      | ----      | ----    |   97     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Tumbleweed/           |
     2 | dvd                 | dvd                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                      |
     3 | home_Vayun          | Vayun's Home Project (openSUSE_Tumbleweed) | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Vayun/openSUSE_Tumbleweed/               |
     4 | openSUSE-20180120-0 | openSUSE-20180120-0                        | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-TOSHIBA_TransMemory_54B80A3FA788C191E0025070-0:0-part2 |
     5 | packman             | packman                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                      |
     6 | repo-debug          | openSUSE-Tumbleweed-Debug                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                  |
     7 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                                    |
     8 | repo-oss            | openSUSE-Tumbleweed-Oss                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                        |
     9 | repo-source         | openSUSE-Tumbleweed-Source                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/source/tumbleweed/repo/oss/                                 |
    10 | repo-update         | openSUSE-Tumbleweed-Update                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                          |
    Now, there wre some issues with the zypper dup yesterday, in that there were some ghc packages that were required to be downgraded


    Code:
    The following 7 packages are going to be downgraded:
      ghc-array ghc-base ghc-binary ghc-bytestring ghc-containers ghc-deepseq ghc-text
    and it was not able to confirm the checksums of the downloaded package in those cases and asked me to discard them

    I've re-run zypper dup this morning and it has successfully downgraded those packages this time.

    However I don't think haskell is likely to be affecting nm-applet...


    I've tried running a strace on nm-applet but that froze my session when nm-applet tried to roll-down, and I ended up having to Ctrl-Alt-F1 and kill -9 the strace from there...


    I'm just going to try and re-install the package that includes nm-applet, but I'm going to post this first....

  5. #5

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    Unfortunately re-installing NetworkManager-applet does not fix the seg-fault

  6. #6

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    I am experiencing the same issue, nm-applet no longer appears to be running. I have Tumbleweed installed on two systems; a laptop I use for work and my desktop. Both running Xfce 4.12.4.

    On manually start nm-applet on both systems and see the nm-applet tray icon.
    • On the laptop - single clicking on the icon produces a drop down with the familiar networks. nm-applet core dumps (same output as you mentioned above) when I attempt to highlight 'vpn connections' or wait a couple seconds
    • On the desktop - highlighting 'vpn connections' completely halts any keyboard/mouse control I have over the desktop GUI. I see conky continue to update, and I can escape into vtty to kill the nm-applet process to regain control.


    My repos on both systems:
    Code:
    # | Alias                               | Name         | Enabled | GPG Check | Refresh | URI                                                                         --+-------------------------------------+--------------+---------+-----------+---------+-----------------------------------------------------------------------------
    1 | http-download.opensuse.org-66e07ffe | games:openra | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/games:/openra/openSUSE_Tumbleweed/
    2 | packman                             | packman      | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/         
    3 | repo-debug                          | repo-debug   | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/debug                          
    4 | repo-non-oss                        | repo-non-oss | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss                        
    5 | repo-oss                            | repo-oss     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss                            
    6 | repo-update                         | repo-update  | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/tumbleweed/
    I did not notice any errors with zypper dup, and have successfully run it.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    I notice that there's a bug report open on this issue:

    Bug 1097908 - nm-applet seg faults
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    I note that this appears to be fixed now, after an update just now to version 1.8.12-2.1

    Code:
    Information for package NetworkManager-applet:
    ----------------------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                     
    Name           : NetworkManager-applet                       
    Version        : 1.8.12-2.1                                  
    Arch           : x86_64                                      
    Vendor         : openSUSE                                    
    Installed Size : 644.1 KiB

    Regards

  9. #9

    Default Re: nm-applet disappears from panel XFCE4 after a few seconds - after zypper dup today

    Quote Originally Posted by iDominic42 View Post
    I note that this appears to be fixed now, after an update just now to version 1.8.12-2.1

    Code:
    Information for package NetworkManager-applet:
    ----------------------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                     
    Name           : NetworkManager-applet                       
    Version        : 1.8.12-2.1                                  
    Arch           : x86_64                                      
    Vendor         : openSUSE                                    
    Installed Size : 644.1 KiB

    Regards
    Thanks for the update.

    Plus side of this for me is now knowing how to use nmcli

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •