Results 1 to 3 of 3

Thread: Cannot install Mullvad VPN - Dependency issues

  1. #1
    drhedberg NNTP User

    Default Cannot install Mullvad VPN - Dependency issues

    openSUSE Tumbleweed KDE fresh install.

    Downloaded the Mullvad commercial VPN .rpm but instructions are here only for Fedora: https://mullvad.net/en/guides/instal...vad-app-linux/

    Code:
    sudo rpm -i MullvadVPN-2019.7_x86_64.rpm
    Code:
    error: Failed dependencies:
            dbus-libs is needed by mullvad-vpn-2019.7.0-1.x86_64
            libnotify is needed by mullvad-vpn-2019.7.0-1.x86_64
            libnsl is needed by mullvad-vpn-2019.7.0-1.x86_64
    I see libnotify and libnsl are installed in yast but still showing failed dependencies and nothing comes up for dbus. Do I just ignore the warning and install anyway?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,304
    Blog Entries
    2

    Default Re: Cannot install Mullvad VPN - Dependency issues

    Hard to say for sure, but you can choose to ignore and see if it works.

    When installing a Fedora package on TW,
    The problem is perhaps more likely that that the package or file version is not supported because TW uses very recent releases... the package naming convention is usually similar.

    But, there can be more issues related to how the software is written...
    If it's written well using relative paths, then files will be discovered easily on both Feoora and openSUSE, but if fixed paths are used, then that will break the app.

    Bottom line,
    Without details it's not possible to do more than speculate but in the end unless it's a very simple app, it's likely not worth tracking down any problem... it's likely better to just let the app Developers know and let them fix their own problems.

    IMO,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    drhedberg NNTP User

    Smile Re: Cannot install Mullvad VPN - Dependency issues

    I just ignored the warning in Yast, installed it and it's working great! Thanks for your help with this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •