Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Ctrl+backspace not working

  1. #1

    Default Ctrl+backspace not working

    Hello everybody --

    I just installed LEAP 15 with GNOME on an old desktop computer and I have this strange problem: when I hit ctrl+backspace it does not delete the entire word backward, but just a single character. This happens in gedit and Evolution, while in Libreoffice Ctrl+backward acts as I expected (delete a word backward). I can I get the usual behavior in all applications?

    Thanks a lot
    Last edited by Cpedone; 13-Jun-2018 at 10:55. Reason: Did not specify DE

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: Ctrl+backspace not working

    Quote Originally Posted by Cpedone View Post
    Hello everybody --

    I just installed LEAP 15 with GNOME on an old desktop computer and I have this strange problem: when I hit ctrl+backspace it does not delete the entire word backward, but just a single character. This happens in gedit and Evolution, while in Libreoffice Ctrl+backward acts as I expected (delete a word backward). I can I get the usual behavior in all applications?

    Thanks a lot
    The alt+backspace shortcut does that (and I think ctrl+w does similar in most terminals).
    openSUSE Leap 15.1; KDE Plasma 5

  3. #3

    Default Re: Ctrl+backspace not working

    That does not seem to work: Alt-backspace still only deletes one character to the left of the cursor in Evolution and gedit. It does delete the entire word to the left of cursor in Emacs, as expected. I was looking for global keyword shortcuts in the system settings, I see there's the option to add a new one, but I don't know what is the actual command for "delete word backward". Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: Ctrl+backspace not working

    Quote Originally Posted by Cpedone View Post
    That does not seem to work: Alt-backspace still only deletes one character to the left of the cursor in Evolution and gedit. It does delete the entire word to the left of cursor in Emacs, as expected. I was looking for global keyword shortcuts in the system settings, I see there's the option to add a new one, but I don't know what is the actual command for "delete word backward". Thanks!
    I'm not a Gnome user, but on one laptop where I've installed it I found that ctrl+backspace does delete an entire word/string in evolution and gedit. I'm not sure why that's not the case for you. Hopefully, someone else can chime in here.
    openSUSE Leap 15.1; KDE Plasma 5

  5. #5

    Default Re: Ctrl+backspace not working

    The weird thing is that I am a GNOME user, and I've never had this issue. I've got Fedora installed on my laptop and on that machine ctrl-backspace acts as expected... Thanks for the help, hope that someone else have suggestions!

  6. #6

    Unhappy Re: Ctrl+backspace not working

    Bump... Any ideas?

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: Ctrl+backspace not working

    Strangely, after experimenting further I've found that this display manager influences the behaviour here. When I start Gnome with SDDM and launch gedit, then Ctrl-Backspace works to delete the word to the left of the cursor. With GDM as the display manager this does not work.
    Last edited by deano_ferrari; 18-Jun-2018 at 03:25.
    openSUSE Leap 15.1; KDE Plasma 5

  8. #8

    Default Re: Ctrl+backspace not working

    Quote Originally Posted by deano_ferrari View Post
    Strangely, after experimenting further I've found that this display manager influences the behaviour here. When I start Gnome with SDDM and launch gedit, then Ctrl-Backspace works to delete the word to the left of the cursor. With GDM as the display manager this does not work.
    Okay, I managed to find how to change the display manager in YaST... but it seems like there's no SDDM, just Xorg and GDM. I switched from GDM to Xorg, but ctrl-backspace still does not work...

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,547
    Blog Entries
    1

    Default Re: Ctrl+backspace not working

    Quote Originally Posted by Cpedone View Post
    Okay, I managed to find how to change the display manager in YaST... but it seems like there's no SDDM, just Xorg and GDM. I switched from GDM to Xorg, but ctrl-backspace still does not work...
    It won't generally be installed, unless KDE was chosen as desktop. (The package is 'sddm'.)
    openSUSE Leap 15.1; KDE Plasma 5

  10. #10

    Default Re: Ctrl+backspace not working

    Quote Originally Posted by Cpedone View Post
    Okay, I managed to find how to change the display manager in YaST... but it seems like there's no SDDM, just Xorg and GDM. I switched from GDM to Xorg, but ctrl-backspace still does not work...
    SOLVED! For some reason, choosing Xorg as display manager in YaST did not work, but choosing it al login did the trick! Thank you a thousand for your help.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •