Results 1 to 10 of 10

Thread: Scilab 6.0.1 does not start

  1. #1
    Join Date
    Apr 2010
    Location
    Brazil - MG
    Posts
    59

    Default Scilab 6.0.1 does not start

    Hi,

    I have just installed Scilab 6.0.1 (6.0.1-lp150-4.10), but when I tried to run Scilab via applications menu or via command line I received the following message:
    Code:
    :~> scilab
    Picked up _JAVA_OPTIONS:  -Djava.class.path=/usr/share/java/flexdock-1.2.4.jar:/usr/share/java/skinlf-6.7.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/javahelp2.jar:/usr/share/java/lucene-core-6.6.0.jar:/usr/share/java/lucene-core-6.6.0.jar:/usr/share/java/lucene-queryparser-6.6.0.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine.jar:/usr/share/java/jgraphx-3.9.2.jar:/usr/share/scilab//modules/scirenderer/jar/scirenderer.jar:/usr/lib64/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jaf_api.jar:/usr/share/scilab//modules/types/jar/org.scilab.modules.types.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop.jar:/usr/share/java/xmlgraphics-fop.jar:/usr/share/java/saxon9.jar:/usr/share/java/batik-all-1.9.jar:/usr/share/java/xml-commons-jaxp-1.3-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath.jar:/usr/share/scilab//modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/java/ecj.jar:/usr/share/scilab//modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab//modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab//modules/history_manager/jar/org.scilab.modules.history_manager.jar:/usr/share/scilab//modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab//modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab//modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab//modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab//modules/gui/jar/org.scilab.modules.gui.jar:/usr/share/scilab//modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab//modules/renderer/jar/org.scilab.modules.renderer.jar:/usr/share/scilab//modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab//modules/core/jar/org.scilab.modules.core.jar:/usr/share/scilab//modules/scinotes/jar/org.scilab.modules.scinotes.jar:/usr/share/scilab//modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab//modules/graph/jar/org.scilab.modules.graph.jar:/usr/share/scilab//modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab//modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab//modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab//modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab//modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar: -Djava.library.path=/usr/lib64/scilab -Djava.add.modules=java.xml.bind
    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.scilab.modules.jvm.LibraryPath (file:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar) to field java.lang.ClassLoader.sys_paths
    WARNING: Please consider reporting this to the maintainers of org.scilab.modules.jvm.LibraryPath
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    It was not possible to create a Scilab main class. Error:
    Exception in thread "main" java.lang.InternalError: XXX0 profile[1]: GL3bc -> profileImpl GL4bc !!! not mapped 
            at com.jogamp.opengl.GLProfile.computeProfileMap(GLProfile.java:2071)
            at com.jogamp.opengl.GLProfile.initProfilesForDeviceCritical(GLProfile.java:1954)
            at com.jogamp.opengl.GLProfile.initProfilesForDevice(GLProfile.java:1875)
            at com.jogamp.opengl.GLProfile.initProfilesForDefaultDevices(GLProfile.java:1842)
            at com.jogamp.opengl.GLProfile.access$000(GLProfile.java:80)
            at com.jogamp.opengl.GLProfile$1.run(GLProfile.java:230)
            at java.base/java.security.AccessController.doPrivileged(Native Method)
            at com.jogamp.opengl.GLProfile.initSingleton(GLProfile.java:216)
            at com.jogamp.opengl.GLProfile.getProfileMap(GLProfile.java:2297)
            at com.jogamp.opengl.GLProfile.get(GLProfile.java:988)
            at com.jogamp.opengl.GLProfile.getDefault(GLProfile.java:722)
            at com.jogamp.opengl.GLProfile.getDefault(GLProfile.java:733)
            at org.scilab.modules.gui.SwingView.<init>(Unknown Source)
            at org.scilab.modules.gui.SwingView.registerSwingView(Unknown Source)
            at org.scilab.modules.core.Scilab.<init>(Unknown Source)
    
    Scilab could not create Scilab Java Main-Class (we could not find the Scilab main class. Verify if Scilab and third party packages are available).
    I also tried to install using Yast and '1 click install'. In both cases the results are the same. Am I missing something? Should I install the nVidia drivers?

    Thanks for any help.
    Leap 15.0 KDE5.45.0 Gigabyte H97-D3H i7-4790 3.60GHz 16Gb GTX 970 HP LaserJet 1020 Flatron E2350V

  2. #2
    Join Date
    Apr 2010
    Location
    Brazil - MG
    Posts
    59

    Default Re: Scilab 6.0.1 does not start

    Hi again,

    I also tried to download the tarballs 6.0.1, 6.0.1 and 5.5.2 from http://www.scilab.org/en/download/ and install them in /usr/share/scilab-x.x.x/ with the same results...

    Thanks.
    Leap 15.0 KDE5.45.0 Gigabyte H97-D3H i7-4790 3.60GHz 16Gb GTX 970 HP LaserJet 1020 Flatron E2350V

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,304
    Blog Entries
    2

    Default Re: Scilab 6.0.1 does not start

    Your posted stdout with its thrown errors seem pretty clear...

    Scilab apparently is tightening up its security and some things haven't been modified appropriately.

    Find the bugzilla or method to report bugs to Scilab and provide them with what you posted (or simply give them a link to this Forum thread).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Apr 2010
    Location
    Brazil - MG
    Posts
    59

    Default Re: Scilab 6.0.1 does not start

    Quote Originally Posted by tsu2 View Post
    Your posted stdout with its thrown errors seem pretty clear...

    Scilab apparently is tightening up its security and some things haven't been modified appropriately.

    Find the bugzilla or method to report bugs to Scilab and provide them with what you posted (or simply give them a link to this Forum thread).

    TSU
    OK, but I only had this problem with Leap 15.0, even using older versions, like 5.5.2...
    In Leap 42.1 I used 5.5.2 and 6.0.0 versions without problem.

    Should I fill a bug report anyway?
    Leap 15.0 KDE5.45.0 Gigabyte H97-D3H i7-4790 3.60GHz 16Gb GTX 970 HP LaserJet 1020 Flatron E2350V

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,304
    Blog Entries
    2

    Default Re: Scilab 6.0.1 does not start

    Quote Originally Posted by belzonte View Post
    OK, but I only had this problem with Leap 15.0, even using older versions, like 5.5.2...
    In Leap 42.1 I used 5.5.2 and 6.0.0 versions without problem.

    Should I fill a bug report anyway?
    According to your posted log,
    It looks like Scilab is making changes, and it's possible that not all the individual apps have been modified to comply with their new standards.
    So,
    This is likely something that started only very recently (possibly since your last previous install) and depending on their maintenance might even have been resolved already.
    But, the only way to make sure that somebody knows that the apps <you> don't have installed is to file a bug.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6
    Join Date
    Apr 2010
    Location
    Brazil - MG
    Posts
    59

    Default Re: Scilab 6.0.1 does not start

    Hi,

    I apologize for not posting in this thread earlier. I have been quit busy these few past days.

    In my first post I said scilab does not start. I was wrong. The problem is that scilab takes 10 seconds to start after a xterm shows up. Because of this I thought that all the text flowing in the xterm were error/log messages. Looking the scilab.desktop I found the following exec command:
    Code:
    Exec=xterm -title "Scilab launcher: DO NOT CLOSE" -e scilab -f
    So scilab needs this xterm starting first...

    Once starting scilab I noticed that I could not open the ATOMS module manager and nothing happens whe I click on the icons to set Xcos and Preferences...

    I will try to install older scilab-5.5.2 and see if it works fine.

    Thanks!
    Leap 15.0 KDE5.45.0 Gigabyte H97-D3H i7-4790 3.60GHz 16Gb GTX 970 HP LaserJet 1020 Flatron E2350V

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,304
    Blog Entries
    2

    Default Re: Scilab 6.0.1 does not start

    All you describe is all very well,
    But none of that likely relates to the error in what you posted (I'll highlight the important part).
    It's not likely that this can be fixed by the end user, which is why the warning requested you report to Scilab.

    TSU

    :~> scilabPicked up _JAVA_OPTIONS: -Djava.class.path=/usr/share/java/flexdock-1.2.4.jar:/usr/share/java/skinlf-6.7.jar:/usr/share/java/looks.jar:/usr/share/java/commons-logging.jar:/usr/share/java/javahelp2.jar:/usr/share/java/lucene-core-6.6.0.jar:/usr/share/java/lucene-core-6.6.0.jar:/usr/share/java/lucene-queryparser-6.6.0.jar:/usr/share/java/jrosetta-API.jar:/usr/share/java/jrosetta-engine.jar:/usr/share/java/jgraphx-3.9.2.jar:/usr/share/scilab//modules/scirenderer/jar/scirenderer.jar:/usr/lib64/java/jogl2.jar:/usr/share/java/gluegen2-rt.jar:/usr/share/java/jaf_api.jar:/usr/share/scilab//modules/types/jar/org.scilab.modules.types.jar:/usr/share/java/jeuclid-core.jar:/usr/share/java/jlatexmath-fop.jar:/usr/share/java/xmlgraphics-fop.jar:/usr/share/java/saxon9.jar:/usr/share/java/batik-all-1.9.jar:/usr/share/java/xml-commons-jaxp-1.3-apis-ext.jar:/usr/share/java/commons-io.jar:/usr/share/java/xmlgraphics-commons.jar:/usr/share/java/avalon-framework.jar:/usr/share/java/jlatexmath.jar:/usr/share/scilab//modules/helptools/jar/org.scilab.modules.helptools.jar:/usr/share/java/ecj.jar:/usr/share/scilab//modules/jvm/jar/org.scilab.modules.jvm.jar:/usr/share/scilab//modules/commons/jar/org.scilab.modules.commons.jar:/usr/share/scilab//modules/history_manager/jar/org.scilab.modules.history_manager.jar:/usr/share/scilab//modules/completion/jar/org.scilab.modules.completion.jar:/usr/share/scilab//modules/console/jar/org.scilab.modules.console.jar:/usr/share/scilab//modules/localization/jar/org.scilab.modules.localization.jar:/usr/share/scilab//modules/action_binding/jar/org.scilab.modules.action_binding.jar:/usr/share/scilab//modules/gui/jar/org.scilab.modules.gui.jar:/usr/share/scilab//modules/preferences/jar/org.scilab.modules.preferences.jar:/usr/share/scilab//modules/renderer/jar/org.scilab.modules.renderer.jar:/usr/share/scilab//modules/graphic_export/jar/org.scilab.modules.graphic_export.jar:/usr/share/scilab//modules/core/jar/org.scilab.modules.core.jar:/usr/share/scilab//modules/scinotes/jar/org.scilab.modules.scinotes.jar:/usr/share/scilab//modules/xcos/jar/org.scilab.modules.xcos.jar:/usr/share/scilab//modules/graph/jar/org.scilab.modules.graph.jar:/usr/share/scilab//modules/graphic_objects/jar/org.scilab.modules.graphic_objects.jar:/usr/share/scilab//modules/ui_data/jar/org.scilab.modules.ui_data.jar:/usr/share/scilab//modules/javasci/jar/org.scilab.modules.javasci.jar:/usr/share/scilab//modules/history_browser/jar/org.scilab.modules.history_browser.jar:/usr/share/scilab//modules/external_objects_java/jar/org.scilab.modules.external_objects_java.jar: -Djava.library.path=/usr/lib64/scilab -Djava.add.modules=java.xml.bind
    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.scilab.modules.jvm.LibraryPath (file:/usr/share/scilab/modules/jvm/jar/org.scilab.modules.jvm.jar) to field java.lang.ClassLoader.sys_paths
    WARNING: Please consider reporting this to the maintainers of org.scilab.modules.jvm.LibraryPath
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release

    It was not possible to create a Scilab main class. Error:
    Exception in thread "main" java.lang.InternalError: XXX0 profile[1]: GL3bc -> profileImpl GL4bc !!! not mapped
    at com.jogamp.opengl.GLProfile.computeProfileMap(GLProfile.java:2071)
    at com.jogamp.opengl.GLProfile.initProfilesForDeviceCritical(GLProfile.java:1954)
    at com.jogamp.opengl.GLProfile.initProfilesForDevice(GLProfile.java:1875)
    at com.jogamp.opengl.GLProfile.initProfilesForDefaultDevices(GLProfile.java:1842)
    at com.jogamp.opengl.GLProfile.access$000(GLProfile.java:80)
    at com.jogamp.opengl.GLProfile$1.run(GLProfile.java:230)
    at java.base/java.security.AccessController.doPrivileged(Native Method)
    at com.jogamp.opengl.GLProfile.initSingleton(GLProfile.java:216)
    at com.jogamp.opengl.GLProfile.getProfileMap(GLProfile.java:2297)
    at com.jogamp.opengl.GLProfile.get(GLProfile.java:988)
    at com.jogamp.opengl.GLProfile.getDefault(GLProfile.java:722)
    at com.jogamp.opengl.GLProfile.getDefault(GLProfile.java:733)
    at org.scilab.modules.gui.SwingView.<init>(Unknown Source)
    at org.scilab.modules.gui.SwingView.registerSwingView(Unknown Source)
    at org.scilab.modules.core.Scilab.<init>(Unknown Source)
    Scilab could not create Scilab Java Main-Class (we could not find the Scilab main class. Verify if Scilab and third party packages are available)
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8
    Join Date
    Jun 2012
    Location
    Serbia
    Posts
    50

    Default Re: Scilab 6.0.1 does not start

    Hi, it is same for me also. Sciliba 6.0.1, Leap 15.0. Hope it will be resolved soon

  9. #9
    Join Date
    Apr 2010
    Location
    Brazil - MG
    Posts
    59

    Default Re: Scilab 6.0.1 does not start

    Quote Originally Posted by tsu2 View Post
    All you describe is all very well,
    But none of that likely relates to the error in what you posted (I'll highlight the important part).
    It's not likely that this can be fixed by the end user, which is why the warning requested you report to Scilab.
    TSU
    OK. I understand your point of view. I even did write a bug report to bugzilla.scilab.org, but before sending it I decided to try the tarball from the Scilab site (scilab-6.0.1.bin.linux-x86_64.tar.gz).

    It is now installed in /usr/share/ and is working fine with no messages (the xterm is always blank). So I think the problem may be the Leap 15.0 packaging and not a scilab bug.
    The earlier Scilab versions did not use the xterm or at least did not show it up. When I installed 6.0.1 from yast2 this xterm was flooded with messages and I could not set my preferences, my default directory (it always defaults to my home directory) or access ATOMS by clicking on the respective icons.

    I am far from being an expert, so if you still recommend me to fill a bug to bugzilla.scilab.org I will do it.

    Thanks!
    Leap 15.0 KDE5.45.0 Gigabyte H97-D3H i7-4790 3.60GHz 16Gb GTX 970 HP LaserJet 1020 Flatron E2350V

  10. #10
    Join Date
    Apr 2010
    Location
    Brazil - MG
    Posts
    59

    Default Re: Scilab 6.0.1 does not start

    BTW, sorry for not posting the previous message earlier. I am quite busy these days...

    Thanks!
    Leap 15.0 KDE5.45.0 Gigabyte H97-D3H i7-4790 3.60GHz 16Gb GTX 970 HP LaserJet 1020 Flatron E2350V

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •