Results 1 to 9 of 9

Thread: Windows 7 will not boot, openSUSE does

  1. #1

    Default Windows 7 will not boot, openSUSE does

    I just had to replace my boot SSD. I installed Windows 7 on the new one without problem. My backup drive is an old Hitachi HD that has had no problems. I cleaned it out and formatted the drive. Then I partitioned it, giving myself 400 gigs to install Linux.
    I installed openSUSE, server, LEAP. No problems with the install. I am on that now.
    The problem is that I cannot boot into Windows anymore. GRUB2 shows Windows Boot Manager (on /dev/sdb1) in the options and I set that as the default boot. Probe Foreign OS is ON, Fast Boot is OFF, Secure Boot is OFF, and Enable Secure Boot Support in YaST2 is OFF. I have tried that last setting both on and off without change.
    When I try to boot with the Windows Boot Manager I get an error stating "Windows failed to start" with options to Launch Startup Repair or Start Windows Normally. Either option returns me to this screen. When I do the Start Windows Normally it briefly flashes the Windows loading screen (1 or 2 seconds) and then goes back to the error screen.
    I have BIOS set to boot off the drive with Linux on it. When I set it to boot from the SSD that Windows is installed on I get a GRUB2 error. The OS's are installed on seperate drives and Linux did not show any partitions on the Windows drive during install.
    My Windows 7 install disk is from the initial launch of 7 and when I try to use it to "Repair" it errors out with a message that my media is outdated. My machine is using UEFI, which I don't think existed when 7 came out (or the disk just is not loaded with UEFI info).

    I have tried to search for solutions but nothing I found seemed to match my problem. Linux is detecting the other OS, but apparently my Windows Boot Manager is broken and I cant fix it.

    Help?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Windows 7 will not boot, openSUSE does

    7 does not fully support EFI boot so probable was installed using MBR. You probably installed openSUSE in EFI mod. You can not chain between OS's using different boot methods all os must use the same method.. To install in MBR mode you need to boot the install media in that mode. ie select legacy booting in the UEFI/BIOS.

  3. #3

    Default Re: Windows 7 will not boot, openSUSE does

    Quote Originally Posted by gogalthorp View Post
    7 does not fully support EFI boot so probable was installed using MBR. You probably installed openSUSE in EFI mod. You can not chain between OS's using different boot methods all os must use the same method.. To install in MBR mode you need to boot the install media in that mode. ie select legacy booting in the UEFI/BIOS.
    Does this mean I have to re-install openSUSE?
    Also, I cannot find a setting in my BIOS for Legacy Booting. It must be able to boot that way as I have had this MOBO for 4 years running Win7.

    Sorry if the questions seem simple, but I have not installed Linux since Red Hat 6. A lot has changed.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Windows 7 will not boot, openSUSE does

    Quote Originally Posted by mac173173 View Post
    Does this mean I have to re-install openSUSE?
    Also, I cannot find a setting in my BIOS for Legacy Booting. It must be able to boot that way as I have had this MOBO for 4 years running Win7.

    Sorry if the questions seem simple, but I have not installed Linux since Red Hat 6. A lot has changed.
    Can you show us the output of the following?
    Code:
    fdisk -l
    Code:
    blkid
    openSUSE Leap 15.3; KDE Plasma 5

  5. #5

    Default Re: Windows 7 will not boot, openSUSE does

    On 2018-06-07, mac173173 <mac173173@no-mx.forums.microfocus.com> wrote:
    >
    > I just had to replace my boot SSD. I installed Windows 7 on the new one
    > without problem. My backup drive is an old Hitachi HD that has had no
    > problems. I cleaned it out and formatted the drive. Then I partitioned
    > it, giving myself 400 gigs to install Linux.
    > I installed openSUSE, server, LEAP. No problems with the install. I am
    > on that now.
    > The problem is that I cannot boot into Windows anymore. GRUB2 shows
    > Windows Boot Manager (on /dev/sdb1) in the options and I set that as the
    > default boot. Probe Foreign OS is ON, Fast Boot is OFF, Secure Boot is
    > OFF, and Enable Secure Boot Support in YaST2 is OFF. I have tried that
    > last setting both on and off without change.
    > When I try to boot with the Windows Boot Manager I get an error stating
    > "Windows failed to start" with options to Launch Startup Repair or Start
    > Windows Normally. Either option returns me to this screen. When I do the
    > Start Windows Normally it briefly flashes the Windows loading screen (1
    > or 2 seconds) and then goes back to the error screen.
    > I have BIOS set to boot off the drive with Linux on it. When I set it to
    > boot from the SSD that Windows is installed on I get a GRUB2 error. The
    > OS's are installed on seperate drives and Linux did not show any
    > partitions on the Windows drive during install.
    > My Windows 7 install disk is from the initial launch of 7 and when I try
    > to use it to "Repair" it errors out with a message that my media is
    > outdated. My machine is using UEFI, which I don't think existed when 7
    > came out (or the disk just is not loaded with UEFI info).
    >
    > I have tried to search for solutions but nothing I found seemed to match
    > my problem. Linux is detecting the other OS, but apparently my Windows
    > Boot Manager is broken and I cant fix it.
    >
    > Help?


    A few points before you begin:

    - Back up all your data if you haven't already done so.
    - Windows 7 definitely supports UEFI.
    - The Secure Boot option cannot be changed for a given Windows install otherwise it will fail to boot.
    - GNU/Linux can os-probe Windows but not the other way round so you need to fix Windows before GNU/Linux).

    In your position, I would do this:

    1. Back up data onto external media. Operating systems can be replaced; data can't.
    2. Move data onto newly created NTFS partitions on your spinning drive.
    3. Disconnect your spinning drive but leave your SSD connected.
    4. Use the Windows recovery disk to repair your SSD bootloading Windows.
    5. If #4 fails, go to a Windows forum and ask for help (personally I'd reinstall Windows).
    6. Reconnect your spinning drive and disconnect your SSD.
    7. Confirm Leap boots.
    8. If #7 fails, boot using SystemRecoveryCD, remount, chroot, and fix your bootloader.
    9. If #8 fails, come back to this forum and ask for help (personally I'd reinstall openSUSE).
    10. Once Leap boots, reconnect the SSD but set the UEFI to boot from the spinning drive.
    11. Within openSUSE, run os-prober and grub-mkconfig (or just use YaST) to detect Windows.
    12. Reboot and confirm you can reboot into Windows and disable fast boot.


  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Windows 7 will not boot, openSUSE does

    7 can boot EFI but does not support all features like secure boot.

  7. #7

    Default Re: Windows 7 will not boot, openSUSE does

    On 2018-06-07, gogalthorp <gogalthorp@no-mx.forums.microfocus.com> wrote:
    >
    > 7 can boot EFI but does not support all features like secure boot.


    Strange; UEFI SecureBoot was supported by Vista...

    ....ahh, I stand corrected. The infamous KB3133977 patch ...
    https://www.theregister.co.uk/2016/0...sus_windows_7/

  8. #8

    Default Re: Windows 7 will not boot, openSUSE does

    Quote Originally Posted by flymail View Post
    On 2018-06-07, mac173173 <mac173173@no-mx.forums.microfocus.com> wrote:
    A few points before you begin:

    - Back up all your data if you haven't already done so.
    - Windows 7 definitely supports UEFI.
    - The Secure Boot option cannot be changed for a given Windows install otherwise it will fail to boot.
    - GNU/Linux can os-probe Windows but not the other way round so you need to fix Windows before GNU/Linux).

    In your position, I would do this:

    1. Back up data onto external media. Operating systems can be replaced; data can't.
    2. Move data onto newly created NTFS partitions on your spinning drive.
    3. Disconnect your spinning drive but leave your SSD connected.
    4. Use the Windows recovery disk to repair your SSD bootloading Windows.
    5. If #4 fails, go to a Windows forum and ask for help (personally I'd reinstall Windows).
    6. Reconnect your spinning drive and disconnect your SSD.
    7. Confirm Leap boots.
    8. If #7 fails, boot using SystemRecoveryCD, remount, chroot, and fix your bootloader.
    9. If #8 fails, come back to this forum and ask for help (personally I'd reinstall openSUSE).
    10. Once Leap boots, reconnect the SSD but set the UEFI to boot from the spinning drive.
    11. Within openSUSE, run os-prober and grub-mkconfig (or just use YaST) to detect Windows.
    12. Reboot and confirm you can reboot into Windows and disable fast boot.
    Thank you.

    Disconnecting the Leap drive allowed me to get to the boot menu and revert to the last stable state. That got Windows booting again. Unfortunately Leap would not stop hijacking the boot when I plugged the Leap drive back in, so I deleted that partition and will re-install Leap with the Windows drive disconnected. Your advice got me there, so thanks.

    BTW, because you cannot delete or format a partition while the OS is on that partition (the OS cannot delete itself) and I could not boot with the Leap drive plugged in, I had some trouble figuring out how to wipe that partition. I found a tool called Gparted that had a bootable download that did the trick. I know I could have reinstalled Leap over itself, but I wanted to insure I could back up everything in Windows before I went through this again!

  9. #9

    Default Re: Windows 7 will not boot, openSUSE does

    On 2018-06-09, mac173173 <mac173173@no-mx.forums.microfocus.com> wrote:
    > Unfortunately Leap would not stop hijacking the boot when I plugged the
    > Leap drive back in, so I deleted that partition and will re-install Leap
    > with the Windows drive disconnected.


    When installing Leap, you can specify the drive and partition to install the bootloader. I'm 100% confident the openSUSE
    installer will do what it says but not with most other GNU/Linux distros. The only way to be fully sure is by
    disconnecting the drive - and that's a pain if you have NVMe drives...

    > Your advice got me there, so thanks.


    Glad it worked for you. On desktops, I always separate OSs on different drives so each OS can take full responsibility
    of its own bootloader.

    > I found a tool called Gparted that had a bootable
    > download that did the trick.


    I use SystemRescueCD which comes with a very powerful partition program called GNU parted.

    > I know I could have reinstalled Leap over itself, but I wanted to insure I could back up everything in Windows before
    > I went through this again!


    Very sensible. To lose data is unfortunate, but to lose data without backups sounds like carelessness.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •