Hi.
Since upgrading to Leap 15.0 I've been having a bit of trouble with Spotify client (installed as flatpak). Sometimes, and I can't really tell when it is happening specifically, Spotify client won't start. Here is konsole output when it starts successfully:
Code:
filip@norm07:~> flatpak run com.spotify.Client
Could not determine display scale factor, running with default.
/app/extra/bin/spotify: /app/lib/libcurl-gnutls.so.4: no version information available (required by /app/extra/bin/spotify)
Gtk-Message: Failed to load module "canberra-gtk-module"
/app/extra/share/spotify/spotify: /app/lib/libcurl-gnutls.so.4: no version information available (required by /app/extra/share/spotify/spotify)
/proc/self/exe: /app/lib/libcurl-gnutls.so.4: no version information available (required by /proc/self/exe)
Fontconfig warning: "/etc/fonts/fonts.conf", line 5: unknown element "its:rules"
and a lot of other fontconfig warnings and errors which doesn't really matter
And here's output when it won't start
Code:
filip@norm07:~> flatpak run com.spotify.Client
No protocol specified
Could not determine display scale factor, running with default.
/app/extra/bin/spotify: /app/lib/libcurl-gnutls.so.4: no version information available (required by /app/extra/bin/spotify)
Gtk-Message: Failed to load module "canberra-gtk-module"
No protocol specified

(spotify:5): Gtk-WARNING **: cannot open display: :99.0
Traceback (most recent call last):
  File "/app/bin/spotify", line 18, in <module>
    subprocess.check_call(argv)
  File "/usr/lib/python3.5/subprocess.py", line 581, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/app/extra/bin/spotify']' returned non-zero exit status 1
My current workaround for this issue is to reboot and start Spotify as soon as I log in.

Also, out of curiosity, I checked if I can start openTTD (also installed with flatpak) when the problem with Spotify occurs and it says:
Code:
Error: Couldn't find any suitable video driver