Results 1 to 4 of 4

Thread: Storage::Exception

  1. #1
    Join Date
    Dec 2008
    Location
    Belgium
    Posts
    36

    Default Storage::Exception

    Hello ,

    Don't know if this is the right place , but before to file a bug i want some opinion .
    I'm on Tumbleweed with KDE4

    The error :
    yast2 - bootloader app quit with :

    Internal error. Please report a bug report with logs.
    Run save_y2logs to get complete logs.
    Details: Storage::Exception
    Caller: /usr/share/YaST2/lib/y2storage/storage_class_wrapper.rb:260:in `find_by_any_name'
    I tried to do a clean install with import existing disk parts from fstab
    gives an error in
    /
    /usr/share/YaST2/lib/bootloader/bootloader_base or bootloader_factory , this i don't remeber
    with an option to debug in ruby ?

    A few days before , I did change boot grub2 to EFI from regular grub2
    followed some "how to" somewhere , don't remeber the site .

    boot is normal to desktop .

    TIA
    rudi

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Storage::Exception

    1. Do you have a recovery disk for your Tumbleweed?
    I suspect that ti might fix whatever you did. Rescue CD images are listed last here
    https://download.opensuse.org/tumbleweed/iso/

    2. Are you installed on BTRFS?
    If your boot directory is in your root partition (IIRC that's the default, but I'm not in front of a TW now to check), rolling back to a snapshot before your changes might be possible.

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Dec 2008
    Location
    Belgium
    Posts
    36

    Default Re: Storage::Exception

    thanks for response ,

    I recovered from a 42.3 backup image . and went ahead with zypper dup to Tumbleweed .
    Everything is back to normal now .
    Also , now i discovered my usb disk needed a chkdsk /f , probably the culprit .
    I guess this thread can be closed .

    rudi

  4. #4

    Lightbulb Re: Storage::Exception

    Last edited by Fraser_Bell; 28-Aug-2018 at 14:26. Reason: Fix Links: OP Please Do NOT Use HTML tags.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •