Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problems with upgrading Leap 42.3 to Leap 15.0

  1. #1

    Question Problems with upgrading Leap 42.3 to Leap 15.0

    I ran into serious difficulties trying to upgrade Leap 42.3 to Leap 15.0. The installation program stopped shortly before terminating with the message:"Internal error. Please report a bug report with logs. Run save_y2logs to complete logs. Details: Invalid merge argument grub2 for grub2-efi. Caller:/mounts/mp_0001/usr/share/YaST2/lib/bootloader/bootloader_base.rb:72: in "merge". Start the Rubby debugger now and debug the issue. Yes (for experts) No." if you press "yes" a window pops up with the debugger "byebug" for programs written in the computer language "ruby", which should allow you to debug the program "bootloader_base.rb" However if you don't feel competent to do this like me you'll end up with an unbootable version of Leap-15.0.
    I am looking for help. Did anybody in this forum have a similar experience? Can anybody tell me how to use the debugger "byebug" in order to debug the program "bootloader_base.rb" ?
    Last edited by kummerhan; 04-Jun-2018 at 14:45. Reason: some typos

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    I don't know what went wrong.

    The good news: your system is pretty much installed.
    The bad news: it might be unbootable.

    I am assuming that you did exit somehow, and are not just sitting there waiting for advice.

    Boot something. Boot the installer to the rescue system. Or boot live media. Or boot the installer, and use CTRL-ALT-F2 on the license screen (to get a root command line).

    Mount your root partition. I would usually mount that to "/mnt". It might be a command such as
    Code:
    mount /dev/sdaX  /mnt
    Then you can at least try to look around and see what is there.

    Mount something else (could be a USB or something else easily accessible). You could mount at "/mnt/mnt".

    Code:
    cd /mnt/var/log   #### this changes to the "/var/log" in your mounted root partition,
    tar zcf  - /path/to/where/you/mounted/yastlogs.tgz  YaST2
    #### that should create a compressed tar archive of the Yast logs
    cd /   ## move out of the mounted system
    Now unmount whatever you mounted to receive the compressed tar archive
    Code:
    umount /path/to/where/you/mounted
    Then umount your root partition
    Code:
    umount /mnt
    Shutdown
    Code:
    shutdown -h now
    Power-off also works to shutdown. Since you have unmounted those partitions, and you booted from a read-only live system, nothing should be damaged.

    Then report a bug, and upload that compressed tar archive as an attachment.

    After that, my suggestion would be a rescue where you try to manually install booting. Post back if you need guidance on that.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    Oops. A typo.

    I wrote:
    Code:
    tar zcf  - /path/to/where/you/mounted/yastlogs.tgz  YaST2
    But it should be:
    Code:
    tar zcf  /path/to/where/you/mounted/yastlogs.tgz  YaST2
    That "-" does not belong there.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4
    Join Date
    Sep 2012
    Posts
    7,106

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    Quote Originally Posted by kummerhan View Post
    Details: Invalid merge argument grub2 for grub2-efi.
    Sounds like original install was done in BIOS mode and upgrade is attempted in EFI mode.

  5. #5

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    Reply to nrickert: Thank you a lot for your help. I was able to create the file "yastlogs.tgz" and I shall attach it to a bugreport which I shall write as soon as possible. Yes, I also would appreciate any help on trying to install booting from the rescue system. kummerhan

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    Quote Originally Posted by kummerhan View Post
    Yes, I also would appreciate any help on trying to install booting from the rescue system. kummerhan
    The first step is to boot the installer to the rescue system. Before you do that, decide whether you want UEFI booting or legacy MBR booting. If you want UEFI booting, then you need to boot the installer in UEFI mode. Otherwise you need to boot the installer in legacy MBR mode (or CSM -- compatibility support module -- mode). How booting installs depends on how you boot the installer.

    After that: The rescue system should get you to a root command line. If you see a login prompt, then login as root (no password needed for the rescue system).

    Step 1: Mount your root partition at "/mnt". The command will be something like
    Code:
    mount /dev/sdaX /mnt
    but replace "/dev/sdaX" with the proper device name for your root partition. If you are using "btrfs" then you also need to mount the subvolumes. I'll get to that later.

    Step 2: Mount your home partition at "/mnt/home". This isn't strictly necessary, but probably best for consistency.

    Step 3: Some bind mounts:
    Code:
    mount --bind /dev  /mnt/dev
    mount --bind /proc /mnt/proc
    mount --bind /sys /mnt/sys
    Step 4: Go to "chroot" mode with
    Code:
    chroot /mnt
    In effect, this puts you inside your mounted system. Most of what follows has to be done in this chroot mode.

    Step 5: If you are using "btrfs" then:
    Code:
    mount -a
    I think that will mount your "btrfs" subvolumes. It may also mount other file systems that could be needed.

    If you are using UEFI, you also need to make sure that "/boot/efi" is mounted. You can probably check with
    Code:
    ls /boot/efi
    It should have been mounted with that "mount -a" above.

    Step 6: Install grub booting
    Easiest, at this point, might be to use yast. You will get a command line version. And you will want to go the bootloader section.
    If you booted in UEFI mode, be sure to select "grub2-efi" as the bootloader. Otherwise select "grub". Make any other changes, the click "Continue" or "Ok" or "Next" as needed until done.

    If that all works then:

    [code]
    exit #### should exit from chroot mode
    shutdown -r now #### should reboot
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    Thank you for your help. I now posted a bug report (#1096257). Trying to carry out your program I ran into difficulties. I shall post the details later. kummerhan

  8. #8

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    message to nrickert: I followed your instructions to the letter. At first it didn't have the desired effect.. But then I run the upgrade program again and wow !!! it worked Success!!! Thank you so much for your help!!kummerhan

  9. #9

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    Hi,
    I don't know whether to tack my problem on here or start a new thread with the same name!

    I have reached a point where I'm told:
    ===================
    The screen locker is broken and unlocking is not possible anymore.

    In order to unlock, switch to a virtual terminal (eg Ctrl + Alt + F2),
    Login and execute the command
    loginctl unlock-sessions
    Afterwards, switch back to the running session (eg Ctrl + Alt + F7)
    ===================

    I can switch but there is half a cursor on the left of the screen and nothing I type is entered on the screen.

    I tried to login as root with psswd anyway, but there is no response, leaving me only to switch back the 'sessions locked ' message.

    Any suggestions would be much appreciated

    Regards

    Chris

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Problems with upgrading Leap 42.3 to Leap 15.0

    Quote Originally Posted by kummerhan View Post
    But then I run the upgrade program again and wow !!! it worked Success!!!
    I'm glad you have it working.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •