Results 1 to 7 of 7

Thread: Tox.chat has no video

  1. #1
    Join Date
    Jun 2016
    Location
    Ireland
    Posts
    335

    Default Tox.chat has no video

    Hi,

    I try to use Tox.chat https://tox.chat/ but I can't set video from a USB webcam.
    I use Mate desktop.
    toxcore version: 0.2.2
    Qt version: 5.9.4
    My webcam is Philips PCVC730K

    VLC can display the cam video and says about codec
    Codec: Planar 4.2.0 YUV (I421)
    Video resolution: 640x480
    Frame rate : 15
    Color primaries: ITU-R BT.709
    Color transferfunction: sRGB
    When I accept a call the webcam button is grey out.
    When I call from the webcam button, I get a small coloured square without video inside and the following error in the CLI.
    Code:
    [17:36:51.890 UTC] core/coreav.cpp:275 : Debug: "Starting call with 0"
    [17:36:51.890 UTC] audio/backend/openal.cpp:300 : Debug: Opening audio input "Jabra UC VOICE 550a MS Analog Mono"
    [17:36:51.899 UTC] audio/backend/openal.cpp:324 : Debug: Opened audio input "Jabra UC VOICE 550a MS Analog Mono"
    [17:36:51.900 UTC] audio/backend/openal.cpp:246 : Debug: Subscribed to audio input device [ 1 subscriptions ]
    [17:36:51.900 UTC] audio/backend/openal.cpp:341 : Debug: Opening audio output "Jabra UC VOICE 550a MS Digital Stereo (IEC958)"
    [17:36:51.910 UTC] audio/backend/openal.cpp:353 : Debug: Opened audio output "Jabra UC VOICE 550a MS Digital Stereo (IEC958)"
    [17:36:51.916 UTC] audio/backend/openal.cpp:676 : Debug: Audio source 2 created. Sources active: 1
    [17:36:51.916 UTC] video/camerasource.cpp:384 : Debug: Closing device  "none"
    [17:36:51.916 UTC] video/camerasource.cpp:267 : Debug: Opening device  "/dev/video0"
    [17:36:51.916 UTC] platform/camera/v4l2.cpp:205 : Warning: Pixel format not found
    [video4linux2,v4l2 @ 0x7f2300005c20] No such input format: invalid.
    [17:36:51.917 UTC] video/camerasource.cpp:280 : Warning: Failed to open device!
    [17:36:51.917 UTC] video/camerasource.cpp:267 : Debug: Opening device  "/dev/video0"
    [17:36:51.917 UTC] platform/camera/v4l2.cpp:205 : Warning: Pixel format not found
    [video4linux2,v4l2 @ 0x7f2300005d00] No such input format: invalid.
    [17:36:51.917 UTC] video/camerasource.cpp:280 : Warning: Failed to open device!
    [17:36:56.022 UTC] :0 : Warning: QObject::startTimer: Timers cannot be started from another thread
    [17:36:56.184 UTC] widget/form/chatform.cpp:625 : Debug: creating netcam
    [17:36:56.186 UTC] video/netcamview.cpp:86 : Debug: SIZER QRect(0,0 320x240)
    [17:36:56.186 UTC] video/camerasource.cpp:267 : Debug: Opening device  "/dev/video0"
    [17:36:56.186 UTC] platform/camera/v4l2.cpp:205 : Warning: Pixel format not found
    [video4linux2,v4l2 @ 0x7f2300005d00] No such input format: invalid.
    [17:36:56.187 UTC] video/camerasource.cpp:280 : Warning: Failed to open device!
    [17:39:09.874 UTC] core/coreav.cpp:306 : Debug: "Cancelling call with 0"
    [17:39:09.875 UTC] audio/backend/openal.cpp:698 : Debug: Audio source 2 deleted. Sources active: 0
    [17:39:09.876 UTC] audio/backend/openal.cpp:502 : Debug: Closing audio output
    I can't find any setting regarding Pixel format nether in Mate nor in Tox.chat.
    I tried the following
    Code:
    ffmpeg -f avfoundation -list_devices true -i ""
    ffmpeg version 3.4.2 Copyright (c) 2000-2018 the FFmpeg developers
      built with gcc 7 (SUSE Linux)
      configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64  --incdir=/usr/include/ffmpeg --extra-cflags='-fmessage-length=0  -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2  -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables  -fstack-clash-protection -g' --optflags='-fmessage-length=0  -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2  -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables  -fstack-clash-protection -g' --disable-htmlpages --enable-pic  --disable-stripping --enable-shared --disable-static --enable-gpl  --disable-openssl --enable-avresample --enable-libcdio --enable-gnutls  --enable-ladspa --enable-libass --enable-libbluray --enable-libcelt  --enable-libcdio --enable-libdc1394 --enable-libfreetype --enable-libgsm  --enable-libmp3lame --enable-libopenjpeg --enable-libopus  --enable-libpulse --enable-libspeex --enable-libtheora  --enable-libtwolame --enable-libvidstab --enable-libvorbis  --enable-libvpx --enable-libwebp --enable-libzvbi --enable-vaapi  --enable-vdpau --enable-libfdk_aac --enable-nonfree --enable-libx264  --enable-libx265 --enable-libxvid
      libavutil      55. 78.100 / 55. 78.100
      libavcodec     57.107.100 / 57.107.100
      libavformat    57. 83.100 / 57. 83.100
      libavdevice    57. 10.100 / 57. 10.100
      libavfilter     6.107.100 /  6.107.100
      libavresample   3.  7.  0 /  3.  7.  0
      libswscale      4.  8.100 /  4.  8.100
      libswresample   2.  9.100 /  2.  9.100
      libpostproc    54.  7.100 / 54.  7.100
    Unrecognized option 'list_devices'.
    Error splitting the argument list: Option not found
    jp@loja:~> ffmpeg -list_devices true -f dshow -i dummy
    ffmpeg version 3.4.2 Copyright (c) 2000-2018 the FFmpeg developers
      built with gcc 7 (SUSE Linux)
      configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64  --incdir=/usr/include/ffmpeg --extra-cflags='-fmessage-length=0  -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2  -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables  -fstack-clash-protection -g' --optflags='-fmessage-length=0  -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2  -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables  -fstack-clash-protection -g' --disable-htmlpages --enable-pic  --disable-stripping --enable-shared --disable-static --enable-gpl  --disable-openssl --enable-avresample --enable-libcdio --enable-gnutls  --enable-ladspa --enable-libass --enable-libbluray --enable-libcelt  --enable-libcdio --enable-libdc1394 --enable-libfreetype --enable-libgsm  --enable-libmp3lame --enable-libopenjpeg --enable-libopus  --enable-libpulse --enable-libspeex --enable-libtheora  --enable-libtwolame --enable-libvidstab --enable-libvorbis  --enable-libvpx --enable-libwebp --enable-libzvbi --enable-vaapi  --enable-vdpau --enable-libfdk_aac --enable-nonfree --enable-libx264  --enable-libx265 --enable-libxvid
      libavutil      55. 78.100 / 55. 78.100
      libavcodec     57.107.100 / 57.107.100
      libavformat    57. 83.100 / 57. 83.100
      libavdevice    57. 10.100 / 57. 10.100
      libavfilter     6.107.100 /  6.107.100
      libavresample   3.  7.  0 /  3.  7.  0
      libswscale      4.  8.100 /  4.  8.100
      libswresample   2.  9.100 /  2.  9.100
      libpostproc    54.  7.100 / 54.  7.100
    Unrecognized option 'list_devices'.
    Error splitting the argument list: Option not found
    ffmpeg can't find option list_devices, should work https://ffmpeg.org/ffmpeg-all.html#Options-50
    Is it a ffmpeg issue or a tox issue?

    I don't know what to do now.
    Any idea how to fix that ?
    Thanks

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,310

    Default Re: Tox.chat has no video

    Where did you get ffmpeg?? probably should be from packman.

  3. #3
    Join Date
    Jun 2016
    Location
    Ireland
    Posts
    335

    Default Re: Tox.chat has no video

    Quote Originally Posted by gogalthorp View Post
    Where did you get ffmpeg?? probably should be from packman.
    I did the upgrade from 42.3 with bootable USB stick offline, then added Packman, added priority and checked for update.
    It should be from Packman... I checked, it is from Packman

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,484

    Default Re: Tox.chat has no video

    Quote Originally Posted by MrNice View Post
    I did the upgrade from 42.3 with bootable USB stick offline, then added Packman, added priority and checked for update.
    It should be from Packman... I checked, it is from Packman
    I am afraid that it is then still possible you have packages from OSS that should be from Packman. Changing repo priority does not change vendor of already installed [packages.

    Thus, please do the Vendor switch to Packman.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,926
    Blog Entries
    14

    Default Re: Tox.chat has no video

    How did you install the tox client? I get it that you downloaded it from the site? If so, why not use the qtox package from the distro?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jun 2016
    Location
    Ireland
    Posts
    335

    Default Re: Tox.chat has no video

    Quote Originally Posted by hcvv View Post
    I am afraid that it is then still possible you have packages from OSS that should be from Packman. Changing repo priority does not change vendor of already installed [packages.

    Thus, please do the Vendor switch to Packman.
    Sorry for my misunderstanding between repo priority and vendor switch.
    In fact I did just after install vendor switch with Yast and with CLI "zypper dup --from...". So, packages should be from Packman.

    Quote Originally Posted by Knurpht View Post
    How did you install the tox client? I get it that you downloaded it from the site? If so, why not use the qtox package from the distro?
    I didn't install from the site (this was before upgrade to 15.0), I installed qtox from Main.
    Code:
    zypper info qtox
    Loading repository data...
    Reading installed packages...
    
    
    Information for package qtox:
    -----------------------------
    Repository     : Main Repository (OSS)                            
    Name           : qtox                                             
    Version        : 1.14.0-lp150.1.11                                
    Arch           : x86_64                                           
    Vendor         : openSUSE                                         
    Installed Size : 7.2 MiB                                          
    Installed      : Yes                                              
    Status         : up-to-date                                       
    Source package : qtox-1.14.0-lp150.1.11.src                       
    Summary        : Tox client that follows the Tox design guidelines
    Description    :                                                  
        qTox is a Tox client that follows the Tox design
        guidelines.
    Maybe I could look from where all the dependencies are? Do you know the command?

    Edit:
    I open another thread for an issue that could be linked.
    https://forums.opensuse.org/showthre...nd-video-files

  7. #7
    Join Date
    Jun 2016
    Location
    Ireland
    Posts
    335

    Default Re: Tox.chat has no video

    New test with a Toshiba laptop, new install 15.0 on clean HDD. Webcam on USB

    Lean 15.0 qTox can receive video from an Android tablet but can't get the video on his own window and off course can't sent it.

    Started qTox in CLI to show the errors messages when I call.
    Code:
    platform/camera/v4l2.cpp:205 : Warning: Pixel format not found
    No such input format: invalid.
    Warning: Failed to open device!
    See first post for more details

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •