Results 1 to 4 of 4

Thread: Authentication Required - how to get rid of this annoying dialog after every login

  1. #1

    Default Authentication Required - how to get rid of this annoying dialog after every login

    Hi guys,
    This annoying dialog "Authentication Required" started to pop up recently, just after every login to KDE, demanding root password to refresh system repositories.
    After a minute or so it disappears on it's own, followed by a "update failed" tray notification, which also disappears soon. It's not a blocker, just annoying and looking unprofessionally.
    Please, how to get rid of this?

    It must be something to do with KDE/Gnome interoperability because:
    • it started to appear only after I had installed Gnome alongside my primary KDE
    • no Authentication Required pops up when login to Gnome
    • the dialog looks like it is from Gnome (KDE has a differently looking password UI)





    The popup dialog says: "Authentication is required to refresh the system repositories".
    Action: Refresh system repositories
    org.freedesktop.packagekit.system-sources-refresh
    Vendor: The PackageKit project.
    polkit.subject-pid: xxxx
    polkit.caller-pid: xxxx

    I probably need to go to Gnome and disable some service somewhere but I don't know what.
    How to generally disable automatic update check? I can live without it and rely only on manually triggered updates.

    There was perhaps a similar issue discussed in 2014: https://forums.opensuse.org/showthre...-after-startup
    But the solution go to Configure Desktop (in the menu) --> Startup and Shutdown --> Service Manager -> uncheck the box for Apper as there is no more any Apper service or Configure Desktop app.

    Cheers!
    Espinosa

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,609
    Blog Entries
    3

    Default Re: Authentication Required - how to get rid of this annoying dialog after every login

    I don't normally see that.

    Right click on the tray (bottom right). Click on "System Tray Settings". Uncheck the box for "Software Updates".

    No, I don't think that is Gnome related. But you probably did something that caused this. Maybe you went to Yast "Security Center and Hardening" and tightened the permissions.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Authentication Required - how to get rid of this annoying dialog after every login

    Hi nrickert
    Thank you for your helpful answer.

    Right click on the tray (bottom right). Click on "System Tray Settings". Uncheck the box for "Software Updates".
    That did the trick! True, I don't have update check at all but I can live without it. It's mostly s server box. I'll have to look for other solution.

    No, I don't think that is Gnome related
    You are right. I followed the process, entered password, and what followed looked like a standard KDE System Update check.
    Sorry for the confusion, visuals slightly changed from older versions.

    Maybe you went to Yast "Security Center and Hardening" and tightened the permissions.
    Sorry, no. Not knowingly..

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,609
    Blog Entries
    3

    Default Re: Authentication Required - how to get rid of this annoying dialog after every login

    Quote Originally Posted by espinosa_cz View Post
    True, I don't have update check at all but I can live without it. It's mostly s server box. I'll have to look for other solution.
    Run
    Yast Online Update
    from time to time. For a server, I would suggest you run it just before scheduled reboots.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •