Results 1 to 3 of 3

Thread: possible bug in lsblk?

  1. #1

    Default possible bug in lsblk?

    I observe some undesired behaviour when running "lsblk -f" command

    Code:
    ~ lsblk    
    NAME                MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda                   8:0    0 238.5G  0 disk  
    ├─sda1                8:1    0   200M  0 part /boot/efi
    ├─sda2                8:2    0    16G  0 part [SWAP]
    ├─sda3                8:3    0   512M  0 part  
    ├─sda4                8:4    0   512M  0 part  
    ├─sda5                8:5    0   512M  0 part /boot
    └─sda6                8:6    0 220.8G  0 part  
      ├─system-opensuse 254:0    0    30G  0 lvm  /opt
      ├─system-home     254:1    0   120G  0 lvm  /home
      ├─system-arch     254:2    0    30G  0 lvm   
      └─system-kubuntu  254:3    0    30G  0 lvm   
    ~ lsblk -f
    NAME                FSTYPE LABEL UUID MOUNTPOINT
    sda                                    
    ├─sda1                                /boot/efi
    ├─sda2                                [SWAP]
    ├─sda3                                 
    ├─sda4                                 
    ├─sda5                                /boot
    └─sda6                                 
      ├─system-opensuse                   /opt
      ├─system-home                       /home
      ├─system-arch                        
      └─system-kubuntu     
    

    a desired output, as given for example on ubuntu should be
    Code:
    ➜  ~ lsblk -f
    NAME                FSTYPE      LABEL        UUID                                   MOUNTPOINT
    sda                                                                                 
    ├─sda1              vfat                     C585-9DC4                              /boot/efi
    ├─sda2              swap                     e828059b-7c11-4f0e-9f1f-b75b62ebef7a   [SWAP]
    ├─sda3              ext2        ARCH_BOOT    feb73714-657e-46c1-9eb7-49375e7e9b5b   
    ├─sda4              ext2        KUBUNTU_BOOT ac37b0b2-6df9-44ea-9072-7b49cea780c1   /boot
    ├─sda5              ext2                     ac0a5cbf-d6b4-4ab2-b850-662ac492bee5   
    └─sda6              LVM2_member              r5mf6J-GsWU-DOR1-iDzb-LZTC-tLMJ-EWDwOY 
      ├─system-kubuntu  ext4                     66fc7a28-f3d9-4636-ae55-511c1d4c814d   /
      ├─system-home     ext4                     d5f52f9d-fb32-45f0-99fd-a33c36408890   /home
      ├─system-arch     ext4                     9fb29b95-b4fa-4c48-8ea9-c03473e3e9b8   
      └─system-opensuse btrfs                    dee4c375-ecd6-42ee-92bc-5cd86b1f7400

    Is this a bug or a desired behaviour? Running command with "sudo" gives correct output.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,118

    Default Re: possible bug in lsblk?

    Quote Originally Posted by RafalSkolasinski View Post
    Running command with "sudo" gives correct output.
    You mean that running it as a root process gives you what you expected?

    Code:
    man lsblk
    does not explain much more then that there is a default list of columns that will be shown, and it warns that the list may change over versions. But it does not say that that list might be different for root and non-root processes.

    In any case, I am afraid that filing a bug where the documentation says that the default list is not fixed (and please specify the list explicitly with the -o option when you want to be sure) will not really help.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,800
    Blog Entries
    15

    Default Re: possible bug in lsblk?

    Hi
    I would expect it to be desired output since the -f option obtains it's information from the blkid command, this command sits in /usr/sbin so wouldn't expect to work as a user...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •