Results 1 to 2 of 2

Thread: Sutitleeditor and video files

  1. #1
    Join Date
    Jun 2016
    Location
    Ireland
    Posts
    246

    Default Sutitleeditor and video files

    Hi,

    I want to use Subtitleeditor. Installed is 0.54.0-lp150.2.1, from the Main repository OSS
    It uses gstreamer
    Code:
    subtitleeditor --gst-version
    GStreamer Core Library version 1.12.5
    The issue is, when I open a video file, nothing appears in the window.
    I tried a lot of different files (codec, container) included video from camcorder. VLC can play these files fine.

    I started subtitleeditor from terminal to get some error messages but I can seen none.
    Code:
    subtitleeditor --debug-all
    subtitleeditor --gst-debug-level=3
    subtitleeditor --debug-video-player
    Last, I tried Gnome Subtitles. When I open the same files, I get the error message "Internal data stream error" and no video appears.

    It's look an issue on my system but not for VLC nor Totem?

    Your help is welcome.
    Thanks
    Code:
    # zypper lr -d
    Repository priorities in effect:                                                                                                                                                                       (See 'zypper lr -P' for details)
          90 (raised priority)  :  1 repository  
          99 (default priority) :  6 repositories
    
    # | Alias                           | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                | Service
    --+---------------------------------+-----------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------+--------
    1 | download.nvidia.com-leap        | nVidia Graphics Drivers     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.0                     |        
    2 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/  |        
    3 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/             |        
    4 | download.opensuse.org-oss       | Main Repository (OSS)       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/      |        
    5 | download.opensuse.org-oss_1     | Main Update Repository      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss                  |        
    6 | opensuse-guide.org-repo         | Libdvdcss Repository        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/                 |        
    7 | packman                         | packman                     | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/ |        
    
    # zypper se -si gstreamer
    Loading repository data...
    Reading installed packages...
    
    S  | Name                              | Type        | Version           | Arch   | Repository           
    ---+-----------------------------------+-------------+-------------------+--------+----------------------
    i+ | GStreamer Multimedia Codecs       | application |                   | noarch | (System Packages)    
    i+ | PackageKit-gstreamer-plugin       | package     | 1.1.10-lp150.2.1  | x86_64 | Main Repository (OSS)
    i+ | gstreamer                         | package     | 1.12.5-lp150.1.1  | x86_64 | Main Repository (OSS)
    i+ | gstreamer-lang                    | package     | 1.12.5-lp150.1.1  | noarch | Main Repository (OSS)
    i+ | gstreamer-libnice                 | package     | 0.1.14-lp150.1.11 | x86_64 | Main Repository (OSS)
    i  | gstreamer-plugin-cluttergst3      | package     | 3.0.26-lp150.1.2  | x86_64 | Main Repository (OSS)
    i+ | gstreamer-plugins-bad             | package     | 1.12.5-lp150.2.4  | x86_64 | packman              
    i+ | gstreamer-plugins-bad-lang        | package     | 1.12.5-lp150.2.4  | noarch | packman              
    i+ | gstreamer-plugins-bad-orig-addon  | package     | 1.12.5-lp150.2.4  | x86_64 | packman              
    i+ | gstreamer-plugins-base            | package     | 1.12.5-lp150.1.1  | x86_64 | Main Repository (OSS)
    i+ | gstreamer-plugins-base-lang       | package     | 1.12.5-lp150.1.1  | noarch | Main Repository (OSS)
    i+ | gstreamer-plugins-cogl            | package     | 1.22.2-lp150.2.19 | x86_64 | Main Repository (OSS)
    i+ | gstreamer-plugins-farstream       | package     | 0.2.8-lp150.1.11  | x86_64 | Main Repository (OSS)
    i+ | gstreamer-plugins-good            | package     | 1.12.5-lp150.1.1  | x86_64 | Main Repository (OSS)
    i+ | gstreamer-plugins-good-extra      | package     | 1.12.5-lp150.1.1  | x86_64 | Main Repository (OSS)
    i+ | gstreamer-plugins-good-lang       | package     | 1.12.5-lp150.1.1  | noarch | Main Repository (OSS)
    i+ | gstreamer-plugins-libav           | package     | 1.12.5-lp150.3.2  | x86_64 | packman              
    i+ | gstreamer-plugins-ugly            | package     | 1.12.5-lp150.2.1  | x86_64 | packman              
    i+ | gstreamer-plugins-ugly-lang       | package     | 1.12.5-lp150.2.1  | noarch | packman              
    i+ | gstreamer-plugins-ugly-orig-addon | package     | 1.12.5-lp150.2.1  | x86_64 | packman              
    i+ | libgstreamer-1_0-0                | package     | 1.12.5-lp150.1.1  | x86_64 | Main Repository (OSS)
    i+ | libgstreamer-1_0-0-32bit          | package     | 1.12.5-lp150.1.1  | x86_64 | Main Repository (OSS)
    i+ | libgstreamermm-1_0-1              | package     | 1.10.0-lp150.1.3  | x86_64 | Main Repository (OSS)
    i+ | phonon-backend-gstreamer          | package     | 4.9.0-lp150.1.12  | x86_64 | Main Repository (OSS)
    i+ | vlc-codec-gstreamer               | package     | 3.0.2-lp150.3.1   | x86_64 | packman

  2. #2
    Join Date
    Jun 2016
    Location
    Ireland
    Posts
    246

    Default [FIXED]Re: Sutitleeditor and video files

    At least I found the solution.

    The issue is due to the bad auto selection of the output.
    Go to Menu > Options > Preferences > Video Player tab > Output > Select X Window System (X11/XShm/Xv).

    Voila!

    Hope this will help others.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •