Page 1 of 5 123 ... LastLast
Results 1 to 10 of 43

Thread: unable to browse to smb shares using dolphin

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,534

    Default unable to browse to smb shares using dolphin

    have struck an unusual problem with a fresh install of leap 15

    in dolphin, if I type the location of my nas shares (smb://ipaddress . . .) I can access my shares without problem.
    However, if I try to browse to the shares using the network > samba shares link in dolphin's Places I am presented with the message "Unable to find any workgroups in your local network. This might be caused by an enabled firewall." I get this message whether the firewall is active or not.
    I have samaba ports opened up in my firewall - as already mentioned - I can access my shares if I type the ip addres directly into dolphin.

    this is my smb.conf


    Code:
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    [global]
    workgroup = farcusnet
    name resolve order = bcast host lmhosts wins
    netbios name = suselaptop
    passdb backend = tdbsam
    local master = yes
    preferred master = yes
    os level = 64
    server string = 
    printcap name = cups
    cups options = raw
    use client driver = yes
    map to guest = Bad User
    usershare allow guests = No
    appreciate any help
    Mark F.
    openSUSE Leap 15.0 / Plasma 5.12



  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,534

    Default Re: unable to browse to smb shares using dolphin

    I see someone has posted the same issue as me in this thread with no solution as yet.
    Mark F.
    openSUSE Leap 15.0 / Plasma 5.12



  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    18,370
    Blog Entries
    1

    Default Re: unable to browse to smb shares using dolphin

    Quote Originally Posted by farcusnz View Post
    I see someone has posted the same issue as me in this thread with no solution as yet.
    See my reply there with some links to pages discussing the same issue. There is a workaround mentioned (involving setting the 'client max protocol' to NT1 in smb.conf), but not an ideal one IMHO.
    Last edited by deano_ferrari; 03-Jun-2018 at 21:18.
    openSUSE Leap 15.0; KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    18,370
    Blog Entries
    1

    Default Re: unable to browse to smb shares using dolphin

    Another similar discussion here...
    https://www.linuxquestions.org/quest...ng-4175624745/
    openSUSE Leap 15.0; KDE Plasma 5

  5. #5
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    399

    Default Re: unable to browse to smb shares using dolphin

    I saw that problem from February. I did not think that is an openSUSE problem. I have tried more KDE distributions (in a VM) - they have the same problem. I think that is a KDE issue.

  6. #6
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,534

    Default Re: unable to browse to smb shares using dolphin

    Quote Originally Posted by deano_ferrari View Post
    See my reply there with some links to pages discussing the same issue. There is a workaround mentioned (involving setting the 'client max protocol' to NT1 in smb.conf), but not an ideal one IMHO.
    Thanks . . .adding that line to smb.conf discovery works again in dolphin. However, it doesn't really solve the problem . . .
    I am trying to link to my NAS (Buffalo Linkstation) but using client discovery, while it shows the drive in dolphin, if I try to access it using that link I get the message
    Could not connect to host for smb://ls-chl/
    the difference here is that it is using the client name rather than the ip address - so there still appears to be something wrong with samba trying to connect using client name.
    Mark F.
    openSUSE Leap 15.0 / Plasma 5.12



  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    18,370
    Blog Entries
    1

    Default Re: unable to browse to smb shares using dolphin

    Quote Originally Posted by farcusnz View Post
    Thanks . . .adding that line to smb.conf discovery works again in dolphin. However, it doesn't really solve the problem . . .
    I am trying to link to my NAS (Buffalo Linkstation) but using client discovery, while it shows the drive in dolphin, if I try to access it using that link I get the message

    the difference here is that it is using the client name rather than the ip address - so there still appears to be something wrong with samba trying to connect using client name.
    Can you ping the device by it's hostname? If I were you, I'd consider moving away from using discovery, and just create a permanent link to your NAS device in the Places menu perhaps.
    Last edited by deano_ferrari; 03-Jun-2018 at 23:40.
    openSUSE Leap 15.0; KDE Plasma 5

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    18,370
    Blog Entries
    1

    Default Re: unable to browse to smb shares using dolphin

    Have you investigated using a different protocol to access your NAS device?
    http://www.marcusfolkesson.se/take-c...station-nas-2/
    If you can get SFTP working on it (along with Avahi), then Dolphin can cope with that too. Better for non-Windows clients IMO.
    openSUSE Leap 15.0; KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,534

    Default Re: unable to browse to smb shares using dolphin

    Quote Originally Posted by deano_ferrari View Post
    Can you ping the device by it's hostname? If I were you, I'd consider moving away from using discovery, and just create a permanent link to your NAS device in the Places menu perhaps.
    I have two linkstations - an older ls-chl and also a ls200 (same as in your link for adding sftp).
    the lack of discovery isn't really a problem as I have permanent links to them on my desktop for quick access.
    I've noticed that discovery also appears to be a problem on my raspberry pi (running OSMC / Kodi) so it appears to be a wider samba issue than just openSUSE.

    btw . . . beginner question but how would I ping the host name over smb? (ping ls-chl)?
    Mark F.
    openSUSE Leap 15.0 / Plasma 5.12



  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    18,370
    Blog Entries
    1

    Default Re: unable to browse to smb shares using dolphin

    I was just wondering if you could resolve/ping that hostname...
    Code:
    ping ls-chl
    openSUSE Leap 15.0; KDE Plasma 5

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •