Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: repos problem

  1. #1
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default repos problem

    Hi
    Every time I try to update the system I get this message:
    Code:
     $ sudo zypper update
    No se encuentra el archivo /repodata/repomd.xml en el medio http://download.opensuse.org/distribution/leap/42.3/repo/oss/
    ¿Cancelar, reintentar o ignorar? [a/r/i/...? mostrar todas las opciones] (a):
    And in Yast I have:
    https://drive.google.com/open?id=1aXyPo4IAmGpgVQNFa6Wuhblw0hzGOKF8

    Can you help me fix this?

    Thanks!
    Last edited by jazmiel; 02-Jun-2018 at 07:26. Reason: the link extended 'til the end of message

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: repos problem

    I'm getting a 404 on your link. And I don't speak the language of your error message.

    However: I occasionally run into what is probably the same problem. The repo was probably being updated at around the time you were trying to use it. I suggest you wait a few hours, and then try again.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,742

    Default Re: repos problem

    And when you do this (as root) of course):
    Code:
    LANG=C zypper up
    most of us will understand better.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: repos problem

    A thing you can do:
    Code:
    sudo zypper clean
    sudo zypper ref
    sudo zypper up
    That would clean out cached data, get the content of the repos, then try to perform the update.

    A thing to consider would be to find a mirror close to where you live
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: repos problem

    most definitely a mirror issue if the issue persists you should pick a different mirror preferably one in your isp's network or country
    you need to link to a file to get a mirror list you can't do it with a directory so I picked the README file
    https://download.opensuse.org/distri...DME?mirrorlist
    if there's no mirror in your country pick one of the German mirrors as they're up most of the time they're fast and reliable like
    ftp://ftp.gwdg.de/pub/opensuse/distr...42.3/repo/oss/
    you can edit a repo's url in yast or with zypper

  6. #6
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default Re: repos problem

    Thank you for all of your replies.
    The mesage I obtain is this:
    Code:
    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/leap/42.3/repo/oss/'
    Abort, retry, ignore? [a/r/i/...? shows all options] (a):
    This my YaST repositories:
    https://drive.google.com/open?id=1aXyPo4IAmGpgVQNFa6Wuhblw0hzGOKF8

    What is in order to do? Thanks


  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: repos problem

    You can at least remove one of the Packman repos. Check for other duplicates too. But the list itself shouldn't be the problem. Did you try the suggestion I gave you?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default Re: repos problem

    Quote Originally Posted by Knurpht View Post
    You can at least remove one of the Packman repos. Check for other duplicates too. But the list itself shouldn't be the problem. Did you try the suggestion I gave you?
    Thanks, I removed one of packman's. I had tried what you suggested, and repeated it, but still have the same message:
    Code:
    # zypper ref
    Repository 'VLC' is up to date.                                                 
    Repository 'The latest official release of MATE (openSUSE_Leap_42.3)' is up to d
                                                                                    
    Repository 'Repositorio principal (NON-OSS)' is up to date.                     
    Repository 'Repositorio de actualizaciones (No OpenSource)' is up to date.      
    Repository 'Repositorio principal (OSS)' is up to date.                         
    Repository 'Packman Repository' is up to date.                                  
    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/leap/42.3/repo/oss/'
    Abort, retry, ignore? [a/r/i/...? shows all options] (a):
    What can I try?

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,742

    Default Re: repos problem

    When you look with your browser to that URL http://download.opensuse.org/distrib...42.3/repo/oss/ you will see thatthere is indeed bo /repodata there. When you compare with the repos of non-OSS in your repo list, you will see that there there is /suse at the end. And when you look into http://download.opensuse.org/distrib.../repo/oss/suse you will see that there is a /repodata there.

    So better change you OSS repo by adding /suse and try again.
    Henk van Velden

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: repos problem

    download.opensuse.org is a redirector, which redirects to a mirror near by you.
    Maybe this mirror has problems.

    Use another:
    https://mirrors.opensuse.org/

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •